<!DOCTYPE html>
<html class="no-js" lang="en-US">
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<link rel="profile" href="https://gmpg.org/xfn/11" />
<link rel="pingback" href="https://www.ostechnix.com/xmlrpc.php">
<script>document.documentElement.className = document.documentElement.className.replace("no-js","js");</script>

<title>How To List All Users In Linux - OSTechNix</title>
<meta name="description" content="Since Linux is a multi-user operating system, it may consists of more than one user. This brief guide explains how to list all users in Linux." />
<meta name="robots" content="index, follow" />
<meta name="googlebot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
<meta name="bingbot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
<link rel="canonical" href="https://www.ostechnix.com/how-to-list-all-users-in-linux/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="How To List All Users In Linux - OSTechNix" />
<meta property="og:description" content="Since Linux is a multi-user operating system, it may consists of more than one user. This brief guide explains how to list all users in Linux." />
<meta property="og:url" content="https://www.ostechnix.com/how-to-list-all-users-in-linux/" />
<meta property="og:site_name" content="OSTechNix" />
<meta property="article:publisher" content="https://www.facebook.com/ostechnix/" />
<meta property="article:published_time" content="2020-05-16T14:21:07+00:00" />
<meta property="og:image" content="https://www.ostechnix.com/wp-content/uploads/2020/05/List-All-Users-In-Linux.png" />
<meta property="og:image:width" content="800" />
<meta property="og:image:height" content="450" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:creator" content="@ostechnix" />
<meta name="twitter:site" content="@ostechnix" />
<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://www.ostechnix.com/#organization","name":"OSTechNix","url":"https://www.ostechnix.com/","sameAs":["https://www.facebook.com/ostechnix/","https://in.linkedin.com/in/ostechnix","https://twitter.com/ostechnix"],"logo":{"@type":"ImageObject","@id":"https://www.ostechnix.com/#logo","inLanguage":"en-US","url":"https://www.ostechnix.com/wp-content/uploads/2016/10/OSTechNix_280915-01.png","width":3333,"height":1667,"caption":"OSTechNix"},"image":{"@id":"https://www.ostechnix.com/#logo"}},{"@type":"WebSite","@id":"https://www.ostechnix.com/#website","url":"https://www.ostechnix.com/","name":"OSTechNix","description":"Open Source - Technology - Linux And Unix","publisher":{"@id":"https://www.ostechnix.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":"https://www.ostechnix.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://www.ostechnix.com/how-to-list-all-users-in-linux/#primaryimage","inLanguage":"en-US","url":"https://www.ostechnix.com/wp-content/uploads/2020/05/List-All-Users-In-Linux.png","width":800,"height":450},{"@type":"WebPage","@id":"https://www.ostechnix.com/how-to-list-all-users-in-linux/#webpage","url":"https://www.ostechnix.com/how-to-list-all-users-in-linux/","name":"How To List All Users In Linux - OSTechNix","isPartOf":{"@id":"https://www.ostechnix.com/#website"},"primaryImageOfPage":{"@id":"https://www.ostechnix.com/how-to-list-all-users-in-linux/#primaryimage"},"datePublished":"2020-05-16T14:21:07+00:00","dateModified":"2020-05-16T14:21:07+00:00","description":"Since Linux is a multi-user operating system, it may consists of more than one user. This brief guide explains how to list all users in Linux.","inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://www.ostechnix.com/how-to-list-all-users-in-linux/"]}]},{"@type":"Article","@id":"https://www.ostechnix.com/how-to-list-all-users-in-linux/#article","isPartOf":{"@id":"https://www.ostechnix.com/how-to-list-all-users-in-linux/#webpage"},"author":{"@id":"https://www.ostechnix.com/#/schema/person/e4f4cd4c175ef6a91695a056cbaed01a"},"headline":"How To List All Users In Linux","datePublished":"2020-05-16T14:21:07+00:00","dateModified":"2020-05-16T14:21:07+00:00","commentCount":0,"mainEntityOfPage":{"@id":"https://www.ostechnix.com/how-to-list-all-users-in-linux/#webpage"},"publisher":{"@id":"https://www.ostechnix.com/#organization"},"image":{"@id":"https://www.ostechnix.com/how-to-list-all-users-in-linux/#primaryimage"},"keywords":"Linux,Linux commands,Linux user management","articleSection":"FAQ,Linux,Linux Admnistration,Linux Basics,Linux Commands,Linux Tips &amp; Tricks,Tips and Tricks,Unix/Linux Beginners","inLanguage":"en-US","potentialAction":[{"@type":"CommentAction","name":"Comment","target":["https://www.ostechnix.com/how-to-list-all-users-in-linux/#respond"]}]},{"@type":["Person"],"@id":"https://www.ostechnix.com/#/schema/person/e4f4cd4c175ef6a91695a056cbaed01a","name":"sk","image":{"@type":"ImageObject","@id":"https://www.ostechnix.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/82930172130088777d42141847e45c10?s=96&d=mm&r=g","caption":"sk"}}]}</script>

<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="OSTechNix &raquo; Feed" href="https://www.ostechnix.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="OSTechNix &raquo; Comments Feed" href="https://www.ostechnix.com/comments/feed/" />
<link id="hu-user-gfont" href="//fonts.googleapis.com/css?family=Ubuntu:400,400italic,300italic,300,700&subset=latin,latin-ext" rel="stylesheet" type="text/css"><link rel="alternate" type="application/rss+xml" title="OSTechNix &raquo; How To List All Users In Linux Comments Feed" href="https://www.ostechnix.com/how-to-list-all-users-in-linux/feed/" />

<script type="text/javascript" data-cfasync="false">
	var em_version         = '6.0.2';
	var em_track_user      = true;
	var em_no_track_reason = '';
	
	var disableStr = 'ga-disable-UA-75259810-1';

	/* Function to detect opted out users */
	function __gaTrackerIsOptedOut() {
		return document.cookie.indexOf(disableStr + '=true') > -1;
	}

	/* Disable tracking if the opt-out cookie exists. */
	if ( __gaTrackerIsOptedOut() ) {
		window[disableStr] = true;
	}

	/* Opt-out function */
	function __gaTrackerOptout() {
	  document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
	  window[disableStr] = true;
	}

	if ( 'undefined' === typeof gaOptout ) {
		function gaOptout() {
			__gaTrackerOptout();
		}
	}
	
	if ( em_track_user ) {
		(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
		})(window,document,'script','//www.google-analytics.com/analytics.js','__gaTracker');

window.ga = __gaTracker;		__gaTracker('create', 'UA-75259810-1', 'auto');
		__gaTracker('set', 'forceSSL', true);
		__gaTracker('send','pageview');
		__gaTracker( function() { window.ga = __gaTracker; } );
	} else {
		console.log( "" );
		(function() {
			/* https://developers.google.com/analytics/devguides/collection/analyticsjs/ */
			var noopfn = function() {
				return null;
			};
			var noopnullfn = function() {
				return null;
			};
			var Tracker = function() {
				return null;
			};
			var p = Tracker.prototype;
			p.get = noopfn;
			p.set = noopfn;
			p.send = noopfn;
			var __gaTracker = function() {
				var len = arguments.length;
				if ( len === 0 ) {
					return;
				}
				var f = arguments[len-1];
				if ( typeof f !== 'object' || f === null || typeof f.hitCallback !== 'function' ) {
					console.log( 'Not running function __gaTracker(' + arguments[0] + " ....) because you are not being tracked. " + em_no_track_reason );
					return;
				}
				try {
					f.hitCallback();
				} catch (ex) {

				}
			};
			__gaTracker.create = function() {
				return new Tracker();
			};
			__gaTracker.getByName = noopnullfn;
			__gaTracker.getAll = function() {
				return [];
			};
			__gaTracker.remove = noopfn;
			window['__gaTracker'] = __gaTracker;
			window.ga = __gaTracker;		})();
		}
</script>

<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.ostechnix.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.4.1"}};
			/*! This file is auto-generated */
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='font-customizer-style-css' href='https://www.ostechnix.com/wp-content/themes/hueman-pro/addons/pro/wfc/front/assets/css/font_customizer.min.css?ver=3.1.0' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css' href='https://www.ostechnix.com/wp-includes/css/dist/block-library/style.min.css?ver=5.4.1' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='responsive-lightbox-swipebox-css' href='https://www.ostechnix.com/wp-content/plugins/responsive-lightbox/assets/swipebox/swipebox.min.css?ver=2.2.2' type='text/css' media='all' />
<link rel='stylesheet' id='hph-front-style-css' href='https://www.ostechnix.com/wp-content/themes/hueman-pro/addons/assets/front/css/hph-front.min.css?ver=1.2.9' type='text/css' media='all' />
<link rel='stylesheet' id='hueman-main-style-css' href='https://www.ostechnix.com/wp-content/themes/hueman-pro/assets/front/css/main.min.css?ver=1.2.9' type='text/css' media='all' />
<style id='hueman-main-style-inline-css' type='text/css'>
body { font-family:'Ubuntu', Arial, sans-serif;font-size:1.13rem }@media only screen and (min-width: 720px) {
        .nav > li { font-size:1.13rem; }
      }::selection { background-color: #3b8dbd; }
::-moz-selection { background-color: #3b8dbd; }a,a+span.hu-external::after,.themeform label .required,#flexslider-featured .flex-direction-nav .flex-next:hover,#flexslider-featured .flex-direction-nav .flex-prev:hover,.post-hover:hover .post-title a,.post-title a:hover,.sidebar.s1 .post-nav li a:hover i,.content .post-nav li a:hover i,.post-related a:hover,.sidebar.s1 .widget_rss ul li a,#footer .widget_rss ul li a,.sidebar.s1 .widget_calendar a,#footer .widget_calendar a,.sidebar.s1 .alx-tab .tab-item-category a,.sidebar.s1 .alx-posts .post-item-category a,.sidebar.s1 .alx-tab li:hover .tab-item-title a,.sidebar.s1 .alx-tab li:hover .tab-item-comment a,.sidebar.s1 .alx-posts li:hover .post-item-title a,#footer .alx-tab .tab-item-category a,#footer .alx-posts .post-item-category a,#footer .alx-tab li:hover .tab-item-title a,#footer .alx-tab li:hover .tab-item-comment a,#footer .alx-posts li:hover .post-item-title a,.comment-tabs li.active a,.comment-awaiting-moderation,.child-menu a:hover,.child-menu .current_page_item > a,.wp-pagenavi a{ color: #3b8dbd; }input[type="submit"],.themeform button[type="submit"],.sidebar.s1 .sidebar-top,.sidebar.s1 .sidebar-toggle,#flexslider-featured .flex-control-nav li a.flex-active,.post-tags a:hover,.sidebar.s1 .widget_calendar caption,#footer .widget_calendar caption,.author-bio .bio-avatar:after,.commentlist li.bypostauthor > .comment-body:after,.commentlist li.comment-author-admin > .comment-body:after{ background-color: #3b8dbd; }.post-format .format-container { border-color: #3b8dbd; }.sidebar.s1 .alx-tabs-nav li.active a,#footer .alx-tabs-nav li.active a,.comment-tabs li.active a,.wp-pagenavi a:hover,.wp-pagenavi a:active,.wp-pagenavi span.current{ border-bottom-color: #3b8dbd!important; }.sidebar.s2 .post-nav li a:hover i,
.sidebar.s2 .widget_rss ul li a,
.sidebar.s2 .widget_calendar a,
.sidebar.s2 .alx-tab .tab-item-category a,
.sidebar.s2 .alx-posts .post-item-category a,
.sidebar.s2 .alx-tab li:hover .tab-item-title a,
.sidebar.s2 .alx-tab li:hover .tab-item-comment a,
.sidebar.s2 .alx-posts li:hover .post-item-title a { color: #82b965; }
.sidebar.s2 .sidebar-top,.sidebar.s2 .sidebar-toggle,.post-comments,.jp-play-bar,.jp-volume-bar-value,.sidebar.s2 .widget_calendar caption{ background-color: #82b965; }.sidebar.s2 .alx-tabs-nav li.active a { border-bottom-color: #82b965; }
.post-comments::before { border-right-color: #82b965; }
      .search-expand,
              #nav-topbar.nav-container { background-color: #00aeef}@media only screen and (min-width: 720px) {
                #nav-topbar .nav ul { background-color: #00aeef; }
              }.is-scrolled #header .nav-container.desktop-sticky,
              .is-scrolled #header .search-expand { background-color: #00aeef; background-color: rgba(0,174,239,0.90) }.is-scrolled .topbar-transparent #nav-topbar.desktop-sticky .nav ul { background-color: #00aeef; background-color: rgba(0,174,239,0.95) }#header { background-color: #eaeaea; }
@media only screen and (min-width: 720px) {
  #nav-header .nav ul { background-color: #eaeaea; }
}
        .is-scrolled #header #nav-mobile { background-color: #454e5c; background-color: rgba(69,78,92,0.90) }#nav-header.nav-container, #main-header-search .search-expand { background-color: #ef4423; }
@media only screen and (min-width: 720px) {
  #nav-header .nav ul { background-color: #ef4423; }
}
        .site-title a img { max-height: 120px; }body { background-color: #eaeaea; }
</style>
<link rel='stylesheet' id='theme-stylesheet-css' href='https://www.ostechnix.com/wp-content/themes/ostechnix_child_theme/style.css?ver=1.0' type='text/css' media='all' />
<link rel='stylesheet' id='hueman-font-awesome-css' href='https://www.ostechnix.com/wp-content/themes/hueman-pro/assets/front/css/font-awesome.min.css?ver=1.2.9' type='text/css' media='all' />
<link rel='stylesheet' id='social-logos-css' href='https://www.ostechnix.com/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css?ver=1' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css' href='https://www.ostechnix.com/wp-content/plugins/jetpack/css/jetpack.css?ver=8.5' type='text/css' media='all' />
<script>if (document.location.protocol != "https:") {document.location = document.URL.replace(/^http:/i, "https:");}</script><script type='text/javascript' src='https://www.ostechnix.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://www.ostechnix.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var exactmetrics_frontend = {"js_events_tracking":"true","download_extensions":"zip,mp3,mpeg,pdf,docx,pptx,xlsx,rar","inbound_paths":"[{\"path\":\"\\\/go\\\/\",\"label\":\"affiliate\"},{\"path\":\"\\\/recommend\\\/\",\"label\":\"affiliate\"}]","home_url":"https:\/\/www.ostechnix.com","hash_tracking":"false"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.ostechnix.com/wp-content/plugins/google-analytics-dashboard-for-wp/assets/js/frontend.min.js?ver=6.0.2'></script>
<script type='text/javascript' src='https://www.ostechnix.com/wp-content/plugins/responsive-lightbox/assets/swipebox/jquery.swipebox.min.js?ver=2.2.2'></script>
<script type='text/javascript' src='https://www.ostechnix.com/wp-content/plugins/responsive-lightbox/assets/infinitescroll/infinite-scroll.pkgd.min.js?ver=5.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var rlArgs = {"script":"swipebox","selector":"lightbox","customEvents":"","activeGalleries":"1","animation":"1","hideCloseButtonOnMobile":"0","removeBarsOnMobile":"0","hideBars":"1","hideBarsDelay":"5000","videoMaxWidth":"1080","useSVG":"1","loopAtEnd":"0","woocommerce_gallery":"0","ajaxurl":"https:\/\/www.ostechnix.com\/wp-admin\/admin-ajax.php","nonce":"d00a04c6d7"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.ostechnix.com/wp-content/plugins/responsive-lightbox/js/front.js?ver=2.2.2'></script>
<link rel='https://api.w.org/' href='https://www.ostechnix.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.ostechnix.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.ostechnix.com/wp-includes/wlwmanifest.xml" />
<meta name="generator" content="WordPress 5.4.1" />
<link rel='shortlink' href='https://www.ostechnix.com/?p=23523' />
<link rel="alternate" type="application/json+oembed" href="https://www.ostechnix.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.ostechnix.com%2Fhow-to-list-all-users-in-linux%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.ostechnix.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.ostechnix.com%2Fhow-to-list-all-users-in-linux%2F&#038;format=xml" />
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
  (adsbygoogle = window.adsbygoogle || []).push({
    google_ad_client: "ca-pub-6701402139964678",
    enable_page_level_ads: true
  });
</script><style type='text/css'>img#wpstats{display:none}</style><!--[if lt IE 9]>
<script src="https://www.ostechnix.com/wp-content/themes/hueman-pro/assets/front/js/ie/html5shiv-printshiv.min.js"></script>
<script src="https://www.ostechnix.com/wp-content/themes/hueman-pro/assets/front/js/ie/selectivizr.js"></script>
<![endif]-->
<link rel="icon" href="https://www.ostechnix.com/wp-content/uploads/2016/10/cropped-favicon-500x500-150x150.png" sizes="32x32" />
<link rel="icon" href="https://www.ostechnix.com/wp-content/uploads/2016/10/cropped-favicon-500x500-300x300.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://www.ostechnix.com/wp-content/uploads/2016/10/cropped-favicon-500x500-300x300.png" />
<meta name="msapplication-TileImage" content="https://www.ostechnix.com/wp-content/uploads/2016/10/cropped-favicon-500x500-300x300.png" />
<style type="text/css" id="wp-custom-css">
			/*
You can add your own CSS here.

Click the help icon above to learn more.

Use this field to test small chunks of CSS code. For important CSS customizations, it is recommended to modify the style.css file of a child theme.
http//codex.wordpress.org/Child_Themes
*/
		</style>
<style id="grids-css" type="text/css">
                .post-list .grid-item {float: left; }
                .cols-1 .grid-item { width: 100%; }
                .cols-2 .grid-item { width: 50%; }
                .cols-3 .grid-item { width: 33.3%; }
                .cols-4 .grid-item { width: 25%; }
                @media only screen and (max-width: 719px) {
                      #grid-wrapper .grid-item{
                        width: 100%;
                      }
                }
            </style>
</head>
<body data-rsssl=1 class="post-template-default single single-post postid-23523 single-format-standard wp-custom-logo wp-embed-responsive col-2cl full-width topbar-enabled header-desktop-sticky hu-header-img-full-width unknown">
<div id="wrapper">
<a class="screen-reader-text skip-link" href="#content">Skip to content</a>
<header id="header" class="both-menus-mobile-on two-mobile-menus both_menus header-ads-desktop header-ads-mobile topbar-transparent no-header-img">
<nav class="nav-container group desktop-menu desktop-sticky " id="nav-topbar" data-menu-id="header-1">

<button class="ham__navbar-toggler-two collapsed" title="Menu" aria-expanded="false">
<span class="ham__navbar-span-wrapper">
<span class="line line-1"></span>
<span class="line line-2"></span>
<span class="line line-3"></span>
</span>
</button>
<div class="nav-text"></div>
<div class="topbar-toggle-down">
<i class="fas fa-angle-double-down" aria-hidden="true" data-toggle="down" title="Expand menu"></i>
<i class="fas fa-angle-double-up" aria-hidden="true" data-toggle="up" title="Collapse menu"></i>
</div>
<div class="nav-wrap container">
<ul id="menu-top-menu" class="nav container-inner group"><li id="menu-item-9" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-9"><a href="https://www.ostechnix.com/">Home</a></li>
<li id="menu-item-11" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-11"><a target="_blank" rel="noopener noreferrer" href="https://www.ostechnix.com/category/opensource/">Open Source</a></li>
<li id="menu-item-10" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10"><a target="_blank" rel="noopener noreferrer" href="https://www.ostechnix.com/category/technology/">Technology</a></li>
<li id="menu-item-12" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-12"><a target="_blank" rel="noopener noreferrer" href="https://www.ostechnix.com/category/linux/">Linux</a>
<ul class="sub-menu">
<li id="menu-item-14" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-14"><a href="https://www.ostechnix.com/category/linux-basics/">Linux Basics</a></li>
<li id="menu-item-15" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-15"><a href="https://www.ostechnix.com/category/linux_distributions/">Linux Distributions</a>
<ul class="sub-menu">
<li id="menu-item-16" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16"><a href="https://www.ostechnix.com/category/linux_distributions/arch-linux/">Arch Linux</a></li>
<li id="menu-item-17" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-17"><a href="https://www.ostechnix.com/category/linux_distributions/centos/">CentOS</a></li>
<li id="menu-item-18" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-18"><a href="https://www.ostechnix.com/category/linux_distributions/debian/">Debian</a></li>
<li id="menu-item-19" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-19"><a href="https://www.ostechnix.com/category/linux_distributions/fedora/">Fedora</a></li>
<li id="menu-item-20" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-20"><a href="https://www.ostechnix.com/category/linux_distributions/linuxmint/">Linux Mint</a></li>
<li id="menu-item-21" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-21"><a href="https://www.ostechnix.com/category/linux_distributions/mageia/">Mageia</a></li>
<li id="menu-item-22" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22"><a href="https://www.ostechnix.com/category/linux_distributions/mandrake/">Mandrake</a></li>
<li id="menu-item-23" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-23"><a href="https://www.ostechnix.com/category/linux_distributions/mandriva/">Mandriva</a></li>
<li id="menu-item-24" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-24"><a href="https://www.ostechnix.com/category/linux_distributions/opensuse/">openSUSE</a></li>
<li id="menu-item-929" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-929"><a href="https://www.ostechnix.com/category/linux_distributions/red-hat-enterprise-linux/">Red Hat Enterprise Linux</a></li>
<li id="menu-item-930" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-930"><a href="https://www.ostechnix.com/category/linux_distributions/scientific-linux/">Scientific Linux</a></li>
</ul>
</li>
</ul>
</li>
<li id="menu-item-13" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-13"><a target="_blank" rel="noopener noreferrer" href="https://www.ostechnix.com/category/unix/">Unix</a>
<ul class="sub-menu">
<li id="menu-item-931" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-931"><a href="https://www.ostechnix.com/category/unix/freebsd/">FreeBSD</a></li>
</ul>
</li>
<li id="menu-item-5925" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5925"><a target="_blank" rel="noopener noreferrer" href="http://ostechnix.tradepub.com/category/information-technology/1207/">Free Videos and EBooks</a></li>
<li id="menu-item-7430" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-7430"><a target="_blank" rel="noopener noreferrer" href="https://www.ostechnix.com/donate/">Donate</a></li>
</ul> </div>
<div id="topbar-header-search" class="container">
<div class="container-inner">
<button class="toggle-search"><i class="fas fa-search"></i></button>
<div class="search-expand">
<div class="search-expand-inner"><form role="search" method="get" class="search-form" action="https://www.ostechnix.com/">
<label>
<span class="screen-reader-text">Search for:</span>
<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
</label>
<input type="submit" class="search-submit" value="Search" />
</form></div>
</div>
</div>
</div>
</nav>
<div class="container group">
<div class="container-inner">
<div class="group hu-pad central-header-zone">
<div class="logo-tagline-group">
<p class="site-title"> <a class="custom-logo-link" href="https://www.ostechnix.com/" rel="home" title="OSTechNix | Home page"><img src="https://www.ostechnix.com/wp-content/uploads/2020/04/cropped-OSTechNix_logo.png" alt="OSTechNix" width="250" height="100" /></a> </p> </div>
<div id="header-widgets">
<div id="custom_html-3" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-6701402139964678" data-ad-slot="4407409178" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div></div> </div>
</div>
<nav class="nav-container group desktop-menu " id="nav-header" data-menu-id="header-2">

<button class="ham__navbar-toggler-two collapsed" title="Menu" aria-expanded="false">
<span class="ham__navbar-span-wrapper">
<span class="line line-1"></span>
<span class="line line-2"></span>
<span class="line line-3"></span>
</span>
</button>
<div class="nav-text"></div>
<div class="nav-wrap container">
<ul id="menu-header-menu" class="nav container-inner group"><li id="menu-item-940" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-940"><a target="_blank" rel="noopener noreferrer" href="https://www.ostechnix.com/category/backup-tools/">Backup tools</a></li>
<li id="menu-item-943" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-943"><a target="_blank" rel="noopener noreferrer" href="https://www.ostechnix.com/category/cloud/">Cloud</a></li>
<li id="menu-item-941" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-941"><a target="_blank" rel="noopener noreferrer" href="https://www.ostechnix.com/category/database/">Database</a></li>
<li id="menu-item-942" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-942"><a target="_blank" rel="noopener noreferrer" href="https://www.ostechnix.com/category/directory-servers/">Directory servers</a></li>
<li id="menu-item-944" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-944"><a target="_blank" rel="noopener noreferrer" href="https://www.ostechnix.com/category/mobile/">Mobile</a>
<ul class="sub-menu">
<li id="menu-item-945" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-945"><a href="https://www.ostechnix.com/category/android/">Android</a></li>
</ul>
</li>
<li id="menu-item-939" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-939"><a target="_blank" rel="noopener noreferrer" href="https://www.ostechnix.com/category/reviews/">Reviews</a></li>
<li id="menu-item-932" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-932"><a target="_blank" rel="noopener noreferrer" href="https://www.ostechnix.com/category/security/">Security</a>
<ul class="sub-menu">
<li id="menu-item-936" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-936"><a href="https://www.ostechnix.com/category/encryption-decryption/">Encryption / Decryption</a></li>
<li id="menu-item-938" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-938"><a href="https://www.ostechnix.com/category/monitoring-tools/">Monitoring Tools</a></li>
</ul>
</li>
<li id="menu-item-933" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-933"><a target="_blank" rel="noopener noreferrer" href="https://www.ostechnix.com/category/tips-and-tricks/">Tips and Tricks</a>
<ul class="sub-menu">
<li id="menu-item-937" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-937"><a href="https://www.ostechnix.com/category/internet-hacks/">Internet hacks</a></li>
</ul>
</li>
<li id="menu-item-934" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-934"><a target="_blank" rel="noopener noreferrer" href="https://www.ostechnix.com/category/trouble-shooting/">Trouble shooting</a></li>
<li id="menu-item-935" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-935"><a target="_blank" rel="noopener noreferrer" href="https://www.ostechnix.com/category/virtualization/">Virtualization</a></li>
</ul> </div>
</nav>
</div>
</div>
</header>
<div class="container" id="page">
<div class="container-inner">
<div class="main">
<div class="main-inner group">
<section class="content" id="content">
<div class="page-title hu-pad group">
<ul class="meta-single group">
<li class="category"><a href="https://www.ostechnix.com/category/faq/" rel="category tag">FAQ</a> <span>/</span> <a href="https://www.ostechnix.com/category/linux/" rel="category tag">Linux</a> <span>/</span> <a href="https://www.ostechnix.com/category/linux-admnistration/" rel="category tag">Linux Admnistration</a> <span>/</span> <a href="https://www.ostechnix.com/category/linux-basics/" rel="category tag">Linux Basics</a> <span>/</span> <a href="https://www.ostechnix.com/category/linux-commands/" rel="category tag">Linux Commands</a> <span>/</span> <a href="https://www.ostechnix.com/category/linux-tips-tricks/" rel="category tag">Linux Tips &amp; Tricks</a> <span>/</span> <a href="https://www.ostechnix.com/category/tips-and-tricks/" rel="category tag">Tips and Tricks</a> <span>/</span> <a href="https://www.ostechnix.com/category/unixlinux-beginners/" rel="category tag">Unix/Linux Beginners</a></li>
</ul>
</div>
<div class="hu-pad group">
<article class="post-23523 post type-post status-publish format-standard has-post-thumbnail hentry category-faq category-linux category-linux-admnistration category-linux-basics category-linux-commands category-linux-tips-tricks category-tips-and-tricks category-unixlinux-beginners tag-linux tag-linux-commands tag-linux-user-management">
<div class="post-inner group">
<h1 class="post-title entry-title">How To List All Users In Linux</h1>
<p class="post-byline">
by <span class="vcard author">
<span class="fn"><a href="https://www.ostechnix.com/author/sk/" title="Posts by sk" rel="author">sk</a></span>
</span>
&middot;
<time class="published" datetime="2020-05-16T19:51:07+05:30">May 16, 2020</time>
</p>
<div class="clear"></div>
<div class="entry themeform share">
<div class="entry-inner">
<p>Since Linux is a multi-user operating system, it may consists of more than one user. This brief guide explains how to list all users in Linux operating systems. Before getting into the topic, we will see what is /etc/passwd file. Because we depend on this file through out this guide.</p>
<h4>A brief note about the /etc/passwd file</h4>
<p>In Linux (and Unix in general), the basic information about each user account is stored in <strong>&#8220;/etc/passwd&#8221;</strong> file. It is nothing but a plain text file that contains the attributes of all user accounts present in a Linux system. By default, this file is readable by all users with the help of any text or graphical programs, such as Vi, Nano, Gedit etc or with commands like <strong>&#8220;cat</strong>&#8220;.</p>
<p>If you open this file..</p>
<pre>$ cat /etc/passwd</pre>
<p>&#8230;you will see several entries like below:</p>
<pre>root:x:0:0:root:/root:/bin/bash
daemon:x:1:1:daemon:/usr/sbin:/usr/sbin/nologin
bin:x:2:2:bin:/bin:/usr/sbin/nologin
sys:x:3:3:sys:/dev:/usr/sbin/nologin
sync:x:4:65534:sync:/bin:/bin/sync
games:x:5:60:games:/usr/games:/usr/sbin/nologin
[...]</pre>
<p>Each line in the /etc/passwd file represents a single user. The root user will be listed on the top. Each line contains seven attributes or fields separated by a colon without any spaces between each field. The name of the seven fields are given below:</p>
<ol>
<li>name,</li>
<li>password,</li>
<li>user ID,</li>
<li>group ID,</li>
<li>gecos,</li>
<li>home directory,</li>
<li>shell.</li>
</ol>
<p>The <em><strong>&#8220;name&#8221;</strong></em> field is the user&#8217;s login name that you use to login to your Linux box.</p>
<p>The <strong><em>&#8220;password&#8221;</em></strong> field merely contains a letter X. Meaning &#8211; the password is encrypted and stored in a separate file called &#8220;/etc/shadow&#8221; for security purpose. The /etc/shadow can not be read by the normal users. Here the X indicates that the user has a password. If this field is empty, the user has no password, so he can login without password.</p>
<p>The <em><strong>&#8220;User ID</strong></em>&#8221; (or UID in short) indicates the user&#8217;s unique numeric identification number. The root account&#8217;s UID is 0 (zero). The numbers from 1 to 99 are reserved for system accounts. And the numbers starting from100 to 999 are reserved for normal users and groups.</p>
<p>The <em><strong>&#8220;Group ID&#8221;</strong></em> (or GID in short) indicates the primary group identifier the user belongs to. The GID is usually the same as the UID.</p>
<p>The <em><strong>&#8220;geckos&#8221;</strong></em> field contains the general information of a user. For example, It may contain the user&#8217;s real name. This filed might be either empty separated by two colons or it might contain multiple entries separated by commas.</p>
<p>The <em><strong>&#8220;home directory&#8221;</strong></em> field indicates the full path of the user&#8217;s home directory, for example <strong>/home/sk</strong>. This is the directory that the user is first in when he logged into a system. The home directory usually contains programs and configurations files belonged to the user.</p>
<p>The last filed is <em><strong>&#8220;shell&#8221;</strong></em>. It indicates the full path of the default shell for that user.</p>
<p>Now, let us take the following line as an example:</p>
<pre>root:x:0:0:root:/root:/bin/bash</pre>
<p>In the above line,</p>
<ul>
<li><strong>root</strong> &#8211; is the user name,</li>
<li><strong>x</strong> &#8211; indicates the root user has password,</li>
<li><strong>0</strong> &#8211; The first 0 (zero) indicates the UID,</li>
<li><strong>0</strong> &#8211; The second zero indicates the GID,</li>
<li><strong>root</strong> &#8211; It indicates the real name of the user.</li>
<li><strong>/root</strong> &#8211; It is the home directory of the root user,</li>
<li><strong>/bin/bash</strong> &#8211; Default shell for root user.</li>
</ul>
<p>Hope you get a basic idea about the /etc/passwd file. Now let us get back to our topic i.e listing all users in a Linux system.</p>
<h2>List All Users In Linux</h2>
<p>There are couple ways to list all users in a Linux system. Here I have included all possible ways.</p>
<h4>Cat command</h4>
<p>As the names says, the cat command is generally used to concatenate files and print the contents of the files.</p>
<p>To list all users in a Linux system using cut command, run:</p>
<pre>$ cat /etc/passwd</pre>
<p>This command will list all available users</p>
<p><strong>Sample output:</strong></p>
<pre>root:x:0:0:root:/root:/bin/bash
daemon:x:1:1:daemon:/usr/sbin:/usr/sbin/nologin
bin:x:2:2:bin:/bin:/usr/sbin/nologin
sys:x:3:3:sys:/dev:/usr/sbin/nologin
sync:x:4:65534:sync:/bin:/bin/sync
games:x:5:60:games:/usr/games:/usr/sbin/nologin
man:x:6:12:man:/var/cache/man:/usr/sbin/nologin
lp:x:7:7:lp:/var/spool/lpd:/usr/sbin/nologin
mail:x:8:8:mail:/var/mail:/usr/sbin/nologin
news:x:9:9:news:/var/spool/news:/usr/sbin/nologin
uucp:x:10:10:uucp:/var/spool/uucp:/usr/sbin/nologin
proxy:x:13:13:proxy:/bin:/usr/sbin/nologin
www-data:x:33:33:www-data:/var/www:/usr/sbin/nologin
backup:x:34:34:backup:/var/backups:/usr/sbin/nologin
list:x:38:38:Mailing List Manager:/var/list:/usr/sbin/nologin
irc:x:39:39:ircd:/var/run/ircd:/usr/sbin/nologin
gnats:x:41:41:Gnats Bug-Reporting System (admin):/var/lib/gnats:/usr/sbin/nologin
nobody:x:65534:65534:nobody:/nonexistent:/usr/sbin/nologin
systemd-network:x:100:102:systemd Network Management,,,:/run/systemd/netif:/usr/sbin/nologin
systemd-resolve:x:101:103:systemd Resolver,,,:/run/systemd/resolve:/usr/sbin/nologin
syslog:x:102:106::/home/syslog:/usr/sbin/nologin
messagebus:x:103:107::/nonexistent:/usr/sbin/nologin
_apt:x:104:65534::/nonexistent:/usr/sbin/nologin
uuidd:x:105:111::/run/uuidd:/usr/sbin/nologin
avahi-autoipd:x:106:112:Avahi autoip daemon,,,:/var/lib/avahi-autoipd:/usr/sbin/nologin
usbmux:x:107:46:usbmux daemon,,,:/var/lib/usbmux:/usr/sbin/nologin
dnsmasq:x:108:65534:dnsmasq,,,:/var/lib/misc:/usr/sbin/nologin
rtkit:x:109:114:RealtimeKit,,,:/proc:/usr/sbin/nologin
cups-pk-helper:x:110:116:user for cups-pk-helper service,,,:/home/cups-pk-helper:/usr/sbin/nologin
speech-dispatcher:x:111:29:Speech Dispatcher,,,:/var/run/speech-dispatcher:/bin/false
whoopsie:x:112:117::/nonexistent:/bin/false
kernoops:x:113:65534:Kernel Oops Tracking Daemon,,,:/:/usr/sbin/nologin
saned:x:114:119::/var/lib/saned:/usr/sbin/nologin
avahi:x:116:122:Avahi mDNS daemon,,,:/var/run/avahi-daemon:/usr/sbin/nologin
colord:x:117:123:colord colour management daemon,,,:/var/lib/colord:/usr/sbin/nologin
hplip:x:118:7:HPLIP system user,,,:/var/run/hplip:/bin/false
geoclue:x:119:124::/var/lib/geoclue:/usr/sbin/nologin
gnome-initial-setup:x:120:65534::/run/gnome-initial-setup/:/bin/false
gdm:x:121:125:Gnome Display Manager:/var/lib/gdm3:/bin/false
sk:x:1000:1000:sk,,,:/home/sk:/bin/bash
Debian-exim:x:122:128::/var/spool/exim4:/usr/sbin/nologin
pulse:x:115:120:PulseAudio daemon,,,:/var/run/pulse:/usr/sbin/nologin
systemd-timesync:x:123:127:systemd Time Synchronization,,,:/run/systemd:/usr/sbin/nologin
tss:x:124:131:TPM software stack,,,:/var/lib/tpm:/bin/false
tcpdump:x:125:132::/nonexistent:/usr/sbin/nologin
_flatpak:x:126:133:Flatpak system-wide installation helper,,,:/nonexistent:/usr/sbin/nologin
systemd-coredump:x:999:999:systemd Core Dumper:/:/usr/sbin/nologin</pre>
<p><a href="https://www.ostechnix.com/wp-content/uploads/2020/05/List-all-users-in-Linux-using-cat-command.png" data-rel="lightbox-image-0" data-rl_title="" data-rl_caption="" title=""><img class="aligncenter size-full wp-image-23532" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://www.ostechnix.com/wp-content/uploads/2020/05/List-all-users-in-Linux-using-cat-command.png" alt="List all users in Linux using cat command" width="944" height="691" data-srcset="https://www.ostechnix.com/wp-content/uploads/2020/05/List-all-users-in-Linux-using-cat-command.png 944w, https://www.ostechnix.com/wp-content/uploads/2020/05/List-all-users-in-Linux-using-cat-command-300x220.png 300w, https://www.ostechnix.com/wp-content/uploads/2020/05/List-all-users-in-Linux-using-cat-command-768x562.png 768w, https://www.ostechnix.com/wp-content/uploads/2020/05/List-all-users-in-Linux-using-cat-command-720x527.png 720w, https://www.ostechnix.com/wp-content/uploads/2020/05/List-all-users-in-Linux-using-cat-command-520x381.png 520w, https://www.ostechnix.com/wp-content/uploads/2020/05/List-all-users-in-Linux-using-cat-command-320x234.png 320w" data-sizes="(max-width: 944px) 100vw, 944px" /></a></p>
<p>As I mentioned already, the first field in the above entries represents the users. If you don&#8217;t want all fields but only display the user names, the following methods would help.</p>
<h4>Cut command</h4>
<p>The &#8220;cut&#8221; command is used to remove sections (or fields) from each line of files.</p>
<p>To list all users with cut command in a Linux system, run:</p>
<pre>$ cut -d: -f1 /etc/passwd</pre>
<p>This command will only display the user names from the /etc/passwd file and ignore all other fields.</p>
<p><strong>Sample output:</strong></p>
<pre>root
daemon
bin
sys
sync
games
man
lp
mail
news
uucp
proxy
www-data
backup
list
irc
gnats
nobody
systemd-network
systemd-resolve
syslog
messagebus
_apt
uuidd
avahi-autoipd
usbmux
dnsmasq
rtkit
cups-pk-helper
speech-dispatcher
whoopsie
kernoops
saned
avahi
colord
hplip
geoclue
gnome-initial-setup
gdm
sk
Debian-exim
pulse
systemd-timesync
tss
tcpdump
_flatpak
systemd-coredump</pre>
<p><a href="https://www.ostechnix.com/wp-content/uploads/2020/05/List-all-users-in-Linux-using-cut-command.png" data-rel="lightbox-image-1" data-rl_title="" data-rl_caption="" title=""><img class="aligncenter size-full wp-image-23534" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://www.ostechnix.com/wp-content/uploads/2020/05/List-all-users-in-Linux-using-cut-command.png" alt="List all users in Linux using cut command" width="785" height="691" data-srcset="https://www.ostechnix.com/wp-content/uploads/2020/05/List-all-users-in-Linux-using-cut-command.png 785w, https://www.ostechnix.com/wp-content/uploads/2020/05/List-all-users-in-Linux-using-cut-command-300x264.png 300w, https://www.ostechnix.com/wp-content/uploads/2020/05/List-all-users-in-Linux-using-cut-command-768x676.png 768w, https://www.ostechnix.com/wp-content/uploads/2020/05/List-all-users-in-Linux-using-cut-command-720x634.png 720w, https://www.ostechnix.com/wp-content/uploads/2020/05/List-all-users-in-Linux-using-cut-command-520x458.png 520w, https://www.ostechnix.com/wp-content/uploads/2020/05/List-all-users-in-Linux-using-cut-command-320x282.png 320w" data-sizes="(max-width: 785px) 100vw, 785px" /></a></p>
<h4>Awk command</h4>
<p>We can also use &#8220;awk&#8221; command to list all users in Linux.</p>
<pre>$ awk -F':' '{ print $1}' /etc/passwd
</pre>
<p>This command will also display only the users and omit all other details.</p>
<p><a href="https://www.ostechnix.com/wp-content/uploads/2020/05/List-all-users-in-Linux-using-awk-command.png" data-rel="lightbox-image-2" data-rl_title="" data-rl_caption="" title=""><img class="aligncenter size-full wp-image-23535" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://www.ostechnix.com/wp-content/uploads/2020/05/List-all-users-in-Linux-using-awk-command.png" alt="List all users in Linux using awk command" width="854" height="691" data-srcset="https://www.ostechnix.com/wp-content/uploads/2020/05/List-all-users-in-Linux-using-awk-command.png 854w, https://www.ostechnix.com/wp-content/uploads/2020/05/List-all-users-in-Linux-using-awk-command-300x243.png 300w, https://www.ostechnix.com/wp-content/uploads/2020/05/List-all-users-in-Linux-using-awk-command-768x621.png 768w, https://www.ostechnix.com/wp-content/uploads/2020/05/List-all-users-in-Linux-using-awk-command-720x583.png 720w, https://www.ostechnix.com/wp-content/uploads/2020/05/List-all-users-in-Linux-using-awk-command-520x421.png 520w, https://www.ostechnix.com/wp-content/uploads/2020/05/List-all-users-in-Linux-using-awk-command-320x259.png 320w" data-sizes="(max-width: 854px) 100vw, 854px" /></a></p>
<h4>Compgen</h4>
<p><strong>Compgen</strong> is BASH built-in to  manipulate the programmable completion facilities.</p>
<p>To list all users using compgen, run:</p>
<pre>$ compgen -u</pre>
<h4>Getent command</h4>
<p>Another way to list the users in Linux is to use <strong>&#8220;getent&#8221;</strong> command like below:</p>
<pre>$ getent passwd</pre>
<p>This command will read the /etc/passwd file and lists all users in that file.</p>
<p><a href="https://www.ostechnix.com/wp-content/uploads/2020/05/List-all-users-in-Linux-using-getent-command.png" data-rel="lightbox-image-3" data-rl_title="" data-rl_caption="" title=""><img class="aligncenter size-full wp-image-23533" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://www.ostechnix.com/wp-content/uploads/2020/05/List-all-users-in-Linux-using-getent-command.png" alt="List all users in Linux using getent command" width="833" height="691" data-srcset="https://www.ostechnix.com/wp-content/uploads/2020/05/List-all-users-in-Linux-using-getent-command.png 833w, https://www.ostechnix.com/wp-content/uploads/2020/05/List-all-users-in-Linux-using-getent-command-300x249.png 300w, https://www.ostechnix.com/wp-content/uploads/2020/05/List-all-users-in-Linux-using-getent-command-768x637.png 768w, https://www.ostechnix.com/wp-content/uploads/2020/05/List-all-users-in-Linux-using-getent-command-720x597.png 720w, https://www.ostechnix.com/wp-content/uploads/2020/05/List-all-users-in-Linux-using-getent-command-520x431.png 520w, https://www.ostechnix.com/wp-content/uploads/2020/05/List-all-users-in-Linux-using-getent-command-320x265.png 320w" data-sizes="(max-width: 833px) 100vw, 833px" /></a></p>
<p>One notable advantage of getent command is it not only lists the users in the /etc/passwd file but all users in all configured userdb backends, for example LDAP, on a given system.</p>
<h4>The &#8220;more&#8221; or &#8220;less&#8221; commands</h4>
<p>The more and less commands are used to open a given file for interactive reading, allowing scrolling and search.</p>
<p>To print all users using more or less command, run:</p>
<pre>$ more /etc/passwd</pre>
<p>Or,</p>
<pre>$ less /etc/passwd</pre>
<hr />
<p><strong>Related read:</strong></p>
<ul>
<li><a href="https://www.ostechnix.com/the-difference-between-more-less-and-most-commands/" target="_blank" rel="noopener noreferrer"><strong>The Difference Between more, less And most Commands</strong></a></li>
<li><a href="https://www.ostechnix.com/how-to-add-delete-and-grant-sudo-privileges-to-users-in-linux/" target="_blank" rel="noopener noreferrer"><strong>How To Add, Delete And Grant Sudo Privileges To Users In Ubuntu</strong></a></li>
<li><a href="https://www.ostechnix.com/quick-tip-how-to-find-out-which-groups-a-user-belongs-to/" target="_blank" rel="noopener noreferrer"><strong>How To Find Out Which Groups A User Belongs To In Linux</strong></a></li>
<li><a href="https://www.ostechnix.com/the-right-way-to-edit-etc-passwd-and-etc-group-files-in-linux/" target="_blank" rel="noopener noreferrer"><strong>The Right Way To Edit /etc/passwd And /etc/group Files In Linux</strong></a></li>
</ul>
<hr />
<p>Hope this helps.</p>
<div class="after-post-box">
<p style="text-align: center;"><strong style="color: #ef4423; font-size: 20px;">Thanks for stopping by! </strong></p>
<h4>Help us to help you:</h4>
<ul>
<li>Subscribe to our Email Newsletter : <strong><a title="Subscribe to our Email newsletter" href="http://feedburner.google.com/fb/a/mailverify?uri=ostechnix" target="_blank" rel="nofollow noopener noreferrer">Sign Up Now</a></strong></li>
<li>Support OSTechNix : <strong><a title="Donate Via PayPal" href="https://www.paypal.me/ostechnix" target="_blank" rel="nofollow noopener noreferrer">Donate Via PayPal</a></strong></li>
<li>Download free E-Books and Videos : <a href="http://ostechnix.tradepub.com/category/information-technology/1207/" target="_blank" rel="noopener noreferrer"><strong>OSTechNix on TradePub</strong></a></li>
<li>Connect with us: <a href="https://www.reddit.com/r/OSTechNix/" target="_blank" rel="noopener noreferrer"><strong>Reddit</strong></a> | <a href="https://www.facebook.com/ostechnix/" target="_blank" rel="noopener noreferrer"><strong>Facebook</strong></a> | <a href="https://twitter.com/ostechnix" target="_blank" rel="noopener noreferrer"><strong>Twitter</strong></a> | <strong> <a href="https://www.linkedin.com/in/ostechnix" target="_blank" rel="noopener noreferrer">LinkedIn</a> </strong>|<strong> <a href="http://feeds.feedburner.com/Ostechnix" target="_blank" rel="noopener noreferrer">RSS feeds</a></strong></li>
</ul>
<p style="text-align: center;"><strong style="color: #ef4423; font-size: 20px;">Have a Good day!!</strong></p>
</div>
<div class="widget_text awac-wrapper"><div class="widget_text awac widget custom_html-2"><div class="textwidget custom-html-widget"><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle" style="display:block" data-ad-format="autorelaxed" data-ad-client="ca-pub-6701402139964678" data-ad-slot="4635513743"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div></div></div><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-reddit"><a rel="nofollow noopener noreferrer" data-shared="" class="share-reddit sd-button share-icon" href="https://www.ostechnix.com/how-to-list-all-users-in-linux/?share=reddit" target="_blank" title="Click to share on Reddit"><span>Reddit</span></a></li><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-23523" class="share-twitter sd-button share-icon" href="https://www.ostechnix.com/how-to-list-all-users-in-linux/?share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-23523" class="share-facebook sd-button share-icon" href="https://www.ostechnix.com/how-to-list-all-users-in-linux/?share=facebook" target="_blank" title="Click to share on Facebook"><span>Facebook</span></a></li><li class="share-linkedin"><a rel="nofollow noopener noreferrer" data-shared="sharing-linkedin-23523" class="share-linkedin sd-button share-icon" href="https://www.ostechnix.com/how-to-list-all-users-in-linux/?share=linkedin" target="_blank" title="Click to share on LinkedIn"><span>LinkedIn</span></a></li><li class="share-jetpack-whatsapp"><a rel="nofollow noopener noreferrer" data-shared="" class="share-jetpack-whatsapp sd-button share-icon" href="https://www.ostechnix.com/how-to-list-all-users-in-linux/?share=jetpack-whatsapp" target="_blank" title="Click to share on WhatsApp"><span>WhatsApp</span></a></li><li class="share-telegram"><a rel="nofollow noopener noreferrer" data-shared="" class="share-telegram sd-button share-icon" href="https://www.ostechnix.com/how-to-list-all-users-in-linux/?share=telegram" target="_blank" title="Click to share on Telegram"><span>Telegram</span></a></li><li class="share-pocket"><a rel="nofollow noopener noreferrer" data-shared="" class="share-pocket sd-button share-icon" href="https://www.ostechnix.com/how-to-list-all-users-in-linux/?share=pocket" target="_blank" title="Click to share on Pocket"><span>Pocket</span></a></li><li class="share-print"><a rel="nofollow noopener noreferrer" data-shared="" class="share-print sd-button share-icon" href="https://www.ostechnix.com/how-to-list-all-users-in-linux/#print" target="_blank" title="Click to print"><span>Print</span></a></li><li class="share-end"></li></ul></div></div></div> <nav class="pagination group">
</nav>
</div>
<div class="sharrre-container no-counter">
<span>Share</span>
<div id="twitter" data-url="https://www.ostechnix.com/how-to-list-all-users-in-linux/" data-text="How To List All Users In Linux" data-title="Tweet"><a class="box" href="#"><div class="count" href="#"><i class="fas fa-plus"></i></div><div class="share"><i class="fab fa-twitter"></i></div></a></div>
<div id="facebook" data-url="https://www.ostechnix.com/how-to-list-all-users-in-linux/" data-text="How To List All Users In Linux" data-title="Like"></div>
<div id="linkedin" data-url="https://www.ostechnix.com/how-to-list-all-users-in-linux/" data-text="How To List All Users In Linux" data-title="Publish on Linked In"></div>
</div>
<style type="text/css"></style>
<script type="text/javascript">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</script>
<div class="clear"></div>
</div>
</div>
</article>
<div class="clear"></div>
<p class="post-tags"><span>Tags:</span> <a href="https://www.ostechnix.com/tag/linux/" rel="tag">Linux</a><a href="https://www.ostechnix.com/tag/linux-commands/" rel="tag">Linux commands</a><a href="https://www.ostechnix.com/tag/linux-user-management/" rel="tag">Linux user management</a></p>
<ul class="post-nav group">
<li class="next"></li>
<li class="previous"><a href="https://www.ostechnix.com/mapscii-world-map-terminal/" rel="prev"><i class="fas fa-chevron-left"></i><strong>Previous story</strong> <span>MapSCII &#8211; The World Map In Your Terminal</span></a></li>
</ul>
<script type="text/javascript">
        jQuery( function($) {
            var _fireWhenCzrAppReady = function() {
              czrapp.proRelPostsRendered = $.Deferred();
              var waypoint = new Waypoint({
                  element: document.getElementById('pro-related-posts-wrapper'),
                  handler: function(direction) {
                        if ( 'pending' == czrapp.proRelPostsRendered.state() ) {
                              var $wrap = $('#pro-related-posts-wrapper');
                              $wrap.addClass('loading');
                              czrapp.doAjax( {
                                      action: "ha_inject_pro_related",
                                      // => Always get the option from the $_POSTED data in ajax
                                      related_post_id : 23523,
                                      pro_related_posts_opt : [],
                                      free_related_posts_opt : "tags",
                                      layout_class : "col-2cl"
                                  } ).done( function( r ) {
                                        if ( r && r.data && r.data.html ) {
                                            if ( 'pending' == czrapp.proRelPostsRendered.state() ) {
                                                $.when( $('#pro-related-posts-wrapper').append( r.data.html ) ).done( function() {
                                                      czrapp.proRelPostsRendered.resolve();
                                                      $wrap.find('.czr-css-loader').css('opacity', 0);
                                                      _.delay( function() {
                                                            $wrap.removeClass('loading').addClass('loaded');
                                                      }, 800 );
                                                });
                                            }
                                        }
                                  });
                        }
                  },
                  offset: '110%'
              });
          };//_fireWhenCzrAppReady

          if ( window.czrapp && czrapp.methods && czrapp.methods.ProHeaderSlid ) {
            _fireWhenCzrAppReady()
          } else {
            document.addEventListener('czrapp-is-ready', _fireWhenCzrAppReady );
          }
        });//jQuery()
    </script>
<div id="pro-related-posts-wrapper"><div class="czr-css-loader czr-mr-loader dark"><div></div><div></div><div></div></div></div>
<section id="comments" class="themeform">

<div id="respond" class="comment-respond">
<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/how-to-list-all-users-in-linux/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://www.ostechnix.com/wp-comments-post.php" method="post" id="commentform" class="comment-form"><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required='required' /></p>
<p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="text" value="" size="30" maxlength="100" aria-describedby="email-notes" required='required' /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="text" value="" size="30" maxlength="200" /></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='23523' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="d44eb58b0f" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="193" /></p></form> </div>
<p class="akismet_comment_form_privacy_notice">This site uses Akismet to reduce spam. <a href="https://akismet.com/privacy/" target="_blank" rel="nofollow noopener">Learn how your comment data is processed</a>.</p>
</section> </div>
</section>
<div class="sidebar s1 collapsed" data-position="right" data-layout="col-2cl" data-sb-id="s1">
<button class="sidebar-toggle" title="Expand Sidebar"><i class="fas sidebar-toggle-arrows"></i></button>
<div class="sidebar-content">
<div class="sidebar-top group">
<p>Follow:</p>
<ul class="social-links"><li><a rel="nofollow noopener noreferrer" class="social-tooltip" title="Follow us on Reddit-square" aria-label="Follow us on Reddit-square" href="https://www.reddit.com/r/OSTechNix/" target="_blank"><i class="fab fa-reddit-square"></i></a></li><li><a rel="nofollow noopener noreferrer" class="social-tooltip" title="Follow us on Facebook-square" aria-label="Follow us on Facebook-square" href="https://www.facebook.com/ostechnix/" target="_blank" style="color:rgba(255,255,255,0.7)"><i class="fab fa-facebook-square"></i></a></li><li><a rel="nofollow noopener noreferrer" class="social-tooltip" title="Follow us on Twitter-square" aria-label="Follow us on Twitter-square" href="https://twitter.com/ostechnix" target="_blank" style="color:rgba(255,255,255,0.7)"><i class="fab fa-twitter-square"></i></a></li><li><a rel="nofollow noopener noreferrer" class="social-tooltip" title="Follow us on Linkedin-square" aria-label="Follow us on Linkedin-square" href="https://in.linkedin.com/in/ostechnix" target="_blank" style="color:rgba(255,255,255,0.7)"><i class="fab fa-linkedin"></i></a></li><li><a rel="nofollow noopener noreferrer" class="social-tooltip" title="Follow us on Rss" aria-label="Follow us on Rss" href="http://feeds.feedburner.com/Ostechnix" target="_blank" style="color:rgba(255,255,255,0.7)"><i class="fas fa-rss"></i></a></li></ul> </div>
<div id="custom_html-4" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-6701402139964678" data-ad-slot="3689433741" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div></div><div id="custom_html-6" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><script>
  (function() {
    var cx = '008602152458925632792:qnuzfwvz-gy';
    var gcse = document.createElement('script');
    gcse.type = 'text/javascript';
    gcse.async = true;
    gcse.src = 'https://cse.google.com/cse.js?cx=' + cx;
    var s = document.getElementsByTagName('script')[0];
    s.parentNode.insertBefore(gcse, s);
  })();
</script>
<gcse:searchbox-only></gcse:searchbox-only></div></div><div id="responsive_lightbox_image_widget-2" class="widget rl-image-widget"><h3 class="widget-title">Get Your Free eBook</h3><a href="https://ostechnix.tradepub.com/free/w_howt04/prgm.cgi" class="rl-image-widget-link"><img class="rl-image-widget-image" src="https://www.ostechnix.com/wp-content/uploads/2020/02/Essential-Linux-Toolkit-ostechnix-768x993.jpg" width="100%" height="auto" title="Essential Linux Toolkit - ostechnix" alt="Free Ebook - Essential Linux Toolkit Free by Ostechnix" style="margin-left: auto; margin-right: auto; display: block;" /></a><div class="rl-image-widget-text" style="text-align: center; display: block;"></div></div><div id="custom_html-5" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-6701402139964678" data-ad-slot="4424653341" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div></div>
</div>
</div>
﻿ </div>
</div>
</div>
</div>
<footer id="footer">
<section class="container" id="footer-widgets">
<div class="container-inner">
<div class="pad group">
<div class="footer-widget-1 grid one-third ">
<div id="text-5" class="widget widget_text"><h3 class="widget-title">Email Newsletter</h3> <div class="textwidget"><form style="border:3px solid #ccc;border-color:#a8a9ad;padding:10px;text-align:center; font-weight:bold; font-size:18px;line-height: 29px;background-color: #00AEEF; color: #FFFFFF;
" action="https://feedburner.google.com/fb/a/mailverify" method="post" target="popupwindow" onsubmit="window.open('https://feedburner.google.com/fb/a/mailverify?uri=Ostechnix', 'popupwindow', 'scrollbars=yes,width=550,height=520');return true"><p>Subscribe to our mailing list</p><p><input type="text" style="width:240px" name="email" /></p><input type="hidden" value="Ostechnix" name="uri" /><input type="hidden" name="loc" value="en_US" /><input type="submit" value="Sign Up Now" /><p>We respect your privacy</p></form></div>
</div> </div>
<div class="footer-widget-2 grid one-third ">
<div id="archives-4" class="widget widget_archive"><h3 class="widget-title">Blog Archive</h3> <label class="screen-reader-text" for="archives-dropdown-4">Blog Archive</label>
<select id="archives-dropdown-4" name="archive-dropdown">
<option value="">Select Month</option>
<option value='https://www.ostechnix.com/2020/05/'> May 2020 &nbsp;(14)</option>
<option value='https://www.ostechnix.com/2020/04/'> April 2020 &nbsp;(32)</option>
<option value='https://www.ostechnix.com/2020/03/'> March 2020 &nbsp;(21)</option>
<option value='https://www.ostechnix.com/2020/02/'> February 2020 &nbsp;(19)</option>
<option value='https://www.ostechnix.com/2020/01/'> January 2020 &nbsp;(22)</option>
<option value='https://www.ostechnix.com/2019/12/'> December 2019 &nbsp;(13)</option>
<option value='https://www.ostechnix.com/2019/11/'> November 2019 &nbsp;(9)</option>
<option value='https://www.ostechnix.com/2019/10/'> October 2019 &nbsp;(11)</option>
<option value='https://www.ostechnix.com/2019/09/'> September 2019 &nbsp;(11)</option>
<option value='https://www.ostechnix.com/2019/08/'> August 2019 &nbsp;(18)</option>
<option value='https://www.ostechnix.com/2019/07/'> July 2019 &nbsp;(18)</option>
<option value='https://www.ostechnix.com/2019/06/'> June 2019 &nbsp;(11)</option>
<option value='https://www.ostechnix.com/2019/05/'> May 2019 &nbsp;(13)</option>
<option value='https://www.ostechnix.com/2019/04/'> April 2019 &nbsp;(12)</option>
<option value='https://www.ostechnix.com/2019/03/'> March 2019 &nbsp;(10)</option>
<option value='https://www.ostechnix.com/2019/02/'> February 2019 &nbsp;(11)</option>
<option value='https://www.ostechnix.com/2019/01/'> January 2019 &nbsp;(9)</option>
<option value='https://www.ostechnix.com/2018/12/'> December 2018 &nbsp;(6)</option>
<option value='https://www.ostechnix.com/2018/11/'> November 2018 &nbsp;(12)</option>
<option value='https://www.ostechnix.com/2018/10/'> October 2018 &nbsp;(19)</option>
<option value='https://www.ostechnix.com/2018/09/'> September 2018 &nbsp;(20)</option>
<option value='https://www.ostechnix.com/2018/08/'> August 2018 &nbsp;(19)</option>
<option value='https://www.ostechnix.com/2018/07/'> July 2018 &nbsp;(15)</option>
<option value='https://www.ostechnix.com/2018/06/'> June 2018 &nbsp;(15)</option>
<option value='https://www.ostechnix.com/2018/05/'> May 2018 &nbsp;(16)</option>
<option value='https://www.ostechnix.com/2018/04/'> April 2018 &nbsp;(21)</option>
<option value='https://www.ostechnix.com/2018/03/'> March 2018 &nbsp;(23)</option>
<option value='https://www.ostechnix.com/2018/02/'> February 2018 &nbsp;(16)</option>
<option value='https://www.ostechnix.com/2018/01/'> January 2018 &nbsp;(19)</option>
<option value='https://www.ostechnix.com/2017/12/'> December 2017 &nbsp;(23)</option>
<option value='https://www.ostechnix.com/2017/11/'> November 2017 &nbsp;(22)</option>
<option value='https://www.ostechnix.com/2017/10/'> October 2017 &nbsp;(17)</option>
<option value='https://www.ostechnix.com/2017/09/'> September 2017 &nbsp;(25)</option>
<option value='https://www.ostechnix.com/2017/08/'> August 2017 &nbsp;(24)</option>
<option value='https://www.ostechnix.com/2017/07/'> July 2017 &nbsp;(23)</option>
<option value='https://www.ostechnix.com/2017/06/'> June 2017 &nbsp;(16)</option>
<option value='https://www.ostechnix.com/2017/05/'> May 2017 &nbsp;(23)</option>
<option value='https://www.ostechnix.com/2017/04/'> April 2017 &nbsp;(25)</option>
<option value='https://www.ostechnix.com/2017/03/'> March 2017 &nbsp;(33)</option>
<option value='https://www.ostechnix.com/2017/02/'> February 2017 &nbsp;(34)</option>
<option value='https://www.ostechnix.com/2017/01/'> January 2017 &nbsp;(25)</option>
<option value='https://www.ostechnix.com/2016/12/'> December 2016 &nbsp;(20)</option>
<option value='https://www.ostechnix.com/2016/11/'> November 2016 &nbsp;(15)</option>
<option value='https://www.ostechnix.com/2016/10/'> October 2016 &nbsp;(10)</option>
<option value='https://www.ostechnix.com/2016/09/'> September 2016 &nbsp;(12)</option>
<option value='https://www.ostechnix.com/2016/08/'> August 2016 &nbsp;(23)</option>
<option value='https://www.ostechnix.com/2016/07/'> July 2016 &nbsp;(6)</option>
<option value='https://www.ostechnix.com/2016/06/'> June 2016 &nbsp;(15)</option>
<option value='https://www.ostechnix.com/2016/05/'> May 2016 &nbsp;(13)</option>
<option value='https://www.ostechnix.com/2016/04/'> April 2016 &nbsp;(20)</option>
<option value='https://www.ostechnix.com/2016/03/'> March 2016 &nbsp;(26)</option>
<option value='https://www.ostechnix.com/2016/02/'> February 2016 &nbsp;(22)</option>
<option value='https://www.ostechnix.com/2016/01/'> January 2016 &nbsp;(4)</option>
<option value='https://www.ostechnix.com/2015/11/'> November 2015 &nbsp;(1)</option>
<option value='https://www.ostechnix.com/2015/10/'> October 2015 &nbsp;(5)</option>
<option value='https://www.ostechnix.com/2015/09/'> September 2015 &nbsp;(9)</option>
<option value='https://www.ostechnix.com/2015/08/'> August 2015 &nbsp;(1)</option>
<option value='https://www.ostechnix.com/2013/12/'> December 2013 &nbsp;(3)</option>
<option value='https://www.ostechnix.com/2013/04/'> April 2013 &nbsp;(1)</option>
<option value='https://www.ostechnix.com/2013/03/'> March 2013 &nbsp;(2)</option>
<option value='https://www.ostechnix.com/2013/02/'> February 2013 &nbsp;(3)</option>
<option value='https://www.ostechnix.com/2013/01/'> January 2013 &nbsp;(10)</option>
<option value='https://www.ostechnix.com/2012/12/'> December 2012 &nbsp;(6)</option>
<option value='https://www.ostechnix.com/2012/11/'> November 2012 &nbsp;(1)</option>
</select>
<script type="text/javascript">
/* <![CDATA[ */
(function() {
	var dropdown = document.getElementById( "archives-dropdown-4" );
	function onSelectChange() {
		if ( dropdown.options[ dropdown.selectedIndex ].value !== '' ) {
			document.location.href = this.options[ this.selectedIndex ].value;
		}
	}
	dropdown.onchange = onSelectChange;
})();
/* ]]> */
</script>
</div> </div>
<div class="footer-widget-3 grid one-third last">
<div id="pages-5" class="widget widget_pages"><h3 class="widget-title">Who we are</h3> <ul>
<li class="page_item page-item-676"><a href="https://www.ostechnix.com/about/">About</a></li>
<li class="page_item page-item-660"><a href="https://www.ostechnix.com/contact-us/">Contact Us</a></li>
<li class="page_item page-item-7410"><a href="https://www.ostechnix.com/donate/">Donate</a></li>
<li class="page_item page-item-1103"><a href="https://www.ostechnix.com/privacy-policy/">Privacy Policy</a></li>
<li class="page_item page-item-1096"><a href="https://www.ostechnix.com/terms-and-conditions/">Terms and Conditions</a></li>
</ul>
</div> </div>
</div>
</div>
</section>
<section class="container" id="footer-bottom">
<div class="container-inner">
<a id="back-to-top" href="#"><i class="fa fa-angle-up"></i></a>
<div class="pad group">
<div class="grid one-half">
<img id="footer-logo" src="https://www.ostechnix.com/wp-content/uploads/2016/10/cropped-OSTechNix_280915-01-1.png" alt="">
<div id="copyright">
<p>OSTechNix &copy; 2020. All Rights Reserved.</p>
</div>
<div id="credit">
<p>This site is licensed under <a href="http://creativecommons.org/licenses/by-nc/4.0/" rel="nofollow">CC BY-NC 4.0</a>. </div>
</div>
<div class="grid one-half last">
<ul class="social-links"><li><a rel="nofollow noopener noreferrer" class="social-tooltip" title="Follow us on Reddit-square" aria-label="Follow us on Reddit-square" href="https://www.reddit.com/r/OSTechNix/" target="_blank"><i class="fab fa-reddit-square"></i></a></li><li><a rel="nofollow noopener noreferrer" class="social-tooltip" title="Follow us on Facebook-square" aria-label="Follow us on Facebook-square" href="https://www.facebook.com/ostechnix/" target="_blank" style="color:rgba(255,255,255,0.7)"><i class="fab fa-facebook-square"></i></a></li><li><a rel="nofollow noopener noreferrer" class="social-tooltip" title="Follow us on Twitter-square" aria-label="Follow us on Twitter-square" href="https://twitter.com/ostechnix" target="_blank" style="color:rgba(255,255,255,0.7)"><i class="fab fa-twitter-square"></i></a></li><li><a rel="nofollow noopener noreferrer" class="social-tooltip" title="Follow us on Linkedin-square" aria-label="Follow us on Linkedin-square" href="https://in.linkedin.com/in/ostechnix" target="_blank" style="color:rgba(255,255,255,0.7)"><i class="fab fa-linkedin"></i></a></li><li><a rel="nofollow noopener noreferrer" class="social-tooltip" title="Follow us on Rss" aria-label="Follow us on Rss" href="http://feeds.feedburner.com/Ostechnix" target="_blank" style="color:rgba(255,255,255,0.7)"><i class="fas fa-rss"></i></a></li></ul> </div>
</div>
</div>
</section>
</footer>
</div>
<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/www.ostechnix.com\/how-to-list-all-users-in-linux\/":23523};
	</script>
<script type='text/javascript'>
/* <![CDATA[ */
var WfcFrontParams = {"effectsAndIconsSelectorCandidates":[],"wfcOptions":null};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.ostechnix.com/wp-content/themes/hueman-pro/addons/pro/wfc/front/assets/js/font-customizer-front.min.js?ver=3.1.0'></script>
<script type='text/javascript' src='https://www.ostechnix.com/wp-content/themes/hueman-pro/addons/assets/front/js/jQuerySharrre.min.js?ver=5.4.1'></script>
<script type='text/javascript' src='https://www.ostechnix.com/wp-includes/js/underscore.min.js?ver=1.8.3'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var HUParams = {"_disabled":[],"SmoothScroll":{"Enabled":false,"Options":{"touchpadSupport":false}},"centerAllImg":"1","timerOnScrollAllBrowsers":"1","extLinksStyle":"1","extLinksTargetExt":"1","extLinksSkipSelectors":{"classes":["btn","button"],"ids":[]},"imgSmartLoadEnabled":"1","imgSmartLoadOpts":{"parentSelectors":[".container .content",".container .sidebar","#footer","#header-widgets"],"opts":{"excludeImg":[".tc-holder-img"],"fadeIn_options":100,"threshold":0}},"goldenRatio":"1.618","gridGoldenRatioLimit":"350","sbStickyUserSettings":{"desktop":false,"mobile":false},"sidebarOneWidth":"340","sidebarTwoWidth":"260","isWPMobile":"","menuStickyUserSettings":{"desktop":"stick_up","mobile":"stick_up"},"mobileSubmenuExpandOnClick":"","submenuTogglerIcon":"<i class=\"fas fa-angle-down\"><\/i>","isDevMode":"","ajaxUrl":"https:\/\/www.ostechnix.com\/?huajax=1","frontNonce":{"id":"HuFrontNonce","handle":"f9a7efe561"},"isWelcomeNoteOn":"","welcomeContent":"","i18n":{"collapsibleExpand":"Expand","collapsibleCollapse":"Collapse"},"deferFontAwesome":"","fontAwesomeUrl":"https:\/\/www.ostechnix.com\/wp-content\/themes\/hueman-pro\/assets\/front\/css\/font-awesome.min.css?1.2.9","mainScriptUrl":"https:\/\/www.ostechnix.com\/wp-content\/themes\/hueman-pro\/assets\/front\/js\/scripts.min.js?1.2.9","flexSliderNeeded":"","flexSliderOptions":{"is_rtl":false,"has_touch_support":true,"is_slideshow":true,"slideshow_speed":5000},"fitTextMap":{"single_post_title":{"selectors":".single h1.entry-title","minEm":1.375,"maxEm":2.62000000000000010658141036401502788066864013671875},"page_title":{"selectors":".page-title h1","minEm":1,"maxEm":1.3000000000000000444089209850062616169452667236328125},"home_page_title":{"selectors":".home .page-title","minEm":1,"maxEm":1.1999999999999999555910790149937383830547332763671875,"compression":2.5},"post_titles":{"selectors":".blog .post-title, .archive .post-title","minEm":1.375,"maxEm":1.475000000000000088817841970012523233890533447265625},"featured_post_titles":{"selectors":".featured .post-title","minEm":1.375,"maxEm":2.125},"comments":{"selectors":".commentlist li","minEm":0.8125,"maxEm":0.93000000000000004884981308350688777863979339599609375,"compression":2.5},"entry":{"selectors":".entry","minEm":0.9375,"maxEm":1.125,"compression":2.5},"content_h1":{"selectors":".entry h1, .woocommerce div.product h1.product_title","minEm":1.7578125,"maxEm":2.671875},"content_h2":{"selectors":".entry h2","minEm":1.5234375,"maxEm":2.390625},"content_h3":{"selectors":".entry h3","minEm":1.40625,"maxEm":1.96875},"content_h4":{"selectors":".entry h4","minEm":1.2890625,"maxEm":1.6875},"content_h5":{"selectors":".entry h5","minEm":1.0546875,"maxEm":1.40625},"content_h6":{"selectors":".entry h6","minEm":0.9375,"maxEm":1.265625,"compression":2.5}},"userFontSize":"18","fitTextCompression":"1.5"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.ostechnix.com/wp-content/themes/hueman-pro/assets/front/js/scripts.min.js?ver=1.2.9' defer></script>
<script type='text/javascript' src='https://www.ostechnix.com/wp-includes/js/comment-reply.min.js?ver=5.4.1'></script>
<script type='text/javascript' src='https://www.ostechnix.com/wp-content/themes/hueman-pro/addons/pro/header/assets/front/vendors/flickity.min.js?ver=1.2.9'></script>
<script type='text/javascript' src='https://www.ostechnix.com/wp-includes/js/wp-embed.min.js?ver=5.4.1'></script>
<script async="async" type='text/javascript' src='https://www.ostechnix.com/wp-content/plugins/akismet/_inc/form.js?ver=4.1.5'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.ostechnix.com/wp-content/plugins/jetpack/_inc/build/sharedaddy/sharing.min.js?ver=8.5'></script>
<script type='text/javascript'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-linkedin', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomlinkedin', 'menubar=1,resizable=1,width=580,height=450' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-telegram', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtelegram', 'menubar=1,resizable=1,width=450,height=450' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-pocket', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcompocket', 'menubar=1,resizable=1,width=450,height=450' );
				return false;
			});
</script>
<!--[if lt IE 9]>
<script src="https://www.ostechnix.com/wp-content/themes/hueman-pro/assets/front/js/ie/respond.js"></script>
<![endif]-->
<script type='text/javascript' src='https://stats.wp.com/e-202020.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:8.5',blog:'84551477',post:'23523',tz:'5.5',srv:'www.ostechnix.com'} ]);
	_stq.push([ 'clickTrackerInit', '84551477', '23523' ]);
</script>
</body>
</html>
