<!DOCTYPE html>
<html class="no-js" lang="en-US" prefix="og: http://ogp.me/ns#">
<head>
  <meta charset="UTF-8">
  <meta name="viewport" content="width=device-width, initial-scale=1.0">
  <link rel="profile" href="http://gmpg.org/xfn/11">
  <link rel="pingback" href="https://www.ostechnix.com/xmlrpc.php">

  <title>Bashhub - Access Your Terminal History From Anywhere - OSTechNix</title>
<script>document.documentElement.className = document.documentElement.className.replace("no-js","js");</script>

<!-- This site is optimized with the Yoast SEO plugin v5.8 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="keywords" content="Bashhub, Access Your Terminal History From Anywhere, History, Python, Linux, CLI, BASH, Zsh, Open source"/>
<link rel="canonical" href="https://www.ostechnix.com/bashhub-access-terminal-history-anywhere/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Bashhub - Access Your Terminal History From Anywhere - OSTechNix" />
<meta property="og:description" content="As you already know, all commands you run on your shell will be saved and you can view them at any time either by using history command or using UP/Down arrows keys or doing a&#046;&#046;&#046;" />
<meta property="og:url" content="https://www.ostechnix.com/bashhub-access-terminal-history-anywhere/" />
<meta property="og:site_name" content="OSTechNix" />
<meta property="article:publisher" content="https://www.facebook.com/ostechnix/" />
<meta property="article:tag" content="Access Your Terminal History" />
<meta property="article:tag" content="BASH" />
<meta property="article:tag" content="Bashhub" />
<meta property="article:tag" content="CLI" />
<meta property="article:tag" content="history" />
<meta property="article:tag" content="Linux" />
<meta property="article:tag" content="Python" />
<meta property="article:tag" content="ZSH" />
<meta property="article:section" content="Command line utilities" />
<meta property="article:published_time" content="2017-11-28T19:57:16+05:30" />
<meta property="og:image" content="https://www.ostechnix.com/wp-content/uploads/2017/11/BASH.jpg" />
<meta property="og:image:secure_url" content="https://www.ostechnix.com/wp-content/uploads/2017/11/BASH.jpg" />
<meta property="og:image:width" content="900" />
<meta property="og:image:height" content="405" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:description" content="As you already know, all commands you run on your shell will be saved and you can view them at any time either by using history command or using UP/Down arrows keys or doing a&#046;&#046;&#046;" />
<meta name="twitter:title" content="Bashhub - Access Your Terminal History From Anywhere - OSTechNix" />
<meta name="twitter:site" content="@ostechnix" />
<meta name="twitter:image" content="https://www.ostechnix.com/wp-content/uploads/2017/11/BASH.jpg" />
<meta name="twitter:creator" content="@ostechnix" />
<script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"WebSite","@id":"#website","url":"https:\/\/www.ostechnix.com\/","name":"OSTechNix","potentialAction":{"@type":"SearchAction","target":"https:\/\/www.ostechnix.com\/?s={search_term_string}","query-input":"required name=search_term_string"}}</script>
<script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"Person","url":"https:\/\/www.ostechnix.com\/bashhub-access-terminal-history-anywhere\/","sameAs":["https:\/\/www.facebook.com\/ostechnix\/","https:\/\/in.linkedin.com\/in\/ostechnix","https:\/\/twitter.com\/ostechnix"],"@id":"#person","name":"Senthilkumar Palani"}</script>
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//secure.gravatar.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="OSTechNix &raquo; Feed" href="https://www.ostechnix.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="OSTechNix &raquo; Comments Feed" href="https://www.ostechnix.com/comments/feed/" />
<link id="hu-user-gfont" href="//fonts.googleapis.com/css?family=Ubuntu:400,400italic,300italic,300,700&subset=latin,latin-ext" rel="stylesheet" type="text/css"><link rel="alternate" type="application/rss+xml" title="OSTechNix &raquo; Bashhub &#8211; Access Your Terminal History From Anywhere Comments Feed" href="https://www.ostechnix.com/bashhub-access-terminal-history-anywhere/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.ostechnix.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56794,8205,9794,65039],[55358,56794,8203,9794,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='responsive-lightbox-swipebox-css'  href='https://www.ostechnix.com/wp-content/plugins/responsive-lightbox/assets/swipebox/css/swipebox.min.css?ver=1.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='hueman-main-style-css'  href='https://www.ostechnix.com/wp-content/themes/hueman/assets/front/css/main.min.css?ver=3.3.25' type='text/css' media='all' />
<style id='hueman-main-style-inline-css' type='text/css'>
body { font-family:'Ubuntu', Arial, sans-serif;font-size:1.00rem }@media only screen and (min-width: 720px) {
        .nav > li { font-size:1.00rem; }
      }::selection { background-color: #3b8dbd; }
::-moz-selection { background-color: #3b8dbd; }a,.themeform label .required,#flexslider-featured .flex-direction-nav .flex-next:hover,#flexslider-featured .flex-direction-nav .flex-prev:hover,.post-hover:hover .post-title a,.post-title a:hover,.sidebar.s1 .post-nav li a:hover i,.content .post-nav li a:hover i,.post-related a:hover,.sidebar.s1 .widget_rss ul li a,#footer .widget_rss ul li a,.sidebar.s1 .widget_calendar a,#footer .widget_calendar a,.sidebar.s1 .alx-tab .tab-item-category a,.sidebar.s1 .alx-posts .post-item-category a,.sidebar.s1 .alx-tab li:hover .tab-item-title a,.sidebar.s1 .alx-tab li:hover .tab-item-comment a,.sidebar.s1 .alx-posts li:hover .post-item-title a,#footer .alx-tab .tab-item-category a,#footer .alx-posts .post-item-category a,#footer .alx-tab li:hover .tab-item-title a,#footer .alx-tab li:hover .tab-item-comment a,#footer .alx-posts li:hover .post-item-title a,.comment-tabs li.active a,.comment-awaiting-moderation,.child-menu a:hover,.child-menu .current_page_item > a,.wp-pagenavi a{ color: #3b8dbd; }.themeform input[type="submit"],.themeform button[type="submit"],.sidebar.s1 .sidebar-top,.sidebar.s1 .sidebar-toggle,#flexslider-featured .flex-control-nav li a.flex-active,.post-tags a:hover,.sidebar.s1 .widget_calendar caption,#footer .widget_calendar caption,.author-bio .bio-avatar:after,.commentlist li.bypostauthor > .comment-body:after,.commentlist li.comment-author-admin > .comment-body:after{ background-color: #3b8dbd; }.post-format .format-container { border-color: #3b8dbd; }.sidebar.s1 .alx-tabs-nav li.active a,#footer .alx-tabs-nav li.active a,.comment-tabs li.active a,.wp-pagenavi a:hover,.wp-pagenavi a:active,.wp-pagenavi span.current{ border-bottom-color: #3b8dbd!important; }.sidebar.s2 .post-nav li a:hover i,
.sidebar.s2 .widget_rss ul li a,
.sidebar.s2 .widget_calendar a,
.sidebar.s2 .alx-tab .tab-item-category a,
.sidebar.s2 .alx-posts .post-item-category a,
.sidebar.s2 .alx-tab li:hover .tab-item-title a,
.sidebar.s2 .alx-tab li:hover .tab-item-comment a,
.sidebar.s2 .alx-posts li:hover .post-item-title a { color: #82b965; }
.sidebar.s2 .sidebar-top,.sidebar.s2 .sidebar-toggle,.post-comments,.jp-play-bar,.jp-volume-bar-value,.sidebar.s2 .widget_calendar caption{ background-color: #82b965; }.sidebar.s2 .alx-tabs-nav li.active a { border-bottom-color: #82b965; }
.post-comments span:before { border-right-color: #82b965; }
      .search-expand,
              #nav-topbar.nav-container { background-color: #00aeef}@media only screen and (min-width: 720px) {
                #nav-topbar .nav ul { background-color: #00aeef; }
              }.is-scrolled #header .nav-container.desktop-sticky,
              .is-scrolled #header .search-expand { background-color: #00aeef; background-color: rgba(0,174,239,0.90) }.is-scrolled .topbar-transparent #nav-topbar.desktop-sticky .nav ul { background-color: #00aeef; background-color: rgba(0,174,239,0.95) }#header { background-color: #eaeaea; }
@media only screen and (min-width: 720px) {
  #nav-header .nav ul { background-color: #eaeaea; }
}
        #header #nav-mobile { background-color: #33363b; }.is-scrolled #header #nav-mobile { background-color: #33363b; background-color: rgba(51,54,59,0.90) }#nav-header.nav-container, #main-header-search .search-expand { background-color: #ef4423; }
@media only screen and (min-width: 720px) {
  #nav-header .nav ul { background-color: #ef4423; }
}
        .site-title a img { max-height: 120px; }body { background-color: #eaeaea; }
</style>
<link rel='stylesheet' id='theme-stylesheet-css'  href='https://www.ostechnix.com/wp-content/themes/ostechnix_child_theme/style.css?ver=3.3.25' type='text/css' media='all' />
<link rel='stylesheet' id='hueman-font-awesome-css'  href='https://www.ostechnix.com/wp-content/themes/hueman/assets/front/css/font-awesome.min.css?ver=3.3.25' type='text/css' media='all' />
<!-- Inline jetpack_facebook_likebox -->
<style id='jetpack_facebook_likebox-inline-css' type='text/css'>
.widget_facebook_likebox {
	overflow: hidden;
}

</style>
<link rel='stylesheet' id='an_style-css'  href='https://www.ostechnix.com/wp-content/uploads/UWMayjOEbsuO/ilwNfyAFDGPI.css?ver=2.2.3' type='text/css' media='all' />
<style id='an_style-inline-css' type='text/css'>
/*	an_style.css	AdBlock Notify	Copyright: (c) 2016 Themeisle, themeisle.com	Version: 2.2.2*/.AfgjetQapDaN-bg {	display: none;	position: fixed;	z-index: 100;	top: 0;	left: 0;	width: 100%;	height: 100%;	background: #000;	background: rgba(0,0,0,0.75);}.AfgjetQapDaN {	visibility: hidden;	position: fixed;	z-index: 101;	top: 100px;	right: 0;	left: 0;	max-width: 640px;	margin-right: auto;	margin-left: auto;	background: #fff;	-webkit-box-shadow: 0 3px 5px 2px rgba(0,0,0,0.25);	box-shadow: 0 3px 5px 2px rgba(0,0,0,0.25);	font-family: Arial, Helvetica, sans-serif;}.AfgjetQapDaN-default,.AfgjetQapDaN-ok {	padding: 30px 30px 15px;}.AfgjetQapDaN-image {	overflow: hidden;	position: relative;	width: 100%;}.AfgjetQapDaN-image .AfgjetQapDaN-left {	position: absolute;	top: 0;	left: 0;	width: 50%;	height: 100%;}.AfgjetQapDaN-image .AfgjetQapDaN-right {	float: right;	width: 50%;	padding: 30px;}.AfgjetQapDaN.small {	width: 200px;	margin-left: -140px;}.AfgjetQapDaN.medium {	width: 400px;	margin-left: -240px;}.AfgjetQapDaN.large {	width: 600px;	margin-left: -340px;}.AfgjetQapDaN.xlarge {	width: 800px;	margin-left: -440px;}.close-AfgjetQapDaN {	display: inline-block;	position: absolute;	top: 15px;	right: 15px;	width: 30px;	height: 30px;	color: #bbb;	font-size: 32px;	font-weight: 700;	line-height: 30px;	text-align: center;	cursor: pointer;	-webkit-transition: 0.3s;	transition: 0.3s;}.close-AfgjetQapDaN:hover {	color: #252b37;}.AfgjetQapDaN h1 {	margin-bottom: 15px;	padding: 0 30px;	color: #252b37;	font-size: 28px;	line-height: 1.25;	text-align: center;}.AfgjetQapDaN-right h1 {	padding: 0 30px 0 0;	text-align: left;}.AfgjetQapDaN p {	margin-bottom: 15px;	color: #333745;	font-size: 14px;}.AfgjetQapDaN p a {	color: #ff6160;}.AfgjetQapDaN-right .close-modal,.AfgjetQapDaN-footer .close-modal {	padding: 15px !important;	border-radius: 0 !important;	background-color: #ff6160;	font-size: 14px;	letter-spacing: 2px !important;	-webkit-transition: 0.3s;	transition: 0.3s;}.AfgjetQapDaN-right .close-modal:hover,.AfgjetQapDaN-footer .close-modal:hover {	background-color: #252b37 !important;}.AfgjetQapDaN-footer .grey-button-modal {	margin-right: 15px;	background-color: #a5a5a5;}.AfgjetQapDaN-footer {	display: block;	padding: 15px 30px;	background-color: #eff4f7;	text-align: right;}@media only screen and (max-width: 640px) {	.AfgjetQapDaN {		right: 5%;		left: 5%;		max-width: 90%;	}	.AfgjetQapDaN-default {		padding: 20px;	}	.AfgjetQapDaN-image .AfgjetQapDaN-left {		width: 100%;		height: 250px;	}	.AfgjetQapDaN-image .AfgjetQapDaN-right {		float: left;		width: 100%;		margin-top: 250px;		padding: 20px;	}	.AfgjetQapDaN h1 {		margin-bottom: 10px;		font-size: 20px;	}	.AfgjetQapDaN-right h1 {		padding: 0;	}	.AfgjetQapDaN p {		margin-bottom: 10px;	}	.close-AfgjetQapDaN {		color: #fcfcfc;		background-color: #252b37;	}	.close-AfgjetQapDaN:hover {		color: #252b37;		background-color: #fcfcfc;	}	.AfgjetQapDaN-footer {		padding: 15px 20px;	}}@media only screen and (max-width: 480px) {	.AfgjetQapDaN-image .AfgjetQapDaN-left {		height: 200px;	}	.AfgjetQapDaN-image .AfgjetQapDaN-right {		margin-top: 200px;	}	.AfgjetQapDaN-footer {		text-align: center;	}	.AfgjetQapDaN-footer .close-modal {		width: 80%;		margin: 5px 10%;	}}
</style>
<link rel='stylesheet' id='social-logos-css'  href='https://www.ostechnix.com/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css?ver=1' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://www.ostechnix.com/wp-content/plugins/jetpack/css/jetpack.css?ver=5.5.1' type='text/css' media='all' />
<script type='text/javascript' src='https://www.ostechnix.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='https://www.ostechnix.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://www.ostechnix.com/wp-content/plugins/responsive-lightbox/assets/swipebox/js/jquery.swipebox.min.js?ver=1.7.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var rlArgs = {"script":"swipebox","selector":"lightbox","customEvents":"","activeGalleries":"1","animation":"1","hideCloseButtonOnMobile":"0","removeBarsOnMobile":"0","hideBars":"1","hideBarsDelay":"5000","videoMaxWidth":"1080","useSVG":"1","loopAtEnd":"0","woocommerce_gallery":"0"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.ostechnix.com/wp-content/plugins/responsive-lightbox/js/front.js?ver=1.7.2'></script>
<script type='text/javascript' async defer src='https://apis.google.com/js/platform.js?ver=4.9'></script>
<link rel='https://api.w.org/' href='https://www.ostechnix.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.ostechnix.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.ostechnix.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 4.9" />
<link rel='shortlink' href='https://wp.me/p5ILHv-2Tp' />
<link rel="alternate" type="application/json+oembed" href="https://www.ostechnix.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.ostechnix.com%2Fbashhub-access-terminal-history-anywhere%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.ostechnix.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.ostechnix.com%2Fbashhub-access-terminal-history-anywhere%2F&#038;format=xml" />
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
  (adsbygoogle = window.adsbygoogle || []).push({
    google_ad_client: "ca-pub-6701402139964678",
    enable_page_level_ads: true
  });
</script>
<link rel='dns-prefetch' href='//v0.wordpress.com'/>
<style type='text/css'>img#wpstats{display:none}</style><!--[if lt IE 9]>
<script src="https://www.ostechnix.com/wp-content/themes/hueman/assets/front/js/ie/html5shiv-printshiv.min.js"></script>
<script src="https://www.ostechnix.com/wp-content/themes/hueman/assets/front/js/ie/selectivizr.js"></script>
<![endif]-->
<link rel="icon" href="https://www.ostechnix.com/wp-content/uploads/2016/10/cropped-favicon-500x500-150x150.png" sizes="32x32" />
<link rel="icon" href="https://www.ostechnix.com/wp-content/uploads/2016/10/cropped-favicon-500x500-300x300.png" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://www.ostechnix.com/wp-content/uploads/2016/10/cropped-favicon-500x500-300x300.png" />
<meta name="msapplication-TileImage" content="https://www.ostechnix.com/wp-content/uploads/2016/10/cropped-favicon-500x500-300x300.png" />
			<style type="text/css" id="wp-custom-css">
				/*
You can add your own CSS here.

Click the help icon above to learn more.

Use this field to test small chunks of CSS code. For important CSS customizations, it is recommended to modify the style.css file of a child theme.
http//codex.wordpress.org/Child_Themes
*/
			</style>
		</head>

<body class="post-template-default single single-post postid-11123 single-format-image wp-custom-logo col-2cl full-width topbar-enabled header-desktop-sticky unknown">

<div id="wrapper">

  
  <header id="header" class="both-menus-mobile-on two-mobile-menus both_menus header-ads-desktop header-ads-mobile topbar-transparent no-header-img">
  
        <nav class="nav-container group desktop-menu desktop-sticky " id="nav-topbar" data-menu-id="header-1">
                <!-- <div class="ham__navbar-toggler collapsed" aria-expanded="false">
          <div class="ham__navbar-span-wrapper">
            <span class="ham-toggler-menu__span"></span>
          </div>
        </div> -->
        <div class="ham__navbar-toggler-two collapsed" title="Menu" aria-expanded="false">
          <div class="ham__navbar-span-wrapper">
            <span class="line line-1"></span>
            <span class="line line-2"></span>
            <span class="line line-3"></span>
          </div>
        </div>
              <div class="nav-text"></div>
  <div class="topbar-toggle-down">
    <i class="fa fa-angle-double-down" aria-hidden="true" data-toggle="down" title="Expand menu"></i>
    <i class="fa fa-angle-double-up" aria-hidden="true" data-toggle="up" title="Collapse menu"></i>
  </div>
  <div class="nav-wrap container">
    <ul id="menu-top-menu" class="nav container-inner group"><li id="menu-item-9" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-9"><a href="http://www.ostechnix.com/">Home</a></li>
<li id="menu-item-11" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-11"><a target="_blank" href="https://www.ostechnix.com/category/opensource/">Open Source</a></li>
<li id="menu-item-10" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10"><a target="_blank" href="https://www.ostechnix.com/category/technology/">Technology</a></li>
<li id="menu-item-12" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-12"><a target="_blank" href="https://www.ostechnix.com/category/linux/">Linux</a>
<ul class="sub-menu">
	<li id="menu-item-14" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14"><a href="https://www.ostechnix.com/category/linux-basics/">Linux Basics</a></li>
	<li id="menu-item-15" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-15"><a href="https://www.ostechnix.com/category/linux_distributions/">Linux Distributions</a>
	<ul class="sub-menu">
		<li id="menu-item-16" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16"><a href="https://www.ostechnix.com/category/linux_distributions/arch-linux/">Arch Linux</a></li>
		<li id="menu-item-17" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-17"><a href="https://www.ostechnix.com/category/linux_distributions/centos/">CentOS</a></li>
		<li id="menu-item-18" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-18"><a href="https://www.ostechnix.com/category/linux_distributions/debian/">Debian</a></li>
		<li id="menu-item-19" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-19"><a href="https://www.ostechnix.com/category/linux_distributions/fedora/">Fedora</a></li>
		<li id="menu-item-20" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-20"><a href="https://www.ostechnix.com/category/linux_distributions/linuxmint/">Linux Mint</a></li>
		<li id="menu-item-21" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-21"><a href="https://www.ostechnix.com/category/linux_distributions/mageia/">Mageia</a></li>
		<li id="menu-item-22" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22"><a href="https://www.ostechnix.com/category/linux_distributions/mandrake/">Mandrake</a></li>
		<li id="menu-item-23" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-23"><a href="https://www.ostechnix.com/category/linux_distributions/mandriva/">Mandriva</a></li>
		<li id="menu-item-24" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-24"><a href="https://www.ostechnix.com/category/linux_distributions/opensuse/">openSUSE</a></li>
		<li id="menu-item-929" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-929"><a href="https://www.ostechnix.com/category/linux_distributions/red-hat-enterprise-linux/">Red Hat Enterprise Linux</a></li>
		<li id="menu-item-930" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-930"><a href="https://www.ostechnix.com/category/linux_distributions/scientific-linux/">Scientific Linux</a></li>
	</ul>
</li>
</ul>
</li>
<li id="menu-item-13" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-13"><a target="_blank" href="https://www.ostechnix.com/category/unix/">Unix</a>
<ul class="sub-menu">
	<li id="menu-item-931" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-931"><a href="https://www.ostechnix.com/category/unix/freebsd/">FreeBSD</a></li>
</ul>
</li>
<li id="menu-item-5925" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5925"><a target="_blank" href="http://ostechnix.tradepub.com/category/information-technology/1207/">Free Videos and EBooks</a></li>
<li id="menu-item-7430" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-7430"><a target="_blank" href="https://www.ostechnix.com/donate/">Donate</a></li>
</ul>  </div>
      <div id="topbar-header-search" class="container">
      <div class="container-inner">
        <div class="toggle-search"><i class="fa fa-search"></i></div>
        <div class="search-expand">
          <div class="search-expand-inner"><form method="get" class="searchform themeform" action="https://www.ostechnix.com/">
	<div>
		<input type="text" class="search" name="s" onblur="if(this.value=='')this.value='To search type and hit enter';" onfocus="if(this.value=='To search type and hit enter')this.value='';" value="To search type and hit enter" />
	</div>
</form></div>
        </div>
      </div><!--/.container-inner-->
    </div><!--/.container-->
  
</nav><!--/#nav-topbar-->  
  <div class="container group">
        <div class="container-inner">

                    <div class="group pad central-header-zone">
                  <div class="logo-tagline-group">
                                        <p class="site-title"><a class="custom-logo-link" href="https://www.ostechnix.com/" rel="home" title="OSTechNix | Home page"><img src="https://www.ostechnix.com/wp-content/uploads/2016/12/cropped-OSTechNix.png" alt="OSTechNix"></a></p>
                                                        </div>

                                        <div id="header-widgets">
                          <div id="text-7" class="widget widget_text">			<div class="textwidget"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- os-header -->
<ins class="adsbygoogle"
     style="display:inline-block;width:728px;height:90px"
     data-ad-client="ca-pub-6701402139964678"
     data-ad-slot="3238338142"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
		</div>                      </div><!--/#header-ads-->
                                </div>
      
                <nav class="nav-container group desktop-menu " id="nav-header" data-menu-id="header-2">
                <!-- <div class="ham__navbar-toggler collapsed" aria-expanded="false">
          <div class="ham__navbar-span-wrapper">
            <span class="ham-toggler-menu__span"></span>
          </div>
        </div> -->
        <div class="ham__navbar-toggler-two collapsed" title="Menu" aria-expanded="false">
          <div class="ham__navbar-span-wrapper">
            <span class="line line-1"></span>
            <span class="line line-2"></span>
            <span class="line line-3"></span>
          </div>
        </div>
              <div class="nav-text"><!-- put your mobile menu text here --></div>

  <div class="nav-wrap container">
        <ul id="menu-header-menu" class="nav container-inner group"><li id="menu-item-940" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-940"><a target="_blank" href="https://www.ostechnix.com/category/backup-tools/">Backup tools</a></li>
<li id="menu-item-943" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-943"><a target="_blank" href="https://www.ostechnix.com/category/cloud/">Cloud</a></li>
<li id="menu-item-941" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-941"><a target="_blank" href="https://www.ostechnix.com/category/database/">Database</a></li>
<li id="menu-item-942" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-942"><a target="_blank" href="https://www.ostechnix.com/category/directory-servers/">Directory servers</a></li>
<li id="menu-item-944" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-944"><a target="_blank" href="https://www.ostechnix.com/category/mobile/">Mobile</a>
<ul class="sub-menu">
	<li id="menu-item-945" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-945"><a href="https://www.ostechnix.com/category/android/">Android</a></li>
</ul>
</li>
<li id="menu-item-939" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-939"><a target="_blank" href="https://www.ostechnix.com/category/reviews/">Reviews</a></li>
<li id="menu-item-932" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-932"><a target="_blank" href="https://www.ostechnix.com/category/security/">Security</a>
<ul class="sub-menu">
	<li id="menu-item-936" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-936"><a href="https://www.ostechnix.com/category/encryption-decryption/">Encryption / Decryption</a></li>
	<li id="menu-item-938" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-938"><a href="https://www.ostechnix.com/category/monitoring-tools/">Monitoring Tools</a></li>
</ul>
</li>
<li id="menu-item-933" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-933"><a target="_blank" href="https://www.ostechnix.com/category/tips-and-tricks/">Tips and Tricks</a>
<ul class="sub-menu">
	<li id="menu-item-937" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-937"><a href="https://www.ostechnix.com/category/internet-hacks/">Internet hacks</a></li>
</ul>
</li>
<li id="menu-item-934" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-934"><a target="_blank" href="https://www.ostechnix.com/category/trouble-shooting/">Trouble shooting</a></li>
<li id="menu-item-935" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-935"><a target="_blank" href="https://www.ostechnix.com/category/virtualization/">Virtualization</a></li>
</ul>  </div>
</nav><!--/#nav-header-->      
    </div><!--/.container-inner-->
      </div><!--/.container-->

</header><!--/#header-->
  
  <div class="container" id="page">
    <div class="container-inner">
            <div class="main">
        <div class="main-inner group">
          
              <section class="content">
              <div class="page-title pad group">
          	    		<ul class="meta-single group">
    			<li class="category"><a href="https://www.ostechnix.com/category/command-line-utilities/" rel="category tag">Command line utilities</a> <span>/</span> <a href="https://www.ostechnix.com/category/faq/" rel="category tag">FAQ</a> <span>/</span> <a href="https://www.ostechnix.com/category/linux/" rel="category tag">Linux</a> <span>/</span> <a href="https://www.ostechnix.com/category/linux-admnistration/" rel="category tag">Linux Admnistration</a> <span>/</span> <a href="https://www.ostechnix.com/category/linux-commands/" rel="category tag">Linux Commands</a> <span>/</span> <a href="https://www.ostechnix.com/category/opensource/" rel="category tag">Opensource</a> <span>/</span> <a href="https://www.ostechnix.com/category/utilities/" rel="category tag">Utilities</a></li>
    			    		</ul>

    	
    </div><!--/.page-title-->
          <div class="pad group">
              <article class="post-11123 post type-post status-publish format-image has-post-thumbnail hentry category-command-line-utilities category-faq category-linux category-linux-admnistration category-linux-commands category-opensource category-utilities tag-access-your-terminal-history tag-bash tag-bashhub tag-cli tag-history tag-linux tag-python tag-zsh post_format-post-format-image">
    <div class="post-inner group">

      <h1 class="post-title entry-title">Bashhub &#8211; Access Your Terminal History From Anywhere</h1>
<p class="post-byline">by   <span class="vcard author">
     <span class="fn"><a href="https://www.ostechnix.com/author/sk/" title="Posts by sk" rel="author">sk</a></span>
   </span> &middot;
                            <time class="published" datetime="November 28, 2017">November 28, 2017</time>
               </p>
      



  	<div class="post-format">
  		<div class="image-container">
  			<img  width="720" height="340"  src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://www.ostechnix.com/wp-content/uploads/2017/11/BASH-720x340.jpg"  class="attachment-thumb-large size-thumb-large wp-post-image" alt="Bashhub - Access Your Terminal History From Anywhere" data-srcset="https://www.ostechnix.com/wp-content/uploads/2017/11/BASH-720x340.jpg 720w, https://www.ostechnix.com/wp-content/uploads/2017/11/BASH-520x245.jpg 520w" data-sizes="(max-width: 720px) 100vw, 720px" />  		</div>
	</div>






      <div class="clear"></div>

      <div class="entry themeform">
        <div class="entry-inner">
          <p>As you already know, all commands you run on your shell will be saved and you can view them at any time either by using <strong>history</strong> command or using UP/Down arrows keys or doing a reverse search using <strong>CTRL+R</strong> key combination from the Terminal. All commands that you run on the Terminal will be saved in <strong>.bash_history</strong> file. But you can view, access, and re-run them only from the same machine itself. What if you want to access your Terminal history from a different system on the network? No problem! Here is where <strong>&#8220;Bashhub&#8221;</strong> utility comes in help. It is a simple online web service where you can save all commands and access them from anywhere. Bashhub saves every commands entered across all sessions and systems, so you can access them from anywhere. To put this simply, your entire BASH history will be available in the cloud and the entire bash history is indexed, and searchable! Bashhub is completely free and open source.</p>
<!-- Quick Adsense WordPress Plugin: http://quickadsense.com/ -->
<div style="float:none;margin:10px 0 10px 0;text-align:center;">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- os-inside-post2 -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-6701402139964678"
     data-ad-slot="5359879344"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>

<p>All commands will be stored in Bashhub&#8217;s database which is encrypted using <strong>storage level encryption via LUKS</strong>. Bashhub will generate a unique identification token to each user. This token is mandatory to perform any actions on behalf of a user for the command api. All commands recorded on behalf of a user are only accessible using that user&#8217;s authentication token. There is currently no way to share these commands and they&#8217;re not publicly accessible. Also Bashhub allows you to ignore some commands that contains sensitive information like user&#8217;s password. You can safely ignore such commands from being recorded by Bashhub to turn off the recording completely at any time.</p>
<h4>Installing Bashhub</h4>
<p>Make sure you have installed <strong>Python 2.7</strong> on your system. Python 2.7 is available in the default repositories of most Linux distributions, so you can install it using your distribution&#8217;s package manager. For example, run the following command to install python 2.7 on Debian and variants.</p>
<pre>sudo apt-get install python2.7</pre>
<p>After installing Python 2.7, run any one of the commands given below depending upon the SHELL you use.</p>
<p>If your shell is <strong>BASH</strong>, enter the following command:</p>
<div>
<pre>curl -OL https://bashhub.com/setup &amp;&amp; bash setup</pre>
</div>
<p>For <strong>Zsh</strong>:</p>
<div>
<pre>curl -OL https://bashhub.com/setup &amp;&amp; zsh setup</pre>
</div>
<p>After few minutes, you will be asked to create a new account if you don&#8217;t have already one. Enter a valid Email id, username and password and your system&#8217;s name.</p>
<pre>What's your email? <strong>sk@senthilkumar.com</strong>
What username would you like? <strong>sk</strong>
What password?

Email: sk@senthilkumar.com Username: sk
Are these correct? [Y/n] y
Registered new user sk

What do you want to call this system? For example Home, File Server, ect. [ubuntuserver]: 
Registered a new system ubuntuserver
Should be good to go! Please close and restart your terminal session.</pre>
<p>Done! Your account has been created at Bashhub. You can access your profile at <strong>https://bashhub.com/&lt;your-user-name&gt;</strong>. Bashub will create a directory named <strong>.bashhub</strong> that contains a few scripts and a python virtual environment in your $HOME directory.</p>
<p>If you&#8217;re an existing user, type &#8220;n&#8221; when you &#8216;re asked &#8220;Are you a new user?&#8221; and enter your registered Email and password.</p>
<p>Close and restart your Terminal to start recording your Terminal history.</p>
<h4>Access Your Terminal History From Anywhere</h4>
<p>Now, run any random commands to verify if it really works.</p>
<p>I ran the following commands:</p>
<pre>clear
pwd
uname -a
ls -l
touch test.txt</pre>
<p>Now it is time to check what commands I have entered.</p>
<p>To do so,run:</p>
<pre>bh</pre>
<p>Sample output:</p>
<p><a href="http://www.ostechnix.com/wp-content/uploads/2017/11/bashhub-1.png" data-rel="lightbox-0" title=""><img  class="aligncenter size-full wp-image-11128"  src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="http://www.ostechnix.com/wp-content/uploads/2017/11/bashhub-1.png"  alt="" width="656" height="437" data-srcset="https://www.ostechnix.com/wp-content/uploads/2017/11/bashhub-1.png 656w, https://www.ostechnix.com/wp-content/uploads/2017/11/bashhub-1-300x200.png 300w" data-sizes="(max-width: 656px) 100vw, 656px" /></a></p>
<p>This command will display the <strong>last 100 commands by default</strong>. You can override the default limit by using &#8220;-n&#8221; flag.</p>
<p>To display only the last 10 commands, run:</p>
<pre>bh -n 10</pre>
<p><strong>Display commands by using specific term</strong></p>
<p>You can also display a specific command by using specific term, for example &#8220;ls&#8221;.</p>
<p>bh -n 10 &#8220;ls&#8221;</p>
<p>If you want to search for a specific command with a search term and run it at the same time, use &#8220;-i&#8221; flag as shown below.</p>
<pre>bh -i "ls"</pre>
<p>If you&#8217;ve run command more than one time, choose the command you want to run from the list and hit enter.</p>
<p><a href="http://www.ostechnix.com/wp-content/uploads/2017/11/bashhub-2.png" data-rel="lightbox-1" title=""><img  class="aligncenter size-full wp-image-11129"  src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="http://www.ostechnix.com/wp-content/uploads/2017/11/bashhub-2.png"  alt="" width="656" height="468" data-srcset="https://www.ostechnix.com/wp-content/uploads/2017/11/bashhub-2.png 656w, https://www.ostechnix.com/wp-content/uploads/2017/11/bashhub-2-300x214.png 300w" data-sizes="(max-width: 656px) 100vw, 656px" /></a></p>
<p>As you see above, I have run &#8220;ls&#8221; command three times.</p>
<p><strong>Display the list of commands executed in a directory</strong></p>
<p>To display the list of last commands you executed in the current working directory, use &#8220;-d&#8221; flag.</p>
<pre>bh -d</pre>
<p>Bashhub will display the most recently used commands.</p>
<p><strong>Interactive search</strong></p>
<p>The other notable feature of Bashhub is interactive search. It is similar to reverse search, you can invoke it by pressing either <strong>bh -i</strong> or <strong>ctrl + b</strong> keys.</p>
<p>Let us do interactive search.</p>
<pre>$ bh -i
(bashhub-i-search): <strong>uname</strong></pre>
<p>The above command will search for for a command that has &#8220;uname&#8221; string. You can perform the interactive search in the current working directory using &#8220;-d&#8221; flag as shown below.</p>
<!-- Quick Adsense WordPress Plugin: http://quickadsense.com/ -->
<div style="float:none;margin:10px 0 10px 0;text-align:center;">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- os-post-inside -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-6701402139964678"
     data-ad-slot="8447266942"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>

<pre>$ bh -i -d
(bashhub-i-search): ls</pre>
<p><strong>Viewing the details of a command</strong></p>
<p>From interactive search, you can also view the detailed information of a command.</p>
<p>First launch the interactive search:</p>
<pre>bh -i</pre>
<p>Then choose the command from the list and hit &#8220;i&#8221; or &#8220;space bar&#8221; keys to display the selected command details.</p>
<p><a href="http://www.ostechnix.com/wp-content/uploads/2017/11/bashhub-3.png" data-rel="lightbox-2" title=""><img  class="aligncenter size-full wp-image-11130"  src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="http://www.ostechnix.com/wp-content/uploads/2017/11/bashhub-3.png"  alt="" width="656" height="437" data-srcset="https://www.ostechnix.com/wp-content/uploads/2017/11/bashhub-3.png 656w, https://www.ostechnix.com/wp-content/uploads/2017/11/bashhub-3-300x200.png 300w" data-sizes="(max-width: 656px) 100vw, 656px" /></a></p>
<p><strong>Delete commands</strong></p>
<p>You can also delete a particular command(s) from the Bashub database. To do so, launch the interactive search:</p>
<pre>bh -i "ls"</pre>
<p>Choose the command that you want to delete and hit &#8220;Backspace&#8221; or &#8220;Delete&#8221; keys from the keyboard.</p>
<p><a href="http://www.ostechnix.com/wp-content/uploads/2017/11/bashhub-4.png" data-rel="lightbox-3" title=""><img  class="aligncenter size-full wp-image-11131"  src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="http://www.ostechnix.com/wp-content/uploads/2017/11/bashhub-4.png"  alt="" width="656" height="437" data-srcset="https://www.ostechnix.com/wp-content/uploads/2017/11/bashhub-4.png 656w, https://www.ostechnix.com/wp-content/uploads/2017/11/bashhub-4-300x200.png 300w" data-sizes="(max-width: 656px) 100vw, 656px" /></a></p>
<p><strong>Ignore particular commands from recording</strong></p>
<p>This is another useful feature of the Bashhub utility. You can prevent a particular command that contains sensitive information like username or password from being recorded by bashhub.</p>
<p>To do so, just add <strong>#ignore</strong> at the end of the command.</p>
<p>Example:</p>
<pre>$ uname -r #ignore</pre>
<p>The above command&#8221; uname -r&#8221; will be recorded. Please note that <span class="c00">if you&#8217;ve already configured your history to <strong>ignore space</strong>, Bash will not save the commands if run them with a space at the start of those commands. In that case, you don&#8217;t need to use &#8220;#ignore&#8221;. </span></p>
<p><strong>Disable recording commands</strong></p>
<p>If you want Bashhub record the commands, you can turn it by running the following command:</p>
<pre>bashhub off</pre>
<p>The commands won&#8217;t be recorded anymore until you turn it on.</p>
<p>Please remember this only affects the current bash session by default. To disable recording of all sessions globally, run:</p>
<pre>bashhub off --global</pre>
<p>To turn on Bashhub recording again. run:</p>
<pre>bashhub on</pre>
<h4>Update Bashhub</h4>
<p>Just rerun the installation command to update Bashhub. Also, run &#8220;bashhub update&#8221; command to update it.</p>
<p><strong>Access Bashhub from a different system</strong></p>
<p><strong>Please note that</strong> you don&#8217;t need to run &#8220;bh&#8221; in the same system itself. Since all commands are stored in Bashhub&#8217;s database, you can view all your Terminal history from any system. Make sure you have installed Bashhub client on the system and login with the registered Email id and the password.</p>
<pre>Are you a new user? [Y/n] <strong>n</strong>
Please enter your bashhub credentials
Username: sk
Password:</pre>
<h4>Check the user statistics</h4>
<pre>bashhub status</pre>
<p>Sample output:</p>
<pre>=== Bashhub Status
https://bashhub.com/sk
Total Commands: 21
Total Sessions: 1
Total Systems: 1
===
Session PID 1154 Started 2 hours ago
Commands In Session: 21
Commands Today: 21</pre>
<h4>Uninstall Bashhub</h4>
<p>If you&#8217;re concerned about the privacy and security implications, Bashhub is not for you. You can uninstall it by removing the following directory from your system.</p>
<pre>rm -r ~/.bashhub</pre>
<p>For more details, refer the help section:</p>
<pre>$ bashhub 
Usage: bashhub [OPTIONS] COMMAND [ARGS]...

Bashhub command line client

Options:
 -V, --version Display version
 -h, --help Show this message and exit.

Commands:
 filter Check if a command is filtered from bashhub.
 help Show this message and exit
 off Turn off saving commands to Bashhub.
 on Turn on saving commands to Bashhub.
 save Save a command to Bashhub
 setup Run Bashhub user and system setup
 status Stats for this session and user
 update Update your Bashhub installation
 util Misc utils used by Bashhub
 version Display version</pre>
<p>And, that&#8217;s all for now folks. Hope you find this useful. More good stuffs to come. Stay tuned!</p>
<p>Cheers!</p>
<p><strong>Resource:</strong></p>
<ul>
<li><a href="https://github.com/rcaloras/bashhub-client" target="_blank" rel="noopener"><strong>Bashhub GitHub Repository</strong></a></li>
</ul>
<div class="after-post-box">
<p style="text-align: center;"><strong style="color: #ef4423; font-size: 20px;">Thanks for stopping by! </strong></p>
<h4>Help us to help you:</h4>
<ul>
<li>Subscribe to our Email Newsletter : <strong><a title="Subscribe to our Email newsletter" href="http://feedburner.google.com/fb/a/mailverify?uri=ostechnix" target="_blank" rel="nofollow noopener noreferrer">Sign Up Now</a></strong></li>
<li>Support OSTechNix : <strong><a title="Donate Via PayPal" href="https://www.paypal.me/ostechnix" target="_blank" rel="nofollow noopener noreferrer">Donate Via PayPal</a></strong></li>
<li>Download free E-Books and Videos : <a href="http://ostechnix.tradepub.com/category/information-technology/1207/" target="_blank" rel="noopener noreferrer"><strong>OSTechNix on TradePub</strong></a></li>
<li>Connect with us: <a href="https://www.facebook.com/ostechnix/" target="_blank" rel="noopener noreferrer"><strong>Facebook</strong></a> | <a href="https://twitter.com/ostechnix" target="_blank" rel="noopener noreferrer"><strong>Twitter</strong></a> | <strong><a href="https://plus.google.com/+SenthilkumarP/" target="_blank" rel="noopener noreferrer">Google Plus</a> </strong>|<strong> <a href="https://www.linkedin.com/in/ostechnix" target="_blank" rel="noopener noreferrer">LinkedIn</a> </strong>|<strong> <a href="http://feeds.feedburner.com/Ostechnix" target="_blank" rel="noopener noreferrer">RSS feeds</a></strong></li>
</ul>
<p style="text-align: center;"><strong style="color: #ef4423; font-size: 20px;">Have a Good day!!</strong></p>
</div>

<!-- Quick Adsense WordPress Plugin: http://quickadsense.com/ -->
<div style="float:none;margin:10px 0 10px 0;text-align:center;">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle"
     style="display:block"
     data-ad-format="autorelaxed"
     data-ad-client="ca-pub-6701402139964678"
     data-ad-slot="4635513743"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>

<div style="font-size:0px;height:0px;line-height:0px;margin:0;padding:0;clear:both"></div><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-reddit"><a rel="nofollow" data-shared="" class="share-reddit sd-button share-icon" href="https://www.ostechnix.com/bashhub-access-terminal-history-anywhere/?share=reddit" target="_blank" title="Click to share on Reddit"><span>Reddit</span></a></li><li class="share-twitter"><a rel="nofollow" data-shared="sharing-twitter-11123" class="share-twitter sd-button share-icon" href="https://www.ostechnix.com/bashhub-access-terminal-history-anywhere/?share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-facebook"><a rel="nofollow" data-shared="sharing-facebook-11123" class="share-facebook sd-button share-icon" href="https://www.ostechnix.com/bashhub-access-terminal-history-anywhere/?share=facebook" target="_blank" title="Click to share on Facebook"><span>Facebook</span></a></li><li class="share-google-plus-1"><a rel="nofollow" data-shared="sharing-google-11123" class="share-google-plus-1 sd-button share-icon" href="https://www.ostechnix.com/bashhub-access-terminal-history-anywhere/?share=google-plus-1" target="_blank" title="Click to share on Google+"><span>Google</span></a></li><li class="share-linkedin"><a rel="nofollow" data-shared="sharing-linkedin-11123" class="share-linkedin sd-button share-icon" href="https://www.ostechnix.com/bashhub-access-terminal-history-anywhere/?share=linkedin" target="_blank" title="Click to share on LinkedIn"><span>LinkedIn</span></a></li><li class="share-pocket"><a rel="nofollow" data-shared="" class="share-pocket sd-button share-icon" href="https://www.ostechnix.com/bashhub-access-terminal-history-anywhere/?share=pocket" target="_blank" title="Click to share on Pocket"><span>Pocket</span></a></li><li class="share-jetpack-whatsapp"><a rel="nofollow" data-shared="" class="share-jetpack-whatsapp sd-button share-icon" href="whatsapp://send?text=Bashhub%20-%20Access%20Your%20Terminal%20History%20From%20Anywhere https%3A%2F%2Fwww.ostechnix.com%2Fbashhub-access-terminal-history-anywhere%2F" target="_blank" title="Click to share on WhatsApp"><span>WhatsApp</span></a></li><li class="share-telegram"><a rel="nofollow" data-shared="" class="share-telegram sd-button share-icon" href="https://www.ostechnix.com/bashhub-access-terminal-history-anywhere/?share=telegram" target="_blank" title="Click to share on Telegram"><span>Telegram</span></a></li><li class="share-email"><a rel="nofollow" data-shared="" class="share-email sd-button share-icon" href="https://www.ostechnix.com/bashhub-access-terminal-history-anywhere/?share=email" target="_blank" title="Click to email this to a friend"><span>Email</span></a></li><li class="share-print"><a rel="nofollow" data-shared="" class="share-print sd-button share-icon" href="https://www.ostechnix.com/bashhub-access-terminal-history-anywhere/#print" target="_blank" title="Click to print"><span>Print</span></a></li><li class="share-end"></li></ul></div></div></div>          <nav class="pagination group">
                      </nav><!--/.pagination-->
        </div>

        
        <div class="clear"></div>
      </div><!--/.entry-->

    </div><!--/.post-inner-->
  </article><!--/.post-->

<div class="clear"></div>

<p class="post-tags"><span>Tags:</span> <a href="https://www.ostechnix.com/tag/access-your-terminal-history/" rel="tag">Access Your Terminal History</a><a href="https://www.ostechnix.com/tag/bash/" rel="tag">BASH</a><a href="https://www.ostechnix.com/tag/bashhub/" rel="tag">Bashhub</a><a href="https://www.ostechnix.com/tag/cli/" rel="tag">CLI</a><a href="https://www.ostechnix.com/tag/history/" rel="tag">history</a><a href="https://www.ostechnix.com/tag/linux/" rel="tag">Linux</a><a href="https://www.ostechnix.com/tag/python/" rel="tag">Python</a><a href="https://www.ostechnix.com/tag/zsh/" rel="tag">ZSH</a></p>

	<ul class="post-nav group">
		<li class="next"></li>
		<li class="previous"><a href="https://www.ostechnix.com/run-unix-1st-edition-1972/" rel="prev"><i class="fa fa-chevron-left"></i><strong>Previous story</strong> <span>How To Run Unix 1st Edition (1972)</span></a></li>
	</ul>



<h4 class="heading">
	<i class="fa fa-hand-o-right"></i>You may also like...</h4>

<ul class="related-posts group">

		<li class="related post-hover">
		<article class="post-3137 post type-post status-publish format-standard has-post-thumbnail hentry category-arch-linux category-centos category-command-line-utilities category-debian category-faq category-fedora category-linux-basics category-linuxmint category-opensource category-red-hat-enterprise-linux category-scientific-linux category-tips-and-tricks category-ubuntu category-utilities tag-bootable-usb-creation-tools tag-etcher tag-linux">

			<div class="post-thumbnail">
				<a href="https://www.ostechnix.com/etcher-beauitiful-app-create-bootable-sd-cards-usb-drives/" title="Etcher &#8211; A Beautiful App To Create Bootable SD Cards Or USB Drives">
					<img  width="520" height="245"  src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://www.ostechnix.com/wp-content/uploads/2016/05/Etcher_001-520x245.png"  class="attachment-thumb-medium size-thumb-medium wp-post-image" alt="Etcher" data-srcset="https://www.ostechnix.com/wp-content/uploads/2016/05/Etcher_001-520x245.png 520w, https://www.ostechnix.com/wp-content/uploads/2016/05/Etcher_001-720x340.png 720w" data-sizes="(max-width: 520px) 100vw, 520px" />																			</a>
							</div><!--/.post-thumbnail-->

			<div class="related-inner">

				<h4 class="post-title entry-title">
					<a href="https://www.ostechnix.com/etcher-beauitiful-app-create-bootable-sd-cards-usb-drives/" rel="bookmark" title="Etcher &#8211; A Beautiful App To Create Bootable SD Cards Or USB Drives">Etcher &#8211; A Beautiful App To Create Bootable SD Cards Or USB Drives</a>
				</h4><!--/.post-title-->

				<div class="post-meta group">
					<p class="post-date">
  <time class="published updated" datetime="2016-05-16 19:28:54">May 16, 2016</time>
</p>

  <p class="post-byline" style="display:none">&nbsp;by    <span class="vcard author">
      <span class="fn"><a href="https://www.ostechnix.com/author/sk/" title="Posts by sk" rel="author">sk</a></span>
    </span> &middot; Published <span class="published">May 16, 2016</span>
     &middot; Last modified <span class="updated">June 13, 2017</span>  </p>
				</div><!--/.post-meta-->

			</div><!--/.related-inner-->

		</article>
	</li><!--/.related-->
		<li class="related post-hover">
		<article class="post-10733 post type-post status-publish format-image has-post-thumbnail hentry category-debian category-linux category-linux_distributions category-opensource category-reviews tag-debian tag-it-infrastructure-and-management tag-linux tag-ucs tag-univention-corporate-server post_format-post-format-image">

			<div class="post-thumbnail">
				<a href="https://www.ostechnix.com/introduction-univention-corporate-server/" title="Introduction To Univention Corporate Server">
					<img  width="520" height="245"  src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://www.ostechnix.com/wp-content/uploads/2017/10/Univention-Corporate-Server-520x245.png"  class="attachment-thumb-medium size-thumb-medium wp-post-image" alt="Univention Corporate Server" data-srcset="https://www.ostechnix.com/wp-content/uploads/2017/10/Univention-Corporate-Server-520x245.png 520w, https://www.ostechnix.com/wp-content/uploads/2017/10/Univention-Corporate-Server-720x340.png 720w" data-sizes="(max-width: 520px) 100vw, 520px" />																			</a>
							</div><!--/.post-thumbnail-->

			<div class="related-inner">

				<h4 class="post-title entry-title">
					<a href="https://www.ostechnix.com/introduction-univention-corporate-server/" rel="bookmark" title="Introduction To Univention Corporate Server">Introduction To Univention Corporate Server</a>
				</h4><!--/.post-title-->

				<div class="post-meta group">
					<p class="post-date">
  <time class="published updated" datetime="2017-10-25 15:38:24">October 25, 2017</time>
</p>

  <p class="post-byline" style="display:none">&nbsp;by    <span class="vcard author">
      <span class="fn"><a href="https://www.ostechnix.com/author/sk/" title="Posts by sk" rel="author">sk</a></span>
    </span> &middot; Published <span class="published">October 25, 2017</span>
      </p>
				</div><!--/.post-meta-->

			</div><!--/.related-inner-->

		</article>
	</li><!--/.related-->
		<li class="related post-hover">
		<article class="post-7094 post type-post status-publish format-image has-post-thumbnail hentry category-command-line-utilities category-faq category-linux category-linux-basics category-scripting category-tips-and-tricks category-utilities tag-bash tag-display-random-quotes-from-commandline tag-fortune tag-linux tag-motivate post_format-post-format-image">

			<div class="post-thumbnail">
				<a href="https://www.ostechnix.com/display-random-quotes-commandline-linux/" title="Display Random Quotes From Commandline In Linux">
					<img  width="520" height="245"  src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://www.ostechnix.com/wp-content/uploads/2017/02/Display-Random-Quotes-From-Commandline-In-Linux-520x245.png"  class="attachment-thumb-medium size-thumb-medium wp-post-image" alt="Display Random Quotes From Commandline In Linux" data-srcset="https://www.ostechnix.com/wp-content/uploads/2017/02/Display-Random-Quotes-From-Commandline-In-Linux-520x245.png 520w, https://www.ostechnix.com/wp-content/uploads/2017/02/Display-Random-Quotes-From-Commandline-In-Linux-720x340.png 720w" data-sizes="(max-width: 520px) 100vw, 520px" />																			</a>
							</div><!--/.post-thumbnail-->

			<div class="related-inner">

				<h4 class="post-title entry-title">
					<a href="https://www.ostechnix.com/display-random-quotes-commandline-linux/" rel="bookmark" title="Display Random Quotes From Commandline In Linux">Display Random Quotes From Commandline In Linux</a>
				</h4><!--/.post-title-->

				<div class="post-meta group">
					<p class="post-date">
  <time class="published updated" datetime="2017-02-25 11:42:24">February 25, 2017</time>
</p>

  <p class="post-byline" style="display:none">&nbsp;by    <span class="vcard author">
      <span class="fn"><a href="https://www.ostechnix.com/author/sk/" title="Posts by sk" rel="author">sk</a></span>
    </span> &middot; Published <span class="published">February 25, 2017</span>
      </p>
				</div><!--/.post-meta-->

			</div><!--/.related-inner-->

		</article>
	</li><!--/.related-->
		
</ul><!--/.post-related-->



<div id="disqus_thread">
    </div>

          </div><!--/.pad-->
        </section><!--/.content-->
          

	<div class="sidebar s1 collapsed" data-position="right" data-layout="col-2cl" data-sb-id="s1">

		<a class="sidebar-toggle" title="Expand Sidebar"><i class="fa icon-sidebar-toggle"></i></a>

		<div class="sidebar-content">

			  			<div class="sidebar-top group">
                        <p>Follow:</p>
          
          <ul class="social-links"><li><a rel="nofollow" class="social-tooltip"  title="Follow us on Facebook-square" href="https://www.facebook.com/ostechnix/" target="_blank"  style="color:rgba(255,255,255,0.7)"><i class="fa fa-facebook-square"></i></a></li><li><a rel="nofollow" class="social-tooltip"  title="Follow us on Twitter-square" href="https://twitter.com/ostechnix" target="_blank"  style="color:rgba(255,255,255,0.7)"><i class="fa fa-twitter-square"></i></a></li><li><a rel="nofollow" class="social-tooltip"  title="Follow us on Google-plus-square" href="https://plus.google.com/u/0/+SenthilkumarP" target="_blank"  style="color:rgba(255,255,255,0.7)"><i class="fa fa-google-plus-square"></i></a></li><li><a rel="nofollow" class="social-tooltip"  title="Follow us on Linkedin-square" href="https://in.linkedin.com/in/ostechnix" target="_blank"  style="color:rgba(255,255,255,0.7)"><i class="fa fa-linkedin-square"></i></a></li><li><a rel="nofollow" class="social-tooltip"  title="Follow us on Rss" href="http://feeds.feedburner.com/Ostechnix" target="_blank"  style="color:rgba(255,255,255,0.7)"><i class="fa fa-rss"></i></a></li></ul>  			</div>
			
			
			
			<div id="text-6" class="widget widget_text">			<div class="textwidget"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- OS-side-bar -->
<ins class="adsbygoogle"
     style="display:inline-block;width:300px;height:600px"
     data-ad-client="ca-pub-6701402139964678"
     data-ad-slot="3689433741"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
		</div><div id="text-4" class="widget widget_text"><h3 class="widget-title">To Search, Type and Hit Enter</h3>			<div class="textwidget"><script>
  (function() {
    var cx = '008602152458925632792:qnuzfwvz-gy';
    var gcse = document.createElement('script');
    gcse.type = 'text/javascript';
    gcse.async = true;
    gcse.src = 'https://cse.google.com/cse.js?cx=' + cx;
    var s = document.getElementsByTagName('script')[0];
    s.parentNode.insertBefore(gcse, s);
  })();
</script>
<gcse:searchbox-only></gcse:searchbox-only></div>
		</div><div id="responsive_lightbox_image_widget-2" class="widget rl-image-widget"><h3 class="widget-title">Free eBook Of the Week</h3><a href="http://ostechnix.tradepub.com/free/w_lina09/prgm.cgi" class="rl-image-widget-link"><img class="rl-image-widget-image" src="https://www.ostechnix.com/wp-content/uploads/2017/08/Learn-Linux-768x995.jpg" width="100%" height="auto" title="Learn Linux" alt="Learn Linux" style="margin-left: auto; margin-right: auto; display: block;" /></a><div class="rl-image-widget-text"></div></div><div id="text-11" class="widget widget_text">			<div class="textwidget"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- os-sidebar1 -->
<ins class="adsbygoogle"
     style="display:inline-block;width:300px;height:250px"
     data-ad-client="ca-pub-6701402139964678"
     data-ad-slot="4424653341"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
		</div><div id="facebook-likebox-2" class="widget widget_facebook_likebox"><h3 class="widget-title"><a href="https://www.facebook.com/ostechnix/">Follow us on Facebook</a></h3>		<div id="fb-root"></div>
		<div class="fb-page" data-href="https://www.facebook.com/ostechnix/" data-width="340"  data-height="432" data-hide-cover="false" data-show-facepile="true" data-show-posts="false">
		<div class="fb-xfbml-parse-ignore"><blockquote cite="https://www.facebook.com/ostechnix/"><a href="https://www.facebook.com/ostechnix/">Follow us on Facebook</a></blockquote></div>
		</div>
		</div><div id="googleplus-badge-2" class="widget widget_googleplus_badge"><h3 class="widget-title">Follow us on Google Plus</h3><div class="g-person" data-href="https://plus.google.com/u/0/+SenthilkumarP" data-layout="portrait" data-theme="dark" data-showcoverphoto="true" data-showtagline="true" data-width="280"></div></div><div id="twitter_timeline-2" class="widget widget_twitter_timeline"><h3 class="widget-title">Follow us on Twitter</h3><a class="twitter-timeline" data-height="400" data-theme="light" data-link-color="#f96e5b" data-border-color="#e8e8e8" data-lang="EN" data-partner="jetpack" href="https://twitter.com/@ostechnix">My Tweets</a></div><div id="alxtabs-3" class="widget widget_hu_tabs">
<h3 class="widget-title"></h3><ul class="alx-tabs-nav group tab-count-3"><li class="alx-tab tab-recent"><a href="#tab-recent-3" title="Recent Posts"><i class="fa fa-clock-o"></i><span>Recent Posts</span></a></li><li class="alx-tab tab-popular"><a href="#tab-popular-3" title="Popular Posts"><i class="fa fa-star"></i><span>Popular Posts</span></a></li><li class="alx-tab tab-comments"><a href="#tab-comments-3" title="Recent Comments"><i class="fa fa-comments-o"></i><span>Recent Comments</span></a></li></ul>
	<div class="alx-tabs-container">


		
						
			<ul id="tab-recent-3" class="alx-tab group ">
								<li>

					
					<div class="tab-item-inner group">
												<p class="tab-item-title"><a href="https://www.ostechnix.com/bashhub-access-terminal-history-anywhere/" rel="bookmark" title="Bashhub &#8211; Access Your Terminal History From Anywhere">Bashhub &#8211; Access Your Terminal History From Anywhere</a></p>
											</div>

				</li>
								<li>

					
					<div class="tab-item-inner group">
												<p class="tab-item-title"><a href="https://www.ostechnix.com/run-unix-1st-edition-1972/" rel="bookmark" title="How To Run Unix 1st Edition (1972)">How To Run Unix 1st Edition (1972)</a></p>
											</div>

				</li>
								<li>

					
					<div class="tab-item-inner group">
												<p class="tab-item-title"><a href="https://www.ostechnix.com/let-us-play-2048-game-terminal/" rel="bookmark" title="Let Us Play 2048 Game In Terminal">Let Us Play 2048 Game In Terminal</a></p>
											</div>

				</li>
								<li>

					
					<div class="tab-item-inner group">
												<p class="tab-item-title"><a href="https://www.ostechnix.com/coinmon-check-cryptocurrency-prices-commandline/" rel="bookmark" title="Coinmon &#8211; Check Cryptocurrency Prices From Commandline">Coinmon &#8211; Check Cryptocurrency Prices From Commandline</a></p>
											</div>

				</li>
								<li>

					
					<div class="tab-item-inner group">
												<p class="tab-item-title"><a href="https://www.ostechnix.com/comment-multiple-lines-vim-editor/" rel="bookmark" title="How To Comment Out Multiple Lines At Once In Vim Editor">How To Comment Out Multiple Lines At Once In Vim Editor</a></p>
											</div>

				</li>
											</ul><!--/.alx-tab-->

		

		
						<ul id="tab-popular-3" class="alx-tab group ">

								<li>

					
					<div class="tab-item-inner group">
												<p class="tab-item-title"><a href="https://www.ostechnix.com/setup-dns-server-step-by-step-in-centos-6-3-rhel-6-3-scientific-linux-6-3-3/" rel="bookmark" title="How to Setup DNS Server in CentOS 6.5">How to Setup DNS Server in CentOS 6.5</a></p>
											</div>

				</li>
								<li>

					
					<div class="tab-item-inner group">
												<p class="tab-item-title"><a href="https://www.ostechnix.com/setup-ftp-server-step-by-step-in-centos-6-x-rhel-6-x-scientific-linux-6-x/" rel="bookmark" title="Setup FTP Server step by step in CentOS 6.5">Setup FTP Server step by step in CentOS 6.5</a></p>
											</div>

				</li>
								<li>

					
					<div class="tab-item-inner group">
												<p class="tab-item-title"><a href="https://www.ostechnix.com/setup-local-yum-server-in-centos-6-x-rhel-6-x-scientific-linux-6-x/" rel="bookmark" title="Setup Local YUM Server in CentOS 6">Setup Local YUM Server in CentOS 6</a></p>
											</div>

				</li>
								<li>

					
					<div class="tab-item-inner group">
												<p class="tab-item-title"><a href="https://www.ostechnix.com/setup-mail-server-using-postfixdovecotsquirrelmail-in-centosrhelscientific-linux-6-3-step-by-step/" rel="bookmark" title="Setup Mail Server using Postfix, Dovecot and SquirrelMail in CentOS">Setup Mail Server using Postfix, Dovecot and SquirrelMail in CentOS</a></p>
											</div>

				</li>
								<li>

					
					<div class="tab-item-inner group">
												<p class="tab-item-title"><a href="https://www.ostechnix.com/setup-ldap-server-389ds-in-centosrhelscientific-linux-6-3-step-by-step/" rel="bookmark" title="How to Setup LDAP server in CentOS 6">How to Setup LDAP server in CentOS 6</a></p>
											</div>

				</li>
											</ul><!--/.alx-tab-->

		

		
			
			<ul id="tab-comments-3" class="alx-tab group ">
								<li>

						
						<div class="tab-item-inner group">
														<div class="tab-item-name">SK says:</div>
							<div class="tab-item-comment"><a href="https://www.ostechnix.com/install-oracle-virtualbox-ubuntu-16-04-headless-server/#comment-2039">If both systems (VM and the host) are in the same...</a></div>

						</div>

				</li>
								<li>

						
						<div class="tab-item-inner group">
														<div class="tab-item-name">Amit Mittal says:</div>
							<div class="tab-item-comment"><a href="https://www.ostechnix.com/setup-ldap-server-389ds-in-centosrhelscientific-linux-6-3-step-by-step/#comment-2038">It seems that 389-ds is not available at the location, how...</a></div>

						</div>

				</li>
								<li>

						
						<div class="tab-item-inner group">
														<div class="tab-item-name">pannet1 says:</div>
							<div class="tab-item-comment"><a href="https://www.ostechnix.com/whatsie-simple-desktop-client-whatsapp-web/#comment-2037">checkout Rambox http://rambox.pro. It has about 50 social applications in a...</a></div>

						</div>

				</li>
								<li>

						
						<div class="tab-item-inner group">
														<div class="tab-item-name">Chuck Razalas says:</div>
							<div class="tab-item-comment"><a href="https://www.ostechnix.com/install-oracle-virtualbox-ubuntu-16-04-headless-server/#comment-2036">Quick question SK. Ok so I have everything working perfectly and...</a></div>

						</div>

				</li>
								<li>

						
						<div class="tab-item-inner group">
														<div class="tab-item-name">Nataly Goncha says:</div>
							<div class="tab-item-comment"><a href="https://www.ostechnix.com/let-us-play-piano-terminal-using-pc-keyboard/#comment-2032">Ah, it is linux base, I can&#039;t relate it but all...</a></div>

						</div>

				</li>
							</ul><!--/.alx-tab-->

		
			</div>

</div>

		</div><!--/.sidebar-content-->

	</div><!--/.sidebar-->

	

﻿        </div><!--/.main-inner-->
      </div><!--/.main-->
    </div><!--/.container-inner-->
  </div><!--/.container-->
    <footer id="footer">

    
    
        <section class="container" id="footer-widgets">
          <div class="container-inner">

            <div class="pad group">

                                <div class="footer-widget-1 grid one-third ">
                    <div id="text-5" class="widget widget_text"><h3 class="widget-title">Email Newsletter</h3>			<div class="textwidget"><form style="border:3px solid #ccc;border-color:#a8a9ad;padding:10px;text-align:center; font-weight:bold; font-size:18px;line-height: 29px;background-color: #00AEEF; color: #FFFFFF;
" action="https://feedburner.google.com/fb/a/mailverify" method="post" target="popupwindow" onsubmit="window.open('https://feedburner.google.com/fb/a/mailverify?uri=Ostechnix', 'popupwindow', 'scrollbars=yes,width=550,height=520');return true"><p>Subscribe to our mailing list</p><p><input type="text" style="width:240px" name="email"/></p><input type="hidden" value="Ostechnix" name="uri"/><input type="hidden" name="loc" value="en_US"/><input type="submit" value="Sign Up Now" /><p>We respect your privacy</p></form></div>
		</div>                  </div>
                                <div class="footer-widget-2 grid one-third ">
                    <div id="top-posts-2" class="widget widget_top-posts"><h3 class="widget-title">Today&#8217;s most read</h3><ul>				<li>
										<a href="https://www.ostechnix.com/find-size-directory-linux/" class="bump-view" data-bump-view="tp">
						How To Find The Size Of A Directory In Linux					</a>
									</li>
							<li>
										<a href="https://www.ostechnix.com/install-arch-linux-latest-version/" class="bump-view" data-bump-view="tp">
						How To Install Arch Linux Latest Version					</a>
									</li>
							<li>
										<a href="https://www.ostechnix.com/bash-insulter-script-insults-user-typing-wrong-command/" class="bump-view" data-bump-view="tp">
						Bash-insulter : A Script That Insults The User When Typing Wrong Command					</a>
									</li>
							<li>
										<a href="https://www.ostechnix.com/how-to-clear-command-line-history-in-linux/" class="bump-view" data-bump-view="tp">
						How to clear Command line history in Linux					</a>
									</li>
							<li>
										<a href="https://www.ostechnix.com/install-and-configure-dns-server-ubuntu-16-04-lts/" class="bump-view" data-bump-view="tp">
						Install and configure DNS server in Ubuntu 16.04 LTS					</a>
									</li>
							<li>
										<a href="https://www.ostechnix.com/install-yaourt-arch-linux/" class="bump-view" data-bump-view="tp">
						How To Install Yaourt In Arch Linux					</a>
									</li>
							<li>
										<a href="https://www.ostechnix.com/configure-grub-2-boot-loader-settings-ubuntu-16-04/" class="bump-view" data-bump-view="tp">
						Configure GRUB2 Boot Loader Settings In Ubuntu 16.04					</a>
									</li>
							<li>
										<a href="https://www.ostechnix.com/reset-ubuntu-factory-defaults/" class="bump-view" data-bump-view="tp">
						How To Reset Ubuntu To Factory Defaults					</a>
									</li>
							<li>
										<a href="https://www.ostechnix.com/install-vsftpd-server-ubuntu-16-04-lts/" class="bump-view" data-bump-view="tp">
						Install VSFTPD server in Ubuntu 16.04 LTS					</a>
									</li>
							<li>
										<a href="https://www.ostechnix.com/check-linux-system-physical-virtual-machine/" class="bump-view" data-bump-view="tp">
						How To Check If A Linux System Is Physical Or Virtual Machine					</a>
									</li>
			</ul></div>                  </div>
                                <div class="footer-widget-3 grid one-third last">
                    <div id="pages-5" class="widget widget_pages"><h3 class="widget-title">Who we are</h3>		<ul>
			<li class="page_item page-item-676"><a href="https://www.ostechnix.com/about/">About</a></li>
<li class="page_item page-item-660"><a href="https://www.ostechnix.com/contact-us/">Contact Us</a></li>
<li class="page_item page-item-7410"><a href="https://www.ostechnix.com/donate/">Donate</a></li>
<li class="page_item page-item-1103"><a href="https://www.ostechnix.com/privacy-policy/">Privacy Policy</a></li>
<li class="page_item page-item-1483"><a href="https://www.ostechnix.com/sitemap/">Sitemap</a></li>
<li class="page_item page-item-1096"><a href="https://www.ostechnix.com/terms-and-conditions/">Terms and Conditions</a></li>
		</ul>
		</div>                  </div>
              
            </div><!--/.pad-->

          </div><!--/.container-inner-->
        </section><!--/.container-->

    
    
    <section class="container" id="footer-bottom">
      <div class="container-inner">

        <a id="back-to-top" href="#"><i class="fa fa-angle-up"></i></a>

        <div class="pad group">

          <div class="grid one-half">
                                      <img id="footer-logo" src="https://www.ostechnix.com/wp-content/uploads/2016/10/cropped-OSTechNix_280915-01-1.png" alt="">
            
            <div id="copyright">
                              <p>OSTechNix &copy; 2017. All Rights Reserved.</p>
                          </div><!--/#copyright-->

                          <div id="credit">
							<p>This site is licensed under <a href="http://creativecommons.org/licenses/by-nc/4.0/" rel="nofollow">CC BY-NC 4.0</a>. 						</div><!--/#credit-->
            
          </div>

          <div class="grid one-half last">
            <ul class="social-links"><li><a rel="nofollow" class="social-tooltip"  title="Follow us on Facebook-square" href="https://www.facebook.com/ostechnix/" target="_blank"  style="color:rgba(255,255,255,0.7)"><i class="fa fa-facebook-square"></i></a></li><li><a rel="nofollow" class="social-tooltip"  title="Follow us on Twitter-square" href="https://twitter.com/ostechnix" target="_blank"  style="color:rgba(255,255,255,0.7)"><i class="fa fa-twitter-square"></i></a></li><li><a rel="nofollow" class="social-tooltip"  title="Follow us on Google-plus-square" href="https://plus.google.com/u/0/+SenthilkumarP" target="_blank"  style="color:rgba(255,255,255,0.7)"><i class="fa fa-google-plus-square"></i></a></li><li><a rel="nofollow" class="social-tooltip"  title="Follow us on Linkedin-square" href="https://in.linkedin.com/in/ostechnix" target="_blank"  style="color:rgba(255,255,255,0.7)"><i class="fa fa-linkedin-square"></i></a></li><li><a rel="nofollow" class="social-tooltip"  title="Follow us on Rss" href="http://feeds.feedburner.com/Ostechnix" target="_blank"  style="color:rgba(255,255,255,0.7)"><i class="fa fa-rss"></i></a></li></ul>          </div>

        </div><!--/.pad-->

      </div><!--/.container-inner-->
    </section><!--/.container-->

  </footer><!--/#footer-->

</div><!--/#wrapper-->

<div id="huDngaHgESbM" class="AfgjetQapDaN" style="background:#dddddd;z-index:9999999; "></div>   <script type="text/javascript">/* <![CDATA[ */var anOptions ={"anOptionChoice":"1","anOptionStats":"1","anOptionAdsSelectors":"","anOptionCookie":"1","anOptionCookieLife":"30","anPageRedirect":"","anPermalink":"undefined","anOptionModalEffect":"fadeAndPop","anOptionModalspeed":"350","anOptionModalclose":true,"anOptionModalOverlay":"rgba( 0,0,0,0.8 )","anAlternativeActivation":false,"anAlternativeElement":"","anAlternativeText":"<p><strong>AdBlock detected!<\/strong><\/p>\n<p>Please add <a title=\"http:\/\/themeisle.com\/\" href=\"themeisle.com\" target=\"_blank\">www.themeisle.com<\/a> to your adblocking whitelist or disable your adblocking software.<\/p>\n","anAlternativeClone":"2","anAlternativeProperties":"","anOptionModalShowAfter":0,"anPageMD5":"","anSiteID":0,"modalHTML":"<div class=\"AfgjetQapDaN-default\">\n\t<h1 style=\"\">Adblocker detected! Please consider reading this notice.<\/h1>\n\t<p>We've detected that you are using AdBlock Plus ore some other adblocking software which is preventing the page from fully loading.<\/p>\n<p>We need money to operate the site, and almost all of it comes from our online advertising.<\/p>\n<p><strong>Please add <a title=\"OSTechNix\" href=\"http:\/\/www.ostechnix.com\" target=\"_blank\" rel=\"noopener\">www.ostechnix.com<\/a> to your ad blocking whitelist or disable your adblocking software.\u00a0<\/strong><\/p>\n<p>To close this box, click on the (X) button on the top or click anywhere on the background.<\/p>\n<p>We really appreciate you for white-listing our site.<\/p>\n<\/div>\n<a class=\"close-modal close-AfgjetQapDaN\">&#215;<\/a>"}/* ]]> */</script><div id="adsense" class="an-sponsored" style="position:absolute; z-index:-1; height:1px; width:1px; visibility: hidden; top: -1px; left: 0;"><img class="an-advert-banner" alt="sponsored" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"></div>	<div style="display:none">
	</div>

	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/www.ostechnix.com\/bashhub-access-terminal-history-anywhere\/":11123};
	</script>
	<div id="sharing_email" style="display: none;">
		<form action="/bashhub-access-terminal-history-anywhere/" method="post">
			<label for="target_email">Send to Email Address</label>
			<input type="email" name="target_email" id="target_email" value="" />

			
				<label for="source_name">Your Name</label>
				<input type="text" name="source_name" id="source_name" value="" />

				<label for="source_email">Your Email Address</label>
				<input type="email" name="source_email" id="source_email" value="" />

						<input type="text" id="jetpack-source_f_name" name="source_f_name" class="input" value="" size="25" autocomplete="off" title="This field is for validation and should not be changed" />
			<script>jQuery( document ).ready( function(){ document.getElementById('jetpack-source_f_name').value = '' });</script>
			
			<img style="float: right; display: none" class="loading" src="https://www.ostechnix.com/wp-content/plugins/jetpack/modules/sharedaddy/images/loading.gif" alt="loading" width="16" height="16" />
			<input type="submit" value="Send Email" class="sharing_send" />
			<a rel="nofollow" href="#cancel" class="sharing_cancel">Cancel</a>

			<div class="errors errors-1" style="display: none;">
				Post was not sent - check your email addresses!			</div>

			<div class="errors errors-2" style="display: none;">
				Email check failed, please try again			</div>

			<div class="errors errors-3" style="display: none;">
				Sorry, your blog cannot share posts by email.			</div>
		</form>
	</div>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201748'></script>
<script type='text/javascript' src='https://secure.gravatar.com/js/gprofiles.js?ver=2017Novaa'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.ostechnix.com/wp-content/plugins/jetpack/modules/wpgroho.js?ver=4.9'></script>
<script type='text/javascript' src='https://www.ostechnix.com/wp-includes/js/underscore.min.js?ver=1.8.3'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var HUParams = {"_disabled":[],"SmoothScroll":{"Enabled":false,"Options":{"touchpadSupport":false}},"centerAllImg":"1","timerOnScrollAllBrowsers":"1","extLinksStyle":"1","extLinksTargetExt":"1","extLinksSkipSelectors":{"classes":["btn","button"],"ids":[]},"imgSmartLoadEnabled":"1","imgSmartLoadOpts":{"parentSelectors":[".container .content",".container .sidebar","#footer","#header-widgets"],"opts":{"excludeImg":[".tc-holder-img"],"fadeIn_options":100}},"goldenRatio":"1.618","gridGoldenRatioLimit":"350","sbStickyUserSettings":{"desktop":false,"mobile":false},"isWPMobile":"","menuStickyUserSettings":{"desktop":"stick_up","mobile":"stick_up"},"isDevMode":"","ajaxUrl":"https:\/\/www.ostechnix.com\/?huajax=1","frontNonce":{"id":"HuFrontNonce","handle":"bb79edd28d"},"userStarted":{"with":"with|3.2.8","on":{"date":"2017-05-19 07:51:36.000000","timezone_type":3,"timezone":"UTC"}},"isWelcomeNoteOn":"","welcomeContent":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.ostechnix.com/wp-content/themes/hueman/assets/front/js/scripts.min.js?ver=3.3.25'></script>
<script type='text/javascript' src='https://www.ostechnix.com/wp-includes/js/comment-reply.min.js?ver=4.9'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var jpfbembed = {"appid":"249643311490","locale":"en_US"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.ostechnix.com/wp-content/plugins/jetpack/_inc/facebook-embed.js'></script>
<script type='text/javascript' src='https://www.ostechnix.com/wp-content/plugins/jetpack/_inc/twitter-timeline.js?ver=4.0.0'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var ajax_object = {"nonce":"fc0f8cd8c1","ajaxurl":"https:\/\/www.ostechnix.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.ostechnix.com/wp-content/uploads/UWMayjOEbsuO/bGIqjIfXyyMH.js?ver=2.2.3'></script>
<script type='text/javascript' src='https://www.ostechnix.com/wp-includes/js/wp-embed.min.js?ver=4.9'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"platform":"wordpress@4.9","language":""},"disqusIdentifier":"11123 http:\/\/www.ostechnix.com\/?p=11123","disqusShortname":"ostechnix","disqusTitle":"Bashhub \u2013 Access Your Terminal History From Anywhere","disqusUrl":"https:\/\/www.ostechnix.com\/bashhub-access-terminal-history-anywhere\/","options":{"manualSync":false},"postId":"11123"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.ostechnix.com/wp-content/plugins/disqus-comment-system/media/js/disqus.js?ver=4.9'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"ostechnix"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.ostechnix.com/wp-content/plugins/disqus-comment-system/media/js/count.js?ver=4.9'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.ostechnix.com/wp-content/plugins/jetpack/modules/sharedaddy/sharing.js?ver=5.5.1'></script>
<script type='text/javascript'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-google-plus-1', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomgoogle-plus-1', 'menubar=1,resizable=1,width=480,height=550' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-linkedin', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomlinkedin', 'menubar=1,resizable=1,width=580,height=450' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-pocket', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcompocket', 'menubar=1,resizable=1,width=450,height=450' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-telegram', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtelegram', 'menubar=1,resizable=1,width=450,height=450' );
				return false;
			});
</script>
<!--[if lt IE 9]>
<script src="https://www.ostechnix.com/wp-content/themes/hueman/assets/front/js/ie/respond.js"></script>
<![endif]-->
<script type='text/javascript' src='https://stats.wp.com/e-201748.js' async defer></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:5.5.1',blog:'84551477',post:'11123',tz:'5.5',srv:'www.ostechnix.com'} ]);
	_stq.push([ 'clickTrackerInit', '84551477', '11123' ]);
</script>
</body>
</html>
