<!DOCTYPE html>
<html class="no-js" lang="en-US">
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<link rel="profile" href="https://gmpg.org/xfn/11" />
<link rel="pingback" href="https://www.ostechnix.com/xmlrpc.php">
<script>document.documentElement.className = document.documentElement.className.replace("no-js","js");</script>

<title>Install And Configure KVM In Ubuntu 20.04 Headless Server - OSTechNix</title>
<meta name="description" content="This guide explains how to install and configure KVM in Ubuntu 20.04 headless server and how to create and manage KVM guest machines using Virsh command." />
<meta name="robots" content="index, follow" />
<meta name="googlebot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
<meta name="bingbot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
<link rel="canonical" href="https://www.ostechnix.com/install-and-configure-kvm-in-ubuntu-20-04-headless-server/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Install And Configure KVM In Ubuntu 20.04 Headless Server - OSTechNix" />
<meta property="og:description" content="This guide explains how to install and configure KVM in Ubuntu 20.04 headless server and how to create and manage KVM guest machines using Virsh command." />
<meta property="og:url" content="https://www.ostechnix.com/install-and-configure-kvm-in-ubuntu-20-04-headless-server/" />
<meta property="og:site_name" content="OSTechNix" />
<meta property="article:publisher" content="https://www.facebook.com/ostechnix/" />
<meta property="article:published_time" content="2020-07-04T14:14:53+00:00" />
<meta property="article:modified_time" content="2020-07-04T14:30:58+00:00" />
<meta property="og:image" content="https://www.ostechnix.com/wp-content/uploads/2020/07/Install-And-Configure-KVM-In-Ubuntu-20.04-Headless-Server.png" />
<meta property="og:image:width" content="800" />
<meta property="og:image:height" content="450" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:creator" content="@ostechnix" />
<meta name="twitter:site" content="@ostechnix" />
<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://www.ostechnix.com/#organization","name":"OSTechNix","url":"https://www.ostechnix.com/","sameAs":["https://www.facebook.com/ostechnix/","https://in.linkedin.com/in/ostechnix","https://www.youtube.com/channel/UC4GsixqwFwsy95oKhpKIS9g","https://twitter.com/ostechnix"],"logo":{"@type":"ImageObject","@id":"https://www.ostechnix.com/#logo","inLanguage":"en-US","url":"https://www.ostechnix.com/wp-content/uploads/2016/10/OSTechNix_280915-01.png","width":3333,"height":1667,"caption":"OSTechNix"},"image":{"@id":"https://www.ostechnix.com/#logo"}},{"@type":"WebSite","@id":"https://www.ostechnix.com/#website","url":"https://www.ostechnix.com/","name":"OSTechNix","description":"Open Source - Technology - Linux And Unix","publisher":{"@id":"https://www.ostechnix.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":"https://www.ostechnix.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://www.ostechnix.com/install-and-configure-kvm-in-ubuntu-20-04-headless-server/#primaryimage","inLanguage":"en-US","url":"https://www.ostechnix.com/wp-content/uploads/2020/07/Install-And-Configure-KVM-In-Ubuntu-20.04-Headless-Server.png","width":800,"height":450,"caption":"Install And Configure KVM In Ubuntu 20.04 Headless Server"},{"@type":"WebPage","@id":"https://www.ostechnix.com/install-and-configure-kvm-in-ubuntu-20-04-headless-server/#webpage","url":"https://www.ostechnix.com/install-and-configure-kvm-in-ubuntu-20-04-headless-server/","name":"Install And Configure KVM In Ubuntu 20.04 Headless Server - OSTechNix","isPartOf":{"@id":"https://www.ostechnix.com/#website"},"primaryImageOfPage":{"@id":"https://www.ostechnix.com/install-and-configure-kvm-in-ubuntu-20-04-headless-server/#primaryimage"},"datePublished":"2020-07-04T14:14:53+00:00","dateModified":"2020-07-04T14:30:58+00:00","description":"This guide explains how to install and configure KVM in Ubuntu 20.04 headless server and how to create and manage KVM guest machines using Virsh command.","inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://www.ostechnix.com/install-and-configure-kvm-in-ubuntu-20-04-headless-server/"]}]},{"@type":"Article","@id":"https://www.ostechnix.com/install-and-configure-kvm-in-ubuntu-20-04-headless-server/#article","isPartOf":{"@id":"https://www.ostechnix.com/install-and-configure-kvm-in-ubuntu-20-04-headless-server/#webpage"},"author":{"@id":"https://www.ostechnix.com/#/schema/person/e4f4cd4c175ef6a91695a056cbaed01a"},"headline":"Install And Configure KVM In Ubuntu 20.04 Headless Server","datePublished":"2020-07-04T14:14:53+00:00","dateModified":"2020-07-04T14:30:58+00:00","commentCount":0,"mainEntityOfPage":{"@id":"https://www.ostechnix.com/install-and-configure-kvm-in-ubuntu-20-04-headless-server/#webpage"},"publisher":{"@id":"https://www.ostechnix.com/#organization"},"image":{"@id":"https://www.ostechnix.com/install-and-configure-kvm-in-ubuntu-20-04-headless-server/#primaryimage"},"keywords":"Kernel-based virtual machine,KVM,Linux,Linux Kernel,Open source,Uubntu,Virtualization","articleSection":"KVM,Linux,Linux Admnistration,Opensource,Ubuntu,Virtualization","inLanguage":"en-US","potentialAction":[{"@type":"CommentAction","name":"Comment","target":["https://www.ostechnix.com/install-and-configure-kvm-in-ubuntu-20-04-headless-server/#respond"]}]},{"@type":["Person"],"@id":"https://www.ostechnix.com/#/schema/person/e4f4cd4c175ef6a91695a056cbaed01a","name":"sk","image":{"@type":"ImageObject","@id":"https://www.ostechnix.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/82930172130088777d42141847e45c10?s=96&d=mm&r=g","caption":"sk"}}]}</script>

<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="OSTechNix &raquo; Feed" href="https://www.ostechnix.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="OSTechNix &raquo; Comments Feed" href="https://www.ostechnix.com/comments/feed/" />
<link id="hu-user-gfont" href="//fonts.googleapis.com/css?family=Ubuntu:400,400italic,300italic,300,700&subset=latin,latin-ext" rel="stylesheet" type="text/css"><link rel="alternate" type="application/rss+xml" title="OSTechNix &raquo; Install And Configure KVM In Ubuntu 20.04 Headless Server Comments Feed" href="https://www.ostechnix.com/install-and-configure-kvm-in-ubuntu-20-04-headless-server/feed/" />
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.ostechnix.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.4.2"}};
			/*! This file is auto-generated */
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='font-customizer-style-css' href='https://www.ostechnix.com/wp-content/themes/hueman-pro/addons/pro/wfc/front/assets/css/font_customizer.min.css?ver=3.1.1' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css' href='https://www.ostechnix.com/wp-includes/css/dist/block-library/style.min.css?ver=5.4.2' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='responsive-lightbox-swipebox-css' href='https://www.ostechnix.com/wp-content/plugins/responsive-lightbox/assets/swipebox/swipebox.min.css?ver=2.2.3' type='text/css' media='all' />
<link rel='stylesheet' id='hph-front-style-css' href='https://www.ostechnix.com/wp-content/themes/hueman-pro/addons/assets/front/css/hph-front.min.css?ver=1.2.13' type='text/css' media='all' />
<link rel='stylesheet' id='hueman-main-style-css' href='https://www.ostechnix.com/wp-content/themes/hueman-pro/assets/front/css/main.min.css?ver=1.2.13' type='text/css' media='all' />
<style id='hueman-main-style-inline-css' type='text/css'>
body { font-family:'Ubuntu', Arial, sans-serif;font-size:1.13rem }@media only screen and (min-width: 720px) {
        .nav > li { font-size:1.13rem; }
      }::selection { background-color: #3b8dbd; }
::-moz-selection { background-color: #3b8dbd; }a,a>span.hu-external::after,.themeform label .required,#flexslider-featured .flex-direction-nav .flex-next:hover,#flexslider-featured .flex-direction-nav .flex-prev:hover,.post-hover:hover .post-title a,.post-title a:hover,.sidebar.s1 .post-nav li a:hover i,.content .post-nav li a:hover i,.post-related a:hover,.sidebar.s1 .widget_rss ul li a,#footer .widget_rss ul li a,.sidebar.s1 .widget_calendar a,#footer .widget_calendar a,.sidebar.s1 .alx-tab .tab-item-category a,.sidebar.s1 .alx-posts .post-item-category a,.sidebar.s1 .alx-tab li:hover .tab-item-title a,.sidebar.s1 .alx-tab li:hover .tab-item-comment a,.sidebar.s1 .alx-posts li:hover .post-item-title a,#footer .alx-tab .tab-item-category a,#footer .alx-posts .post-item-category a,#footer .alx-tab li:hover .tab-item-title a,#footer .alx-tab li:hover .tab-item-comment a,#footer .alx-posts li:hover .post-item-title a,.comment-tabs li.active a,.comment-awaiting-moderation,.child-menu a:hover,.child-menu .current_page_item > a,.wp-pagenavi a{ color: #3b8dbd; }input[type="submit"],.themeform button[type="submit"],.sidebar.s1 .sidebar-top,.sidebar.s1 .sidebar-toggle,#flexslider-featured .flex-control-nav li a.flex-active,.post-tags a:hover,.sidebar.s1 .widget_calendar caption,#footer .widget_calendar caption,.author-bio .bio-avatar:after,.commentlist li.bypostauthor > .comment-body:after,.commentlist li.comment-author-admin > .comment-body:after{ background-color: #3b8dbd; }.post-format .format-container { border-color: #3b8dbd; }.sidebar.s1 .alx-tabs-nav li.active a,#footer .alx-tabs-nav li.active a,.comment-tabs li.active a,.wp-pagenavi a:hover,.wp-pagenavi a:active,.wp-pagenavi span.current{ border-bottom-color: #3b8dbd!important; }.sidebar.s2 .post-nav li a:hover i,
.sidebar.s2 .widget_rss ul li a,
.sidebar.s2 .widget_calendar a,
.sidebar.s2 .alx-tab .tab-item-category a,
.sidebar.s2 .alx-posts .post-item-category a,
.sidebar.s2 .alx-tab li:hover .tab-item-title a,
.sidebar.s2 .alx-tab li:hover .tab-item-comment a,
.sidebar.s2 .alx-posts li:hover .post-item-title a { color: #82b965; }
.sidebar.s2 .sidebar-top,.sidebar.s2 .sidebar-toggle,.post-comments,.jp-play-bar,.jp-volume-bar-value,.sidebar.s2 .widget_calendar caption{ background-color: #82b965; }.sidebar.s2 .alx-tabs-nav li.active a { border-bottom-color: #82b965; }
.post-comments::before { border-right-color: #82b965; }
      .search-expand,
              #nav-topbar.nav-container { background-color: #00aeef}@media only screen and (min-width: 720px) {
                #nav-topbar .nav ul { background-color: #00aeef; }
              }.is-scrolled #header .nav-container.desktop-sticky,
              .is-scrolled #header .search-expand { background-color: #00aeef; background-color: rgba(0,174,239,0.90) }.is-scrolled .topbar-transparent #nav-topbar.desktop-sticky .nav ul { background-color: #00aeef; background-color: rgba(0,174,239,0.95) }#header { background-color: #eaeaea; }
@media only screen and (min-width: 720px) {
  #nav-header .nav ul { background-color: #eaeaea; }
}
        .is-scrolled #header #nav-mobile { background-color: #454e5c; background-color: rgba(69,78,92,0.90) }#nav-header.nav-container, #main-header-search .search-expand { background-color: #ef4423; }
@media only screen and (min-width: 720px) {
  #nav-header .nav ul { background-color: #ef4423; }
}
        .site-title a img { max-height: 120px; }body { background-color: #eaeaea; }
</style>
<link rel='stylesheet' id='theme-stylesheet-css' href='https://www.ostechnix.com/wp-content/themes/ostechnix_child_theme/style.css?ver=1.0' type='text/css' media='all' />
<link rel='stylesheet' id='social-logos-css' href='https://www.ostechnix.com/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css?ver=8.6.1' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css' href='https://www.ostechnix.com/wp-content/plugins/jetpack/css/jetpack.css?ver=8.6.1' type='text/css' media='all' />
<script>if (document.location.protocol != "https:") {document.location = document.URL.replace(/^http:/i, "https:");}</script><script type='text/javascript' src='https://www.ostechnix.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://www.ostechnix.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://www.ostechnix.com/wp-content/plugins/responsive-lightbox/assets/swipebox/jquery.swipebox.min.js?ver=2.2.3'></script>
<script type='text/javascript' src='https://www.ostechnix.com/wp-content/plugins/responsive-lightbox/assets/infinitescroll/infinite-scroll.pkgd.min.js?ver=5.4.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var rlArgs = {"script":"swipebox","selector":"lightbox","customEvents":"","activeGalleries":"1","animation":"1","hideCloseButtonOnMobile":"0","removeBarsOnMobile":"0","hideBars":"1","hideBarsDelay":"5000","videoMaxWidth":"1080","useSVG":"1","loopAtEnd":"0","woocommerce_gallery":"0","ajaxurl":"https:\/\/www.ostechnix.com\/wp-admin\/admin-ajax.php","nonce":"843d5e8c15"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.ostechnix.com/wp-content/plugins/responsive-lightbox/js/front.js?ver=2.2.3'></script>
<script type='text/javascript' src='https://www.ostechnix.com/wp-content/themes/hueman-pro/assets/front/js/libs/mobile-detect.min.js?ver=1.2.13' defer></script>
<link rel='https://api.w.org/' href='https://www.ostechnix.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.ostechnix.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.ostechnix.com/wp-includes/wlwmanifest.xml" />
<meta name="generator" content="WordPress 5.4.2" />
<link rel='shortlink' href='https://www.ostechnix.com/?p=24293' />
<link rel="alternate" type="application/json+oembed" href="https://www.ostechnix.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.ostechnix.com%2Finstall-and-configure-kvm-in-ubuntu-20-04-headless-server%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.ostechnix.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.ostechnix.com%2Finstall-and-configure-kvm-in-ubuntu-20-04-headless-server%2F&#038;format=xml" />
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
  (adsbygoogle = window.adsbygoogle || []).push({
    google_ad_client: "ca-pub-6701402139964678",
    enable_page_level_ads: true
  });
</script><style type='text/css'>img#wpstats{display:none}</style><!--[if lt IE 9]>
<script src="https://www.ostechnix.com/wp-content/themes/hueman-pro/assets/front/js/ie/html5shiv-printshiv.min.js"></script>
<script src="https://www.ostechnix.com/wp-content/themes/hueman-pro/assets/front/js/ie/selectivizr.js"></script>
<![endif]-->
<link rel="icon" href="https://www.ostechnix.com/wp-content/uploads/2016/10/cropped-favicon-500x500-150x150.png" sizes="32x32" />
<link rel="icon" href="https://www.ostechnix.com/wp-content/uploads/2016/10/cropped-favicon-500x500-300x300.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://www.ostechnix.com/wp-content/uploads/2016/10/cropped-favicon-500x500-300x300.png" />
<meta name="msapplication-TileImage" content="https://www.ostechnix.com/wp-content/uploads/2016/10/cropped-favicon-500x500-300x300.png" />
<style type="text/css" id="wp-custom-css">
			/*
You can add your own CSS here.

Click the help icon above to learn more.

Use this field to test small chunks of CSS code. For important CSS customizations, it is recommended to modify the style.css file of a child theme.
http//codex.wordpress.org/Child_Themes
*/
		</style>
<style id="grids-css" type="text/css">
                .post-list .grid-item {float: left; }
                .cols-1 .grid-item { width: 100%; }
                .cols-2 .grid-item { width: 50%; }
                .cols-3 .grid-item { width: 33.3%; }
                .cols-4 .grid-item { width: 25%; }
                @media only screen and (max-width: 719px) {
                      #grid-wrapper .grid-item{
                        width: 100%;
                      }
                }
            </style>
</head>
<body data-rsssl=1 class="post-template-default single single-post postid-24293 single-format-standard wp-custom-logo wp-embed-responsive col-2cl full-width topbar-enabled header-desktop-sticky hu-header-img-full-width hu-fa-not-loaded unknown">
<div id="wrapper">
<a class="screen-reader-text skip-link" href="#content">Skip to content</a>
<header id="header" class="both-menus-mobile-on two-mobile-menus both_menus header-ads-desktop header-ads-mobile topbar-transparent no-header-img">
<nav class="nav-container group desktop-menu desktop-sticky " id="nav-topbar" data-menu-id="header-1">

<button class="ham__navbar-toggler-two collapsed" title="Menu" aria-expanded="false">
<span class="ham__navbar-span-wrapper">
<span class="line line-1"></span>
<span class="line line-2"></span>
<span class="line line-3"></span>
</span>
</button>
<div class="nav-text"></div>
<div class="topbar-toggle-down">
<i class="fas fa-angle-double-down" aria-hidden="true" data-toggle="down" title="Expand menu"></i>
<i class="fas fa-angle-double-up" aria-hidden="true" data-toggle="up" title="Collapse menu"></i>
</div>
<div class="nav-wrap container">
<ul id="menu-top-menu" class="nav container-inner group"><li id="menu-item-9" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-9"><a href="https://www.ostechnix.com/">Home</a></li>
<li id="menu-item-11" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-11"><a target="_blank" rel="noopener noreferrer" href="https://www.ostechnix.com/category/opensource/">Open Source</a></li>
<li id="menu-item-10" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10"><a target="_blank" rel="noopener noreferrer" href="https://www.ostechnix.com/category/technology/">Technology</a></li>
<li id="menu-item-12" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-12"><a target="_blank" rel="noopener noreferrer" href="https://www.ostechnix.com/category/linux/">Linux</a>
<ul class="sub-menu">
<li id="menu-item-14" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14"><a href="https://www.ostechnix.com/category/linux-basics/">Linux Basics</a></li>
<li id="menu-item-15" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-has-children menu-item-15"><a href="https://www.ostechnix.com/category/linux_distributions/">Linux Distributions</a>
<ul class="sub-menu">
<li id="menu-item-16" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16"><a href="https://www.ostechnix.com/category/linux_distributions/arch-linux/">Arch Linux</a></li>
<li id="menu-item-17" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-17"><a href="https://www.ostechnix.com/category/linux_distributions/centos/">CentOS</a></li>
<li id="menu-item-18" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-18"><a href="https://www.ostechnix.com/category/linux_distributions/debian/">Debian</a></li>
<li id="menu-item-19" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-19"><a href="https://www.ostechnix.com/category/linux_distributions/fedora/">Fedora</a></li>
<li id="menu-item-20" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-20"><a href="https://www.ostechnix.com/category/linux_distributions/linuxmint/">Linux Mint</a></li>
<li id="menu-item-21" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-21"><a href="https://www.ostechnix.com/category/linux_distributions/mageia/">Mageia</a></li>
<li id="menu-item-22" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22"><a href="https://www.ostechnix.com/category/linux_distributions/mandrake/">Mandrake</a></li>
<li id="menu-item-23" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-23"><a href="https://www.ostechnix.com/category/linux_distributions/mandriva/">Mandriva</a></li>
<li id="menu-item-24" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-24"><a href="https://www.ostechnix.com/category/linux_distributions/opensuse/">openSUSE</a></li>
<li id="menu-item-929" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-929"><a href="https://www.ostechnix.com/category/linux_distributions/red-hat-enterprise-linux/">Red Hat Enterprise Linux</a></li>
<li id="menu-item-930" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-930"><a href="https://www.ostechnix.com/category/linux_distributions/scientific-linux/">Scientific Linux</a></li>
</ul>
</li>
</ul>
</li>
<li id="menu-item-13" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-13"><a target="_blank" rel="noopener noreferrer" href="https://www.ostechnix.com/category/unix/">Unix</a>
<ul class="sub-menu">
<li id="menu-item-931" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-931"><a href="https://www.ostechnix.com/category/unix/freebsd/">FreeBSD</a></li>
</ul>
</li>
<li id="menu-item-5925" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5925"><a target="_blank" rel="noopener noreferrer" href="http://ostechnix.tradepub.com/category/information-technology/1207/">Free Videos and EBooks</a></li>
<li id="menu-item-7430" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-7430"><a target="_blank" rel="noopener noreferrer" href="https://www.ostechnix.com/donate/">Donate</a></li>
</ul> </div>
<div id="topbar-header-search" class="container">
<div class="container-inner">
<button class="toggle-search"><i class="fas fa-search"></i></button>
<div class="search-expand">
<div class="search-expand-inner"><form role="search" method="get" class="search-form" action="https://www.ostechnix.com/">
<label>
<span class="screen-reader-text">Search for:</span>
<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
</label>
<input type="submit" class="search-submit" value="Search" />
</form></div>
</div>
</div>
</div>
</nav>
<div class="container group">
<div class="container-inner">
<div class="group hu-pad central-header-zone">
<div class="logo-tagline-group">
<p class="site-title"> <a class="custom-logo-link" href="https://www.ostechnix.com/" rel="home" title="OSTechNix | Home page"><img src="https://www.ostechnix.com/wp-content/uploads/2020/04/cropped-OSTechNix_logo.png" alt="OSTechNix" width="250" height="100" /></a> </p> </div>
<div id="header-widgets">
<div id="custom_html-3" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-6701402139964678" data-ad-slot="4407409178" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div></div> </div>
</div>
<nav class="nav-container group desktop-menu " id="nav-header" data-menu-id="header-2">

<button class="ham__navbar-toggler-two collapsed" title="Menu" aria-expanded="false">
<span class="ham__navbar-span-wrapper">
<span class="line line-1"></span>
<span class="line line-2"></span>
<span class="line line-3"></span>
</span>
</button>
<div class="nav-text"></div>
<div class="nav-wrap container">
<ul id="menu-header-menu" class="nav container-inner group"><li id="menu-item-940" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-940"><a target="_blank" rel="noopener noreferrer" href="https://www.ostechnix.com/category/backup-tools/">Backup tools</a></li>
<li id="menu-item-943" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-943"><a target="_blank" rel="noopener noreferrer" href="https://www.ostechnix.com/category/cloud/">Cloud</a></li>
<li id="menu-item-941" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-941"><a target="_blank" rel="noopener noreferrer" href="https://www.ostechnix.com/category/database/">Database</a></li>
<li id="menu-item-942" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-942"><a target="_blank" rel="noopener noreferrer" href="https://www.ostechnix.com/category/directory-servers/">Directory servers</a></li>
<li id="menu-item-944" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-944"><a target="_blank" rel="noopener noreferrer" href="https://www.ostechnix.com/category/mobile/">Mobile</a>
<ul class="sub-menu">
<li id="menu-item-945" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-945"><a href="https://www.ostechnix.com/category/android/">Android</a></li>
</ul>
</li>
<li id="menu-item-932" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-932"><a target="_blank" rel="noopener noreferrer" href="https://www.ostechnix.com/category/security/">Security</a>
<ul class="sub-menu">
<li id="menu-item-936" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-936"><a href="https://www.ostechnix.com/category/encryption-decryption/">Encryption / Decryption</a></li>
<li id="menu-item-938" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-938"><a href="https://www.ostechnix.com/category/monitoring-tools/">Monitoring Tools</a></li>
</ul>
</li>
<li id="menu-item-933" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-933"><a target="_blank" rel="noopener noreferrer" href="https://www.ostechnix.com/category/tips-and-tricks/">Tips and Tricks</a>
<ul class="sub-menu">
<li id="menu-item-937" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-937"><a href="https://www.ostechnix.com/category/internet-hacks/">Internet hacks</a></li>
</ul>
</li>
<li id="menu-item-934" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-934"><a target="_blank" rel="noopener noreferrer" href="https://www.ostechnix.com/category/trouble-shooting/">Trouble shooting</a></li>
<li id="menu-item-935" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-935"><a target="_blank" rel="noopener noreferrer" href="https://www.ostechnix.com/category/virtualization/">Virtualization</a></li>
</ul> </div>
</nav>
</div>
</div>
</header>
<div class="container" id="page">
<div class="container-inner">
<div class="main">
<div class="main-inner group">
<section class="content" id="content">
<div class="page-title hu-pad group">
<ul class="meta-single group">
<li class="category"><a href="https://www.ostechnix.com/category/virtualization/kvm/" rel="category tag">KVM</a> <span>/</span> <a href="https://www.ostechnix.com/category/linux/" rel="category tag">Linux</a> <span>/</span> <a href="https://www.ostechnix.com/category/linux-admnistration/" rel="category tag">Linux Admnistration</a> <span>/</span> <a href="https://www.ostechnix.com/category/opensource/" rel="category tag">Opensource</a> <span>/</span> <a href="https://www.ostechnix.com/category/linux_distributions/ubuntu/" rel="category tag">Ubuntu</a> <span>/</span> <a href="https://www.ostechnix.com/category/virtualization/" rel="category tag">Virtualization</a></li>
</ul>
</div>
<div class="hu-pad group">
<article class="post-24293 post type-post status-publish format-standard has-post-thumbnail hentry category-kvm category-linux category-linux-admnistration category-opensource category-ubuntu category-virtualization tag-kernel-based-virtual-machine tag-kvm tag-linux tag-linux-kernel tag-open-source tag-uubntu tag-virtualization">
<div class="post-inner group">
<h1 class="post-title entry-title">Install And Configure KVM In Ubuntu 20.04 Headless Server</h1>
<p class="post-byline">
by <span class="vcard author">
<span class="fn"><a href="https://www.ostechnix.com/author/sk/" title="Posts by sk" rel="author">sk</a></span>
</span>
&middot;
Published <time class="published" datetime="2020-07-04T19:44:53+05:30">July 4, 2020</time>
&middot; Updated <time class="updated" datetime="2020-07-04T20:00:58+05:30">July 4, 2020</time>
</p>
<div class="clear"></div>
<div class="entry themeform share">
<div class="entry-inner">
<p><strong>KVM</strong>, short for <strong>K</strong>ernel-based <strong>V</strong>irtual <strong>M</strong>achine, is a FreeBSD and Linux kernel module that allows the kernel to act as a hypervisor. Starting from kernel version 2.6.20, KVM is merged into Linux kernel mainline. Using KVM, you can easily setup a virtualization environment in a Linux machine and host a wide variety of guest operating systems including Linux, Windows, BSD, Mac OS and many. In this guide, we will look at how to install and configure KVM in Ubuntu 20.04 headless server. And also we will see how to create and manage KVM guest machines using V<span id="c6f4" data-selectable-paragraph="">irsh</span> command line utility.</p>
<h5>Prerequisites</h5>
<p>Before installing KVM, first make sure your system&#8217;s processor supports hardware virtualization. We have documented a few different ways to identify whether a Linux system supports Virtualization in the following guide.</p>
<ul>
<li><a href="https://www.ostechnix.com/how-to-find-if-a-cpu-supports-virtualization-technology-vt/" target="_blank" rel="noopener noreferrer"><strong>How To Find If A CPU Supports Virtualization Technology (VT)</strong></a></li>
</ul>
<p>If your system supports hardware virtualization, continue the following steps.</p>
<h2>Install And Configure KVM In Ubuntu 20.04 Headless Server</h2>
<p>For the purpose of this guide, I will be using the following systems.</p>
<p><strong>KVM virtualization server:</strong></p>
<ul>
<li><strong>OS</strong> – Ubuntu 20.04 LTS minimal server (No GUI)</li>
<li><strong>IP Address</strong> : 192.168.225.52/24</li>
</ul>
<p><strong>Remote Client:</strong></p>
<ul>
<li><strong>OS</strong> – Ubuntu 20.04 GNOME Desktop</li>
</ul>
<p>First, let us install KVM in our Ubuntu server.</p>
<h3>Install KVM in Ubuntu 20.04 LTS</h3>
<p>Install Kvm and all required dependencies to setup a virtualization environment on your Ubuntu 20.04 LTS sever using command:</p>
<pre>$ sudo apt install qemu qemu-kvm libvirt-clients libvirt-daemon-system virtinst bridge-utils</pre>
<p>Here,</p>
<ul>
<li><strong>qemu</strong> &#8211; A generic machine emulator and virtualizer,</li>
<li><strong>qemu-kvm</strong> &#8211; QEMU metapackage for KVM support (i.e. QEMU Full virtualization on x86 hardware),</li>
<li><strong>libvirt-clients</strong> &#8211; programs for the libvirt library,</li>
<li><strong>libvirt-daemon-system</strong> &#8211; Libvirt daemon configuration files,</li>
<li><strong>virtinst</strong> &#8211; programs to create and clone virtual machines,</li>
<li><strong>bridge-utils</strong> &#8211; utilities for configuring the Linux Ethernet bridge.</li>
</ul>
<p>Once KVM is installed, start libvertd service (If it is not started already):</p>
<pre>$ sudo systemctl enable libvirtd</pre>
<pre>$ sudo systemctl start libvirtd</pre>
<p>Check the status of libvirtd service with command:</p>
<pre>$ systemctl status libvirtd</pre>
<p><strong>Sample output:</strong></p>
<pre>● libvirtd.service - Virtualization daemon
<span style="color: #ff0000;"><strong>     Loaded: loaded</strong></span> (/lib/systemd/system/libvirtd.service; enabled; vendor preset: enabled)
<span style="color: #ff0000;"><strong>     Active: active (running)</strong></span> since Sat 2020-07-04 08:13:41 UTC; 7min ago
TriggeredBy: ● libvirtd-ro.socket
             ● libvirtd-admin.socket
             ● libvirtd.socket
       Docs: man:libvirtd(8)
             https://libvirt.org
   Main PID: 4492 (libvirtd)
      Tasks: 19 (limit: 32768)
     Memory: 12.9M
     CGroup: /system.slice/libvirtd.service
             ├─4492 /usr/sbin/libvirtd
             ├─4641 /usr/sbin/dnsmasq --conf-file=/var/lib/libvirt/dnsmasq/default.conf --l&gt;
             └─4642 /usr/sbin/dnsmasq --conf-file=/var/lib/libvirt/dnsmasq/default.conf --l&gt;

Jul 04 08:13:42 ubuntuserver dnsmasq[4641]: compile time options: IPv6 GNU-getopt DBus i18n&gt;
Jul 04 08:13:42 ubuntuserver dnsmasq-dhcp[4641]: DHCP, IP range 192.168.122.2 -- 192.168.12&gt;
Jul 04 08:13:42 ubuntuserver dnsmasq-dhcp[4641]: DHCP, sockets bound exclusively to interfa&gt;
Jul 04 08:13:42 ubuntuserver dnsmasq[4641]: reading /etc/resolv.conf
Jul 04 08:13:42 ubuntuserver dnsmasq[4641]: using nameserver 127.0.0.53#53
Jul 04 08:13:42 ubuntuserver dnsmasq[4641]: read /etc/hosts - 7 addresses
Jul 04 08:13:42 ubuntuserver dnsmasq[4641]: read /var/lib/libvirt/dnsmasq/default.addnhosts&gt;
Jul 04 08:13:42 ubuntuserver dnsmasq-dhcp[4641]: read /var/lib/libvirt/dnsmasq/default.host&gt;
Jul 04 08:13:42 ubuntuserver dnsmasq[4641]: reading /etc/resolv.conf
Jul 04 08:13:42 ubuntuserver dnsmasq[4641]: using nameserver 127.0.0.53#53</pre>
<p>Well, libvertd service has been enabled and started! Let us do the rest of the configuration now.</p>
<h3>Setup Bridge networking with KVM</h3>
<p>A bridged network shares the real network interface of the host computer with other VMs to connect to the outside network. Therefore each VM can bind directly to any available IPv4 or IPv6 addresses, just like a physical computer.</p>
<p>By default KVM setups a private virtual bridge (Guest-only network), so that all VMs can communicate with one another, within the host computer. It provides its own subnet and DHCP to configure the guest’s network and uses NAT to access the host network.</p>
<p>Have a look at the IP address of the KVM default virtual interfaces using &#8220;ip&#8221; command:</p>
<pre>$ ip a</pre>
<p><strong>Sample output:</strong></p>
<pre>1: lo: &lt;LOOPBACK,UP,LOWER_UP&gt; mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: enp0s3: &lt;BROADCAST,MULTICAST,UP,LOWER_UP&gt; mtu 1500 qdisc fq_codel state UP group default qlen 1000
    link/ether 08:00:27:8a:52:94 brd ff:ff:ff:ff:ff:ff
    inet 192.168.225.52/24 brd 192.168.225.255 scope global dynamic enp0s3
       valid_lft 39559sec preferred_lft 39559sec
    inet6 2409:4072:6c0f:431d:a00:27ff:fe8a:5294/64 scope global mngtmpaddr noprefixroute 
       valid_lft forever preferred_lft forever
    inet6 fe80::a00:27ff:fe8a:5294/64 scope link 
       valid_lft forever preferred_lft forever
3: enp0s8: &lt;BROADCAST,MULTICAST,UP,LOWER_UP&gt; mtu 1500 qdisc fq_codel state UP group default qlen 1000
    link/ether 08:00:27:10:7c:c1 brd ff:ff:ff:ff:ff:ff
    inet 192.168.225.60/24 brd 192.168.225.255 scope global dynamic enp0s8
       valid_lft 39559sec preferred_lft 39559sec
    inet6 2409:4072:6c0f:431d:a00:27ff:fe10:7cc1/64 scope global mngtmpaddr noprefixroute 
       valid_lft forever preferred_lft forever
    inet6 fe80::a00:27ff:fe10:7cc1/64 scope link 
       valid_lft forever preferred_lft forever
4: enp0s9: &lt;BROADCAST,MULTICAST,UP,LOWER_UP&gt; mtu 1500 qdisc fq_codel state UP group default qlen 1000
    link/ether 08:00:27:5d:61:28 brd ff:ff:ff:ff:ff:ff
    inet 192.168.225.51/24 brd 192.168.225.255 scope global dynamic enp0s9
       valid_lft 39559sec preferred_lft 39559sec
    inet6 2409:4072:6c0f:431d:a00:27ff:fe5d:6128/64 scope global mngtmpaddr noprefixroute 
       valid_lft forever preferred_lft forever
    inet6 fe80::a00:27ff:fe5d:6128/64 scope link 
       valid_lft forever preferred_lft forever
5: <span style="color: #ff0000;"><strong>virbr0</strong></span>: &lt;NO-CARRIER,BROADCAST,MULTICAST,UP&gt; mtu 1500 qdisc noqueue state DOWN group default qlen 1000
    link/ether 52:54:00:f1:98:9e brd ff:ff:ff:ff:ff:ff
    inet <span style="color: #ff0000;"><strong>192.168.122.1/24</strong></span> brd 192.168.122.255 scope global virbr0
       valid_lft forever preferred_lft forever
6: virbr0-nic: &lt;BROADCAST,MULTICAST&gt; mtu 1500 qdisc fq_codel master virbr0 state DOWN group default qlen 1000
    link/ether 52:54:00:f1:98:9e brd ff:ff:ff:ff:ff:ff</pre>
<p><a href="https://www.ostechnix.com/wp-content/uploads/2020/07/KVM-default-virtual-interface-IP-address.png" data-rel="lightbox-image-0" data-rl_title="" data-rl_caption="" title=""><img class="aligncenter size-full wp-image-24310" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://www.ostechnix.com/wp-content/uploads/2020/07/KVM-default-virtual-interface-IP-address.png" alt="KVM default virtual interface IP address" width="1366" height="691" data-srcset="https://www.ostechnix.com/wp-content/uploads/2020/07/KVM-default-virtual-interface-IP-address.png 1366w, https://www.ostechnix.com/wp-content/uploads/2020/07/KVM-default-virtual-interface-IP-address-300x152.png 300w, https://www.ostechnix.com/wp-content/uploads/2020/07/KVM-default-virtual-interface-IP-address-1024x518.png 1024w, https://www.ostechnix.com/wp-content/uploads/2020/07/KVM-default-virtual-interface-IP-address-768x388.png 768w, https://www.ostechnix.com/wp-content/uploads/2020/07/KVM-default-virtual-interface-IP-address-720x364.png 720w, https://www.ostechnix.com/wp-content/uploads/2020/07/KVM-default-virtual-interface-IP-address-520x263.png 520w, https://www.ostechnix.com/wp-content/uploads/2020/07/KVM-default-virtual-interface-IP-address-320x162.png 320w" data-sizes="(max-width: 1366px) 100vw, 1366px" /></a></p>
<p>As you can see, KVM default network <strong>virbr0</strong> uses 192.168.122.1/24 IP address. All the VMs will use an IP address in the 192.168.122.0/24 IP range and the host OS will be reachable at 192.168.122.1. You should be able to ssh into the host OS (at 192.168.122.1) from inside the guest OS and use scp to copy files back and forth.</p>
<p>It is OK if you only access the VMs inside from the host itself. However we can&#8217;t access the VMs from other remote systems in the network. Because they use different IP range i.e. 192.168.225.0/24 in my case. In order to access the VMs from other remote hosts, we must setup a public bridge that runs on the host network and uses whatever external DHCP server is on the host network. To put this in layman terms, we are going to make all VMs to use the same IP series used by the host system.</p>
<p>Before setting up a public bridged network, we should disable <strong>Netfilter</strong> for <a href="https://bugzilla.redhat.com/show_bug.cgi?id=512206#c0" target="_blank" rel="noopener noreferrer"><strong>performance and security reasons</strong></a>. Netfilter is currently enabled on bridges by default.</p>
<p id="a9c0" data-selectable-paragraph="">To disable netfilter, create a file called <strong>/etc/sysctl.d/bridge.conf</strong>:</p>
<pre>$ sudo vi /etc/sysctl.d/bridge.conf</pre>
<p data-selectable-paragraph="">Add the following lines:</p>
<pre><span id="8d06" data-selectable-paragraph="">net.bridge.bridge-nf-call-ip6tables=0
net.bridge.bridge-nf-call-iptables=0
net.bridge.bridge-nf-call-arptables=0</span></pre>
<p data-selectable-paragraph="">Save and close the file.</p>
<p id="f320" data-selectable-paragraph="">Then create another file called <strong>/etc/udev/rules.d/99-bridge.rules</strong> :</p>
<pre>$ sudo vi /etc/udev/rules.d/99-bridge.rules</pre>
<p data-selectable-paragraph="">Add the following line:</p>
<pre>ACTION=="add", SUBSYSTEM=="module", KERNEL=="br_netfilter", RUN+="/sbin/sysctl -p /etc/sysctl.d/bridge.conf"<span id="7ea7" data-selectable-paragraph=""></span></pre>
<p id="e8af" data-selectable-paragraph="">This will set the necessary flags to disable netfilter on bridges at the appropriate place in system start-up. Save and close the file. Reboot your system to take effect these changes.</p>
<p data-selectable-paragraph="">Next, we should disable the default networking that KVM installed for itself.</p>
<p data-selectable-paragraph="">Find the name of KVM default network interfaces using &#8220;ip link&#8221; command:</p>
<pre>$ ip link</pre>
<p data-selectable-paragraph=""><strong>Sample output:</strong></p>
<pre>1: lo: &lt;LOOPBACK,UP,LOWER_UP&gt; mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: enp0s3: &lt;BROADCAST,MULTICAST,UP,LOWER_UP&gt; mtu 1500 qdisc fq_codel state UP mode DEFAULT group default qlen 1000
    link/ether 08:00:27:8a:52:94 brd ff:ff:ff:ff:ff:ff
3: enp0s8: &lt;BROADCAST,MULTICAST,UP,LOWER_UP&gt; mtu 1500 qdisc fq_codel state UP mode DEFAULT group default qlen 1000
    link/ether 08:00:27:10:7c:c1 brd ff:ff:ff:ff:ff:ff
4: enp0s9: &lt;BROADCAST,MULTICAST,UP,LOWER_UP&gt; mtu 1500 qdisc fq_codel state UP mode DEFAULT group default qlen 1000
    link/ether 08:00:27:5d:61:28 brd ff:ff:ff:ff:ff:ff
5: <span style="color: #ff0000;"><strong>virbr0</strong></span>: &lt;NO-CARRIER,BROADCAST,MULTICAST,UP&gt; mtu 1500 qdisc noqueue state DOWN mode DEFAULT group default qlen 1000
    link/ether 52:54:00:1f:a2:e7 brd ff:ff:ff:ff:ff:ff
6: <span style="color: #ff0000;"><strong>virbr0-nic</strong></span>: &lt;BROADCAST,MULTICAST&gt; mtu 1500 qdisc fq_codel master virbr0 state DOWN mode DEFAULT group default qlen 1000
    link/ether 52:54:00:1f:a2:e7 brd ff:ff:ff:ff:ff:ff</pre>
<p><a href="https://www.ostechnix.com/wp-content/uploads/2020/07/View-KVM-default-network-interfaces.png" data-rel="lightbox-image-1" data-rl_title="" data-rl_caption="" title=""><img class="aligncenter size-full wp-image-24311" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://www.ostechnix.com/wp-content/uploads/2020/07/View-KVM-default-network-interfaces.png" alt="View KVM default network interfaces" width="1052" height="277" data-srcset="https://www.ostechnix.com/wp-content/uploads/2020/07/View-KVM-default-network-interfaces.png 1052w, https://www.ostechnix.com/wp-content/uploads/2020/07/View-KVM-default-network-interfaces-300x79.png 300w, https://www.ostechnix.com/wp-content/uploads/2020/07/View-KVM-default-network-interfaces-1024x270.png 1024w, https://www.ostechnix.com/wp-content/uploads/2020/07/View-KVM-default-network-interfaces-768x202.png 768w, https://www.ostechnix.com/wp-content/uploads/2020/07/View-KVM-default-network-interfaces-720x190.png 720w, https://www.ostechnix.com/wp-content/uploads/2020/07/View-KVM-default-network-interfaces-520x137.png 520w, https://www.ostechnix.com/wp-content/uploads/2020/07/View-KVM-default-network-interfaces-320x84.png 320w" data-sizes="(max-width: 1052px) 100vw, 1052px" /></a></p>
<p>As you see in the above output, the entries &#8220;virbr0&#8221; and &#8220;virbr0-nic&#8221; are the KVM networks.</p>
<p>Let us remove the default KVM network with command:</p>
<pre>$ virsh net-destroy default</pre>
<p><strong>Sample output:</strong></p>
<pre>Network default destroyed</pre>
<p>Undefine the default network with command:</p>
<pre>$ virsh net-undefine default</pre>
<p><strong>Sample output:</strong></p>
<pre>Network default has been undefined</pre>
<p><a href="https://www.ostechnix.com/wp-content/uploads/2020/07/remove-default-KVM-network-interfaces.png" data-rel="lightbox-image-2" data-rl_title="" data-rl_caption="" title=""><img class="aligncenter size-full wp-image-24312" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://www.ostechnix.com/wp-content/uploads/2020/07/remove-default-KVM-network-interfaces.png" alt="remove default KVM network interfaces" width="567" height="205" data-srcset="https://www.ostechnix.com/wp-content/uploads/2020/07/remove-default-KVM-network-interfaces.png 567w, https://www.ostechnix.com/wp-content/uploads/2020/07/remove-default-KVM-network-interfaces-300x108.png 300w, https://www.ostechnix.com/wp-content/uploads/2020/07/remove-default-KVM-network-interfaces-520x188.png 520w, https://www.ostechnix.com/wp-content/uploads/2020/07/remove-default-KVM-network-interfaces-320x116.png 320w" data-sizes="(max-width: 567px) 100vw, 567px" /></a></p>
<p>If the above commands doesn&#8217;t work for any reason, you can use these commands to disable and undefine KVM default network:</p>
<pre>$ sudo ip link delete virbr0 type bridge</pre>
<pre>$ sudo ip link delete virbr0-nic</pre>
<p>Now run &#8220;ip link&#8221; again to verify if the virbr0 and virbr0-nic interfaces are actually deleted:</p>
<pre><strong>$ ip link</strong>
1: lo: &lt;LOOPBACK,UP,LOWER_UP&gt; mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: enp0s3: &lt;BROADCAST,MULTICAST,UP,LOWER_UP&gt; mtu 1500 qdisc fq_codel state UP mode DEFAULT group default qlen 1000
    link/ether 08:00:27:8a:52:94 brd ff:ff:ff:ff:ff:ff
3: enp0s8: &lt;BROADCAST,MULTICAST,UP,LOWER_UP&gt; mtu 1500 qdisc fq_codel state UP mode DEFAULT group default qlen 1000
    link/ether 08:00:27:10:7c:c1 brd ff:ff:ff:ff:ff:ff
4: enp0s9: &lt;BROADCAST,MULTICAST,UP,LOWER_UP&gt; mtu 1500 qdisc fq_codel state UP mode DEFAULT group default qlen 1000
    link/ether 08:00:27:5d:61:28 brd ff:ff:ff:ff:ff:ff</pre>
<p>See? The KVM default networks are gone.</p>
<p>Now, let us setup the KVM public bridge to use when creating a new VM.</p>
<hr />
<p><span style="color: #ff0000;"><strong>Note:</strong></span></p>
<p>Do not use wireless network interface cards for bridges. Most wireless interlaces do not support bridging. Always use wired network interfaces for seamless connectivity!</p>
<hr />
<p>To create a network bridge in host, edit <strong>/etc/netplan/00-installer-config.yaml</strong> file and add the bridge details.</p>
<p>Here is the default contents of the <strong>00-installer-config.yaml</strong> file in my Ubuntu 20.04 LTS server.</p>
<pre><strong>$ cat /etc/netplan/00-installer-config.yaml</strong>
# This is the network config written by 'subiquity'
network:
  ethernets:
    enp0s3:
      dhcp4: true
    enp0s8:
      dhcp4: true
    enp0s9:
      dhcp4: true
  version: 2</pre>
<p>As you see, I have three wired network interfaces namely enp0s3, enp0s8 and enp0s9 in my Ubuntu server.</p>
<p>Before editing this file, backup your existing /etc/netplan/00-installer-config.yaml file:</p>
<pre>$ sudo cp /etc/netplan/00-installer-config.yaml{,.backup}</pre>
<p>Then edit the default config file using your favorite editor:</p>
<pre>$ sudo vi /etc/netplan/00-installer-config.yaml</pre>
<p>Add/modify it like below:</p>
<pre># This is the network config written by 'subiquity'
network:
  ethernets:
    enp0s3:
      dhcp4: false
      dhcp6: false
    enp0s8:
      dhcp4: false
      dhcp6: false
    enp0s9:
      dhcp4: false
      dhcp6: false
  bridges:
    br0:
      interfaces: [ enp0s3 ]
      addresses: [192.168.225.52/24]
      gateway4: 192.168.255.1
      mtu: 1500
      nameservers:
        addresses: [8.8.8.8,8.8.4.4]
      parameters:
        stp: true
        forward-delay: 4
      dhcp4: no
      dhcp6: no
  version: 2</pre>
<p><a href="https://www.ostechnix.com/wp-content/uploads/2020/07/create-a-network-bridge-in-ubuntu.png" data-rel="lightbox-image-3" data-rl_title="" data-rl_caption="" title=""><img class="aligncenter size-full wp-image-24313" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://www.ostechnix.com/wp-content/uploads/2020/07/create-a-network-bridge-in-ubuntu.png" alt="create a network bridge in ubuntu" width="1366" height="691" data-srcset="https://www.ostechnix.com/wp-content/uploads/2020/07/create-a-network-bridge-in-ubuntu.png 1366w, https://www.ostechnix.com/wp-content/uploads/2020/07/create-a-network-bridge-in-ubuntu-300x152.png 300w, https://www.ostechnix.com/wp-content/uploads/2020/07/create-a-network-bridge-in-ubuntu-1024x518.png 1024w, https://www.ostechnix.com/wp-content/uploads/2020/07/create-a-network-bridge-in-ubuntu-768x388.png 768w, https://www.ostechnix.com/wp-content/uploads/2020/07/create-a-network-bridge-in-ubuntu-720x364.png 720w, https://www.ostechnix.com/wp-content/uploads/2020/07/create-a-network-bridge-in-ubuntu-520x263.png 520w, https://www.ostechnix.com/wp-content/uploads/2020/07/create-a-network-bridge-in-ubuntu-320x162.png 320w" data-sizes="(max-width: 1366px) 100vw, 1366px" /></a></p>
<p>Here, the bridge network interface &#8220;br0&#8221; is attached to host&#8217;s network interface &#8220;enp0s3&#8221;. The ip address of br0 is 192.168.225.52. The gateway is 192.168.225.1. I use Google DNS servers (8.8.8.8 and 8.8.4.4) to connect to Internet. Make sure the space indentation are exactly same as above. If the line indentations are not correct, the bridged network interface will not activate. Replace the above values that matches with your network.</p>
<p>After modifying the network config file, save and close it. Apply the changes by running the following command:</p>
<pre>$ sudo netplan --debug  apply</pre>
<p>Now check if the IP address has been assigned to the bridge interface:</p>
<pre>$ ip a</pre>
<p><strong>Sample output:</strong></p>
<pre>1: lo: &lt;LOOPBACK,UP,LOWER_UP&gt; mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: enp0s3: &lt;BROADCAST,MULTICAST,UP,LOWER_UP&gt; mtu 1500 qdisc fq_codel master br0 state UP group default qlen 1000
    link/ether 08:00:27:8a:52:94 brd ff:ff:ff:ff:ff:ff
3: enp0s8: &lt;BROADCAST,MULTICAST,UP,LOWER_UP&gt; mtu 1500 qdisc fq_codel state UP group default qlen 1000
    link/ether 08:00:27:10:7c:c1 brd ff:ff:ff:ff:ff:ff
    inet6 2409:4072:48b:ab02:a00:27ff:fe10:7cc1/64 scope global mngtmpaddr noprefixroute 
       valid_lft forever preferred_lft forever
    inet6 fe80::a00:27ff:fe10:7cc1/64 scope link 
       valid_lft forever preferred_lft forever
4: enp0s9: &lt;BROADCAST,MULTICAST,UP,LOWER_UP&gt; mtu 1500 qdisc fq_codel state UP group default qlen 1000
    link/ether 08:00:27:5d:61:28 brd ff:ff:ff:ff:ff:ff
    inet6 2409:4072:48b:ab02:a00:27ff:fe5d:6128/64 scope global mngtmpaddr noprefixroute 
       valid_lft forever preferred_lft forever
    inet6 fe80::a00:27ff:fe5d:6128/64 scope link 
       valid_lft forever preferred_lft forever
7: <span style="color: #ff0000;"><strong>br0</strong></span>: &lt;BROADCAST,MULTICAST,UP,LOWER_UP&gt; mtu 1500 qdisc noqueue state UP group default qlen 1000
    link/ether 08:00:27:8a:52:94 brd ff:ff:ff:ff:ff:ff
    inet <span style="color: #ff0000;"><strong>192.168.225.52/24</strong></span> brd 192.168.225.255 scope global br0
       valid_lft forever preferred_lft forever
    inet6 fe80::a00:27ff:fe8a:5294/64 scope link 
       valid_lft forever preferred_lft foreve</pre>
<p><a href="https://www.ostechnix.com/wp-content/uploads/2020/07/check-KVM-bridge-network-IP-address.png" data-rel="lightbox-image-4" data-rl_title="" data-rl_caption="" title=""><img class="aligncenter size-full wp-image-24314" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://www.ostechnix.com/wp-content/uploads/2020/07/check-KVM-bridge-network-IP-address.png" alt="check KVM bridge network IP address" width="1366" height="564" data-srcset="https://www.ostechnix.com/wp-content/uploads/2020/07/check-KVM-bridge-network-IP-address.png 1366w, https://www.ostechnix.com/wp-content/uploads/2020/07/check-KVM-bridge-network-IP-address-300x124.png 300w, https://www.ostechnix.com/wp-content/uploads/2020/07/check-KVM-bridge-network-IP-address-1024x423.png 1024w, https://www.ostechnix.com/wp-content/uploads/2020/07/check-KVM-bridge-network-IP-address-768x317.png 768w, https://www.ostechnix.com/wp-content/uploads/2020/07/check-KVM-bridge-network-IP-address-720x297.png 720w, https://www.ostechnix.com/wp-content/uploads/2020/07/check-KVM-bridge-network-IP-address-520x215.png 520w, https://www.ostechnix.com/wp-content/uploads/2020/07/check-KVM-bridge-network-IP-address-320x132.png 320w" data-sizes="(max-width: 1366px) 100vw, 1366px" /></a></p>
<p>As you see in the above output, the bridged network interface <strong>br0</strong> is assigned with IP address 192.168.225.52 and the enp0s3 entry now has &#8220;master br0&#8221; entry. It means that enp0s3 belongs to the bridge.</p>
<p>You can also use <strong>&#8220;brctl&#8221;</strong> command to show the bridge status:</p>
<pre>$ brctl show br0</pre>
<p><strong>Sample output:</strong></p>
<pre>bridge name	bridge id		STP enabled	interfaces
br0		8000.0800278a5294	yes		enp0s3</pre>
<p>Now we should configure KVM to use this bridge. To do that, create a an XML file called <strong>host-bridge.xml</strong> :</p>
<pre>$ vi host-bridge.xml</pre>
<p>Add the following lines:</p>
<pre><span id="c7cb" data-selectable-paragraph="">&lt;network&gt;
  &lt;name&gt;host-bridge&lt;/name&gt;
  &lt;forward mode="bridge"/&gt;
  &lt;bridge name="br0"/&gt;
&lt;/network&gt;</span></pre>
<p id="66f3" data-selectable-paragraph="">Run the following commands to start the newly created bridge and make it as default bridge for VMs:</p>
<pre><span id="c6f4" data-selectable-paragraph="">$ virsh net-define host-bridge.xml
</span></pre>
<pre><span id="c6f4" data-selectable-paragraph="">$ virsh net-start host-bridge</span></pre>
<pre><span id="c6f4" data-selectable-paragraph="">$ virsh net-autostart host-bridge</span></pre>
<p data-selectable-paragraph=""><a href="https://www.ostechnix.com/wp-content/uploads/2020/07/start-the-KVM-host-bridge.png" data-rel="lightbox-image-5" data-rl_title="" data-rl_caption="" title=""><img class="aligncenter size-full wp-image-24315" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://www.ostechnix.com/wp-content/uploads/2020/07/start-the-KVM-host-bridge.png" alt="start the KVM host bridge" width="537" height="294" data-srcset="https://www.ostechnix.com/wp-content/uploads/2020/07/start-the-KVM-host-bridge.png 537w, https://www.ostechnix.com/wp-content/uploads/2020/07/start-the-KVM-host-bridge-300x164.png 300w, https://www.ostechnix.com/wp-content/uploads/2020/07/start-the-KVM-host-bridge-520x285.png 520w, https://www.ostechnix.com/wp-content/uploads/2020/07/start-the-KVM-host-bridge-320x175.png 320w" data-sizes="(max-width: 537px) 100vw, 537px" /></a></p>
<p id="9096" data-selectable-paragraph="">To verify if the bridge is active and started, run:</p>
<pre><span id="3c01" data-selectable-paragraph="">$ virsh net-list --all
</span></pre>
<p data-selectable-paragraph=""><strong>Sample output:</strong></p>
<pre>Name          State    Autostart   Persistent
------------------------------------------------
 host-bridge   active   yes         yes</pre>
<p data-selectable-paragraph=""><a href="https://www.ostechnix.com/wp-content/uploads/2020/07/verify-KVM-host-bridge-status.png" data-rel="lightbox-image-6" data-rl_title="" data-rl_caption="" title=""><img class="aligncenter size-full wp-image-24316" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://www.ostechnix.com/wp-content/uploads/2020/07/verify-KVM-host-bridge-status.png" alt="verify KVM host bridge status" width="435" height="183" data-srcset="https://www.ostechnix.com/wp-content/uploads/2020/07/verify-KVM-host-bridge-status.png 435w, https://www.ostechnix.com/wp-content/uploads/2020/07/verify-KVM-host-bridge-status-300x126.png 300w, https://www.ostechnix.com/wp-content/uploads/2020/07/verify-KVM-host-bridge-status-320x135.png 320w" data-sizes="(max-width: 435px) 100vw, 435px" /></a></p>
<p id="3052" data-selectable-paragraph="">Congratulations! We have successfully setup KVM bridge and it is active now.</p>
<h2>Create and manage KVM virtual machines using Virsh</h2>
<p>We use <strong>&#8220;virsh&#8221;</strong> command line utility to manage virtual machines. The virsh program is used create, list, pause, restart, shutdown and delete VMs from command line.</p>
<p>By default, the virtual machine files and other related files are stored under <strong>/var/lib/libvirt/ </strong>location. The default path to store ISO images is <strong>/var/lib/libvirt/boot/</strong>. We can of course change these locations when installing a new VM.</p>
<h4>List virtual machines</h4>
<p>First, let us check if there are any virtual machines exists.</p>
<p>To view the list of available virtual machines, run:</p>
<pre>$ sudo virsh list --all</pre>
<p><strong>Sample output:</strong></p>
<p><a href="https://www.ostechnix.com/wp-content/uploads/2020/07/List-virtual-machines-using-virsh.png" data-rel="lightbox-image-7" data-rl_title="" data-rl_caption="" title=""><img class="aligncenter size-full wp-image-24318" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://www.ostechnix.com/wp-content/uploads/2020/07/List-virtual-machines-using-virsh.png" alt="List virtual machines using virsh" width="398" height="171" data-srcset="https://www.ostechnix.com/wp-content/uploads/2020/07/List-virtual-machines-using-virsh.png 398w, https://www.ostechnix.com/wp-content/uploads/2020/07/List-virtual-machines-using-virsh-300x129.png 300w, https://www.ostechnix.com/wp-content/uploads/2020/07/List-virtual-machines-using-virsh-320x137.png 320w" data-sizes="(max-width: 398px) 100vw, 398px" /></a></p>
<p>As you can see, there are no existing virtual machines.</p>
<h4>Create KVM virtual machines</h4>
<p>Let us create an Ubuntu 18.04 Virtual machine with 2 GB RAM, 1 CPU core, 10 GB Hdd. To do that, run:</p>
<pre>$ sudo virt-install --name Ubuntu-18.04 --ram=2048 --vcpus=1 --cpu host --hvm --disk path=/var/lib/libvirt/images/ubuntu-18.04-vm1,size=10 --cdrom /home/ostechnix/ubuntu18.iso --network bridge=br0 --graphics vnc</pre>
<p>Let us break down the above command and see what each option do.</p>
<ul>
<li><strong>&#8211;name Ubuntu-18.04</strong> : The name of the virtual machine</li>
<li><strong>&#8211;ram=2048</strong> : Allocates 2 GB RAM to the VM.</li>
<li><strong>&#8211;vcpus=1</strong> : Indicates the number of CPU cores in the VM.</li>
<li><strong>&#8211;cpu host</strong> : Optimizes the CPU properties for the VM by exposing the host’s CPU’s configuration to the guest.</li>
<li><strong>&#8211;hvm</strong> : Request the full hardware virtualization.</li>
<li><strong>&#8211;disk path=/var/lib/libvirt/images/ubuntu-18.04-vm1,size=10</strong> : The location to save VM’s hdd and it’s size. In this case, I have allocated 10 GB hdd size.</li>
<li><strong>&#8211;cdrom /home/ostechnix/ubuntu18.iso</strong> : The location where you have the actual Ubuntu installer ISO image.</li>
<li><strong>&#8211;network bridge=br0</strong> : Instruct the VM to use bridge network. If you don&#8217;t configured bridge network, ignore this parameter.</li>
<li><strong>&#8211;graphics vnc</strong> : Allows VNC access to the VM from a remote client.</li>
</ul>
<p>Sample output of the above command would be:</p>
<pre>WARNING Graphics requested but DISPLAY is not set. Not running virt-viewer.
WARNING No console to launch for the guest, defaulting to --wait -1

Starting install...
Allocating 'ubuntu-18.04-vm1'                                                                                                                      |  10 GB  00:00:06     
Domain installation still in progress.
Waiting for installation to complete.</pre>
<p>This message will keep showing until you connect to the VM from a remote system via any VNC application and complete the OS installation.</p>
<p>Since our KVM host system (Ubuntu server) doesn&#8217;t has GUI, we can&#8217;t continue the guest OS installation. So, I am going to use a spare machine that has GUI on it to complete the guest OS installation with the help of a VNC client.</p>
<p>We are done with the Ubuntu server here. The following steps should be performed on a client system.</p>
<h4>Access Virtual machines from remote systems via VNC client</h4>
<p>Go to the remote systems that has graphical desktop environment and install any VNC client application if it is not installed already. I have a Ubuntu desktop with <strong>Remmina</strong> remote desktop client installed.</p>
<p>SSH into the KVM host system:</p>
<pre>$ ssh <a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="d4bba7a0b1b7bcbabdac94e5ede6fae5e2ecfae6e6e1fae1e6">[email&#160;protected]</a></pre>
<p>Here,</p>
<ul>
<li><strong>ostechnix</strong> is the name of the user in KVM host (Ubuntu 20.04 server)</li>
<li><strong>192.168.225.52</strong> is the IP address of KVM host.</li>
</ul>
<p>Find the VNC port used by the running VM using command:</p>
<pre>$ sudo virsh dumpxml Ubuntu-18.04 | grep vnc</pre>
<p>Replace &#8220;Ubuntu-18.04&#8221; with your VM&#8217;s name.</p>
<p><strong>Sample output:</strong></p>
<pre>&lt;graphics type='vnc' port=<span style="color: #ff0000;"><strong>'5900'</strong></span> autoport='yes' listen='127.0.0.1'&gt;</pre>
<p>The VNC port numer is <strong>5900</strong>.</p>
<p>Type the following SSH port forwarding command from your terminal:</p>
<pre>$ ssh <a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="e18e92958482898f8899a1d0d8d3cfd0d7d9cfd3d3d4cfd4d3">[email&#160;protected]</a> -L 5900:127.0.0.1:5900</pre>
<p>Launch the VNC client application and choose &#8220;VNC&#8221; protocol and then type <strong>&#8220;localhost:5900&#8221;</strong> in the address bar and finally hit ENTER:</p>
<p><a href="https://www.ostechnix.com/wp-content/uploads/2020/07/Connect-to-virtual-machines-using-VNC-client.png" data-rel="lightbox-image-8" data-rl_title="" data-rl_caption="" title=""><img class="aligncenter size-full wp-image-24324" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://www.ostechnix.com/wp-content/uploads/2020/07/Connect-to-virtual-machines-using-VNC-client.png" alt="Connect to remote virtual machines using VNC client" width="601" height="447" data-srcset="https://www.ostechnix.com/wp-content/uploads/2020/07/Connect-to-virtual-machines-using-VNC-client.png 601w, https://www.ostechnix.com/wp-content/uploads/2020/07/Connect-to-virtual-machines-using-VNC-client-300x223.png 300w, https://www.ostechnix.com/wp-content/uploads/2020/07/Connect-to-virtual-machines-using-VNC-client-520x387.png 520w, https://www.ostechnix.com/wp-content/uploads/2020/07/Connect-to-virtual-machines-using-VNC-client-320x238.png 320w" data-sizes="(max-width: 601px) 100vw, 601px" /></a></p>
<p>The VNC application will now show you the guess OS installation window.</p>
<p><a href="https://www.ostechnix.com/wp-content/uploads/2020/07/Access-Virtual-machines-from-remote-systems-via-VNC-client.png" data-rel="lightbox-image-9" data-rl_title="" data-rl_caption="" title=""><img class="aligncenter size-full wp-image-24325" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://www.ostechnix.com/wp-content/uploads/2020/07/Access-Virtual-machines-from-remote-systems-via-VNC-client.png" alt="Access Virtual machines from remote systems via VNC client" width="1070" height="619" data-srcset="https://www.ostechnix.com/wp-content/uploads/2020/07/Access-Virtual-machines-from-remote-systems-via-VNC-client.png 1070w, https://www.ostechnix.com/wp-content/uploads/2020/07/Access-Virtual-machines-from-remote-systems-via-VNC-client-300x174.png 300w, https://www.ostechnix.com/wp-content/uploads/2020/07/Access-Virtual-machines-from-remote-systems-via-VNC-client-1024x592.png 1024w, https://www.ostechnix.com/wp-content/uploads/2020/07/Access-Virtual-machines-from-remote-systems-via-VNC-client-768x444.png 768w, https://www.ostechnix.com/wp-content/uploads/2020/07/Access-Virtual-machines-from-remote-systems-via-VNC-client-720x417.png 720w, https://www.ostechnix.com/wp-content/uploads/2020/07/Access-Virtual-machines-from-remote-systems-via-VNC-client-520x301.png 520w, https://www.ostechnix.com/wp-content/uploads/2020/07/Access-Virtual-machines-from-remote-systems-via-VNC-client-320x185.png 320w" data-sizes="(max-width: 1070px) 100vw, 1070px" /></a></p>
<p>Just continue the guest OS installation. Once the installation is done, close the VNC application window.</p>
<h4>List running VMs</h4>
<p>Run &#8220;virt list&#8221; command to see the list of running VMs:</p>
<pre>$ sudo virsh list</pre>
<p><strong>Sample output:</strong></p>
<pre> Id   Name           State
------------------------------
 2    Ubuntu-18.04   running</pre>
<p>As you can see, Ubuntu 18.04 VM is currently running and its ID is 2.</p>
<h4>Start VMs</h4>
<p>To start a VM, run:</p>
<pre>$ sudo virsh start Ubuntu-18.04</pre>
<p>You can also use the VM&#8217;s ID to start it:</p>
<pre>$ sudo virsh start 2</pre>
<h4>Restart VMs</h4>
<p>To restart a running VM, do:</p>
<pre>$ sudo virsh reboot Ubuntu-18.04</pre>
<p>Or,</p>
<pre>$ sudo reboot 2</pre>
<h4>Pause VMs</h4>
<p>To pause a running VM, do:</p>
<pre>$ sudo suspend Ubuntu-18.04</pre>
<p>Or,</p>
<pre>$ sudo suspend 2</pre>
<h4>Resume VMs</h4>
<p>To resume a suspended VM, do:</p>
<pre>$ sudo virsh resume Ubuntu-18.04</pre>
<p>Or,</p>
<pre>$ sudo resume 2</pre>
<h4>Shutdown VMs</h4>
<p>To power off a running VM, do:</p>
<pre>$ sudo virsh shutdown Ubuntu-18.04</pre>
<p>Or,</p>
<pre>$ sudo shutdown 2</pre>
<h4>Delete VMs</h4>
<p>To completely remove a VM, do:</p>
<pre>$ sudo virsh undefine Ubuntu-18.04</pre>
<pre>$ sudo virsh destroy Ubuntu-18.04</pre>
<p>Virsh has a lots of commands and options. To learn all of them, refer virsh help section:</p>
<pre>$ virsh --help</pre>
<p>Hope this helps.</p>
<p><strong>Resource:</strong></p>
<ul>
<li><a href="http://www.linux-kvm.org/page/Main_Page" target="_blank" rel="noopener noreferrer"><strong>KVM Website</strong></a></li>
</ul>
<div class="after-post-box">
<p style="text-align: center;"><strong style="color: #ef4423; font-size: 20px;">Thanks for stopping by! </strong></p>
<h4>Help us to help you:</h4>
<ul>
<li>Subscribe to our Email Newsletter : <strong><a title="Subscribe to our Email newsletter" href="http://feedburner.google.com/fb/a/mailverify?uri=ostechnix" target="_blank" rel="nofollow noopener noreferrer">Sign Up Now</a></strong></li>
<li>Support OSTechNix : <strong><a title="Donate Via PayPal" href="https://www.paypal.me/ostechnix" target="_blank" rel="nofollow noopener noreferrer">Donate Via PayPal</a></strong></li>
<li>Download free E-Books and Videos : <a href="http://ostechnix.tradepub.com/category/information-technology/1207/" target="_blank" rel="noopener noreferrer"><strong>OSTechNix on TradePub</strong></a></li>
<li>Connect with us: <a href="https://www.reddit.com/r/OSTechNix/" target="_blank" rel="noopener noreferrer"><strong>Reddit</strong></a> | <a href="https://www.facebook.com/ostechnix/" target="_blank" rel="noopener noreferrer"><strong>Facebook</strong></a> | <a href="https://twitter.com/ostechnix" target="_blank" rel="noopener noreferrer"><strong>Twitter</strong></a> | <strong> <a href="https://www.linkedin.com/in/ostechnix" target="_blank" rel="noopener noreferrer">LinkedIn</a> </strong>|<strong> <a href="http://feeds.feedburner.com/Ostechnix" target="_blank" rel="noopener noreferrer">RSS feeds</a></strong></li>
</ul>
<p style="text-align: center;"><strong style="color: #ef4423; font-size: 20px;">Have a Good day!!</strong></p>
</div>
<div class="widget_text awac-wrapper"><div class="widget_text awac widget custom_html-2"><div class="textwidget custom-html-widget"><script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle" style="display:block" data-ad-format="autorelaxed" data-ad-client="ca-pub-6701402139964678" data-ad-slot="4635513743"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div></div></div><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-reddit"><a rel="nofollow noopener noreferrer" data-shared="" class="share-reddit sd-button share-icon" href="https://www.ostechnix.com/install-and-configure-kvm-in-ubuntu-20-04-headless-server/?share=reddit" target="_blank" title="Click to share on Reddit"><span>Reddit</span></a></li><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-24293" class="share-twitter sd-button share-icon" href="https://www.ostechnix.com/install-and-configure-kvm-in-ubuntu-20-04-headless-server/?share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-24293" class="share-facebook sd-button share-icon" href="https://www.ostechnix.com/install-and-configure-kvm-in-ubuntu-20-04-headless-server/?share=facebook" target="_blank" title="Click to share on Facebook"><span>Facebook</span></a></li><li class="share-linkedin"><a rel="nofollow noopener noreferrer" data-shared="sharing-linkedin-24293" class="share-linkedin sd-button share-icon" href="https://www.ostechnix.com/install-and-configure-kvm-in-ubuntu-20-04-headless-server/?share=linkedin" target="_blank" title="Click to share on LinkedIn"><span>LinkedIn</span></a></li><li class="share-jetpack-whatsapp"><a rel="nofollow noopener noreferrer" data-shared="" class="share-jetpack-whatsapp sd-button share-icon" href="https://www.ostechnix.com/install-and-configure-kvm-in-ubuntu-20-04-headless-server/?share=jetpack-whatsapp" target="_blank" title="Click to share on WhatsApp"><span>WhatsApp</span></a></li><li class="share-telegram"><a rel="nofollow noopener noreferrer" data-shared="" class="share-telegram sd-button share-icon" href="https://www.ostechnix.com/install-and-configure-kvm-in-ubuntu-20-04-headless-server/?share=telegram" target="_blank" title="Click to share on Telegram"><span>Telegram</span></a></li><li class="share-pocket"><a rel="nofollow noopener noreferrer" data-shared="" class="share-pocket sd-button share-icon" href="https://www.ostechnix.com/install-and-configure-kvm-in-ubuntu-20-04-headless-server/?share=pocket" target="_blank" title="Click to share on Pocket"><span>Pocket</span></a></li><li class="share-print"><a rel="nofollow noopener noreferrer" data-shared="" class="share-print sd-button share-icon" href="https://www.ostechnix.com/install-and-configure-kvm-in-ubuntu-20-04-headless-server/#print" target="_blank" title="Click to print"><span>Print</span></a></li><li class="share-end"></li></ul></div></div></div> <nav class="pagination group">
</nav>
</div>
<div class="sharrre-container no-counter">
<span>Share</span>
<div id="twitter" data-url="https://www.ostechnix.com/install-and-configure-kvm-in-ubuntu-20-04-headless-server/" data-text="Install And Configure KVM In Ubuntu 20.04 Headless Server" data-title="Tweet"><a class="box" href="#"><div class="count" href="#"><i class="fas fa-plus"></i></div><div class="share"><i class="fab fa-twitter"></i></div></a></div>
<div id="facebook" data-url="https://www.ostechnix.com/install-and-configure-kvm-in-ubuntu-20-04-headless-server/" data-text="Install And Configure KVM In Ubuntu 20.04 Headless Server" data-title="Like"></div>
<div id="linkedin" data-url="https://www.ostechnix.com/install-and-configure-kvm-in-ubuntu-20-04-headless-server/" data-text="Install And Configure KVM In Ubuntu 20.04 Headless Server" data-title="Publish on Linked In"></div>
</div>
<style type="text/css"></style>
<script type="text/javascript">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</script>
<div class="clear"></div>
</div>
</div>
</article>
<div class="clear"></div>
<p class="post-tags"><span>Tags:</span> <a href="https://www.ostechnix.com/tag/kernel-based-virtual-machine/" rel="tag">Kernel-based virtual machine</a><a href="https://www.ostechnix.com/tag/kvm/" rel="tag">KVM</a><a href="https://www.ostechnix.com/tag/linux/" rel="tag">Linux</a><a href="https://www.ostechnix.com/tag/linux-kernel/" rel="tag">Linux Kernel</a><a href="https://www.ostechnix.com/tag/open-source/" rel="tag">Open source</a><a href="https://www.ostechnix.com/tag/uubntu/" rel="tag">Uubntu</a><a href="https://www.ostechnix.com/tag/virtualization/" rel="tag">Virtualization</a></p>
<ul class="post-nav group">
<li class="next"></li>
<li class="previous"><a href="https://www.ostechnix.com/how-to-find-best-ubuntu-apt-repository-mirror/" rel="prev"><i class="fas fa-chevron-left"></i><strong>Previous story</strong> <span>How To Find Best Ubuntu APT Repository Mirror</span></a></li>
</ul>
<script type="text/javascript">
        jQuery( function($) {
            var _fireWhenCzrAppReady = function() {
              czrapp.proRelPostsRendered = $.Deferred();
              var waypoint = new Waypoint({
                  element: document.getElementById('pro-related-posts-wrapper'),
                  handler: function(direction) {
                        if ( 'pending' == czrapp.proRelPostsRendered.state() ) {
                              var $wrap = $('#pro-related-posts-wrapper');
                              $wrap.addClass('loading');
                              czrapp.doAjax( {
                                      action: "ha_inject_pro_related",
                                      // => Always get the option from the $_POSTED data in ajax
                                      related_post_id : 24293,
                                      pro_related_posts_opt : [],
                                      free_related_posts_opt : "tags",
                                      layout_class : "col-2cl"
                                  } ).done( function( r ) {
                                        if ( r && r.data && r.data.html ) {
                                            if ( 'pending' == czrapp.proRelPostsRendered.state() ) {
                                                $.when( $('#pro-related-posts-wrapper').append( r.data.html ) ).done( function() {
                                                      czrapp.proRelPostsRendered.resolve();
                                                      $wrap.find('.czr-css-loader').css('opacity', 0);
                                                      _.delay( function() {
                                                            $wrap.removeClass('loading').addClass('loaded');
                                                      }, 800 );
                                                });
                                            }
                                        }
                                  });
                        }
                  },
                  offset: '110%'
              });
          };//_fireWhenCzrAppReady

          if ( window.czrapp && czrapp.methods && czrapp.methods.ProHeaderSlid ) {
            _fireWhenCzrAppReady()
          } else {
            document.addEventListener('czrapp-is-ready', _fireWhenCzrAppReady );
          }
        });//jQuery()
    </script>
<div id="pro-related-posts-wrapper"><div class="czr-css-loader czr-mr-loader dark"><div></div><div></div><div></div></div></div>
<section id="comments" class="themeform">

<div id="respond" class="comment-respond">
<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/install-and-configure-kvm-in-ubuntu-20-04-headless-server/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://www.ostechnix.com/wp-comments-post.php" method="post" id="commentform" class="comment-form"><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required='required' /></p>
<p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="text" value="" size="30" maxlength="100" aria-describedby="email-notes" required='required' /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="text" value="" size="30" maxlength="200" /></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='24293' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="d72fb2302e" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="19" /></p></form> </div>
<p class="akismet_comment_form_privacy_notice">This site uses Akismet to reduce spam. <a href="https://akismet.com/privacy/" target="_blank" rel="nofollow noopener">Learn how your comment data is processed</a>.</p>
</section> </div>
</section>
<div class="sidebar s1 collapsed" data-position="right" data-layout="col-2cl" data-sb-id="s1">
<button class="sidebar-toggle" title="Expand Sidebar"><i class="fas sidebar-toggle-arrows"></i></button>
<div class="sidebar-content">
<div class="sidebar-top group">
<p>Follow:</p> <ul class="social-links"><li><a rel="nofollow noopener noreferrer" class="social-tooltip" title="Follow us on Reddit-square" aria-label="Follow us on Reddit-square" href="https://www.reddit.com/r/OSTechNix/" target="_blank"><i class="fab fa-reddit-square"></i></a></li><li><a rel="nofollow noopener noreferrer" class="social-tooltip" title="Follow us on Facebook-square" aria-label="Follow us on Facebook-square" href="https://www.facebook.com/ostechnix/" target="_blank" style="color:rgba(255,255,255,0.7)"><i class="fab fa-facebook-square"></i></a></li><li><a rel="nofollow noopener noreferrer" class="social-tooltip" title="Follow us on Twitter-square" aria-label="Follow us on Twitter-square" href="https://twitter.com/ostechnix" target="_blank" style="color:rgba(255,255,255,0.7)"><i class="fab fa-twitter-square"></i></a></li><li><a rel="nofollow noopener noreferrer" class="social-tooltip" title="Follow us on Linkedin-square" aria-label="Follow us on Linkedin-square" href="https://in.linkedin.com/in/ostechnix" target="_blank" style="color:rgba(255,255,255,0.7)"><i class="fab fa-linkedin"></i></a></li><li><a rel="nofollow noopener noreferrer" class="social-tooltip" title="Follow us on Rss" aria-label="Follow us on Rss" href="http://feeds.feedburner.com/Ostechnix" target="_blank" style="color:rgba(255,255,255,0.7)"><i class="fas fa-rss"></i></a></li></ul> </div>
<div id="custom_html-4" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-6701402139964678" data-ad-slot="3689433741" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div></div><div id="custom_html-6" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><script>
  (function() {
    var cx = '008602152458925632792:qnuzfwvz-gy';
    var gcse = document.createElement('script');
    gcse.type = 'text/javascript';
    gcse.async = true;
    gcse.src = 'https://cse.google.com/cse.js?cx=' + cx;
    var s = document.getElementsByTagName('script')[0];
    s.parentNode.insertBefore(gcse, s);
  })();
</script>
<gcse:searchbox-only></gcse:searchbox-only></div></div><div id="responsive_lightbox_image_widget-2" class="widget rl-image-widget"><h3 class="widget-title">Get Your Free eBook</h3><a href="https://ostechnix.tradepub.com/free/w_howt04/prgm.cgi" class="rl-image-widget-link"><img class="rl-image-widget-image" src="https://www.ostechnix.com/wp-content/uploads/2020/02/Essential-Linux-Toolkit-ostechnix-768x993.jpg" width="100%" height="auto" title="Essential Linux Toolkit - ostechnix" alt="Free Ebook - Essential Linux Toolkit Free by Ostechnix" style="margin-left: auto; margin-right: auto; display: block;" /></a><div class="rl-image-widget-text" style="text-align: center; display: block;"></div></div><div id="custom_html-5" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-6701402139964678" data-ad-slot="4424653341" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div></div>
</div>
</div>
﻿ </div>
</div>
</div>
</div>
<footer id="footer">
<section class="container" id="footer-widgets">
<div class="container-inner">
<div class="pad group">
<div class="footer-widget-1 grid one-third ">
<div id="text-5" class="widget widget_text"><h3 class="widget-title">Email Newsletter</h3> <div class="textwidget"><form style="border:3px solid #ccc;border-color:#a8a9ad;padding:10px;text-align:center; font-weight:bold; font-size:18px;line-height: 29px;background-color: #00AEEF; color: #FFFFFF;
" action="https://feedburner.google.com/fb/a/mailverify" method="post" target="popupwindow" onsubmit="window.open('https://feedburner.google.com/fb/a/mailverify?uri=Ostechnix', 'popupwindow', 'scrollbars=yes,width=550,height=520');return true"><p>Subscribe to our mailing list</p><p><input type="text" style="width:240px" name="email" /></p><input type="hidden" value="Ostechnix" name="uri" /><input type="hidden" name="loc" value="en_US" /><input type="submit" value="Sign Up Now" /><p>We respect your privacy</p></form></div>
</div> </div>
<div class="footer-widget-2 grid one-third ">
<div id="archives-4" class="widget widget_archive"><h3 class="widget-title">Blog Archive</h3> <label class="screen-reader-text" for="archives-dropdown-4">Blog Archive</label>
<select id="archives-dropdown-4" name="archive-dropdown">
<option value="">Select Month</option>
<option value='https://www.ostechnix.com/2020/07/'> July 2020 &nbsp;(2)</option>
<option value='https://www.ostechnix.com/2020/06/'> June 2020 &nbsp;(25)</option>
<option value='https://www.ostechnix.com/2020/05/'> May 2020 &nbsp;(27)</option>
<option value='https://www.ostechnix.com/2020/04/'> April 2020 &nbsp;(32)</option>
<option value='https://www.ostechnix.com/2020/03/'> March 2020 &nbsp;(21)</option>
<option value='https://www.ostechnix.com/2020/02/'> February 2020 &nbsp;(19)</option>
<option value='https://www.ostechnix.com/2020/01/'> January 2020 &nbsp;(22)</option>
<option value='https://www.ostechnix.com/2019/12/'> December 2019 &nbsp;(13)</option>
<option value='https://www.ostechnix.com/2019/11/'> November 2019 &nbsp;(9)</option>
<option value='https://www.ostechnix.com/2019/10/'> October 2019 &nbsp;(10)</option>
<option value='https://www.ostechnix.com/2019/09/'> September 2019 &nbsp;(11)</option>
<option value='https://www.ostechnix.com/2019/08/'> August 2019 &nbsp;(18)</option>
<option value='https://www.ostechnix.com/2019/07/'> July 2019 &nbsp;(18)</option>
<option value='https://www.ostechnix.com/2019/06/'> June 2019 &nbsp;(10)</option>
<option value='https://www.ostechnix.com/2019/05/'> May 2019 &nbsp;(13)</option>
<option value='https://www.ostechnix.com/2019/04/'> April 2019 &nbsp;(12)</option>
<option value='https://www.ostechnix.com/2019/03/'> March 2019 &nbsp;(9)</option>
<option value='https://www.ostechnix.com/2019/02/'> February 2019 &nbsp;(10)</option>
<option value='https://www.ostechnix.com/2019/01/'> January 2019 &nbsp;(9)</option>
<option value='https://www.ostechnix.com/2018/12/'> December 2018 &nbsp;(6)</option>
<option value='https://www.ostechnix.com/2018/11/'> November 2018 &nbsp;(12)</option>
<option value='https://www.ostechnix.com/2018/10/'> October 2018 &nbsp;(19)</option>
<option value='https://www.ostechnix.com/2018/09/'> September 2018 &nbsp;(20)</option>
<option value='https://www.ostechnix.com/2018/08/'> August 2018 &nbsp;(18)</option>
<option value='https://www.ostechnix.com/2018/07/'> July 2018 &nbsp;(15)</option>
<option value='https://www.ostechnix.com/2018/06/'> June 2018 &nbsp;(15)</option>
<option value='https://www.ostechnix.com/2018/05/'> May 2018 &nbsp;(16)</option>
<option value='https://www.ostechnix.com/2018/04/'> April 2018 &nbsp;(21)</option>
<option value='https://www.ostechnix.com/2018/03/'> March 2018 &nbsp;(23)</option>
<option value='https://www.ostechnix.com/2018/02/'> February 2018 &nbsp;(16)</option>
<option value='https://www.ostechnix.com/2018/01/'> January 2018 &nbsp;(19)</option>
<option value='https://www.ostechnix.com/2017/12/'> December 2017 &nbsp;(23)</option>
<option value='https://www.ostechnix.com/2017/11/'> November 2017 &nbsp;(22)</option>
<option value='https://www.ostechnix.com/2017/10/'> October 2017 &nbsp;(17)</option>
<option value='https://www.ostechnix.com/2017/09/'> September 2017 &nbsp;(25)</option>
<option value='https://www.ostechnix.com/2017/08/'> August 2017 &nbsp;(24)</option>
<option value='https://www.ostechnix.com/2017/07/'> July 2017 &nbsp;(23)</option>
<option value='https://www.ostechnix.com/2017/06/'> June 2017 &nbsp;(16)</option>
<option value='https://www.ostechnix.com/2017/05/'> May 2017 &nbsp;(23)</option>
<option value='https://www.ostechnix.com/2017/04/'> April 2017 &nbsp;(25)</option>
<option value='https://www.ostechnix.com/2017/03/'> March 2017 &nbsp;(33)</option>
<option value='https://www.ostechnix.com/2017/02/'> February 2017 &nbsp;(34)</option>
<option value='https://www.ostechnix.com/2017/01/'> January 2017 &nbsp;(25)</option>
<option value='https://www.ostechnix.com/2016/12/'> December 2016 &nbsp;(20)</option>
<option value='https://www.ostechnix.com/2016/11/'> November 2016 &nbsp;(15)</option>
<option value='https://www.ostechnix.com/2016/10/'> October 2016 &nbsp;(10)</option>
<option value='https://www.ostechnix.com/2016/09/'> September 2016 &nbsp;(12)</option>
<option value='https://www.ostechnix.com/2016/08/'> August 2016 &nbsp;(23)</option>
<option value='https://www.ostechnix.com/2016/07/'> July 2016 &nbsp;(6)</option>
<option value='https://www.ostechnix.com/2016/06/'> June 2016 &nbsp;(15)</option>
<option value='https://www.ostechnix.com/2016/05/'> May 2016 &nbsp;(13)</option>
<option value='https://www.ostechnix.com/2016/04/'> April 2016 &nbsp;(20)</option>
<option value='https://www.ostechnix.com/2016/03/'> March 2016 &nbsp;(26)</option>
<option value='https://www.ostechnix.com/2016/02/'> February 2016 &nbsp;(22)</option>
<option value='https://www.ostechnix.com/2016/01/'> January 2016 &nbsp;(4)</option>
<option value='https://www.ostechnix.com/2015/11/'> November 2015 &nbsp;(1)</option>
<option value='https://www.ostechnix.com/2015/10/'> October 2015 &nbsp;(5)</option>
<option value='https://www.ostechnix.com/2015/09/'> September 2015 &nbsp;(9)</option>
<option value='https://www.ostechnix.com/2015/08/'> August 2015 &nbsp;(1)</option>
<option value='https://www.ostechnix.com/2013/12/'> December 2013 &nbsp;(3)</option>
<option value='https://www.ostechnix.com/2013/04/'> April 2013 &nbsp;(1)</option>
<option value='https://www.ostechnix.com/2013/03/'> March 2013 &nbsp;(2)</option>
<option value='https://www.ostechnix.com/2013/02/'> February 2013 &nbsp;(3)</option>
<option value='https://www.ostechnix.com/2013/01/'> January 2013 &nbsp;(10)</option>
<option value='https://www.ostechnix.com/2012/12/'> December 2012 &nbsp;(6)</option>
<option value='https://www.ostechnix.com/2012/11/'> November 2012 &nbsp;(1)</option>
</select>
<script type="text/javascript">
/* <![CDATA[ */
(function() {
	var dropdown = document.getElementById( "archives-dropdown-4" );
	function onSelectChange() {
		if ( dropdown.options[ dropdown.selectedIndex ].value !== '' ) {
			document.location.href = this.options[ this.selectedIndex ].value;
		}
	}
	dropdown.onchange = onSelectChange;
})();
/* ]]> */
</script>
</div> </div>
<div class="footer-widget-3 grid one-third last">
<div id="pages-5" class="widget widget_pages"><h3 class="widget-title">Who we are</h3> <ul>
<li class="page_item page-item-676"><a href="https://www.ostechnix.com/about/">About</a></li>
<li class="page_item page-item-660"><a href="https://www.ostechnix.com/contact-us/">Contact Us</a></li>
<li class="page_item page-item-7410"><a href="https://www.ostechnix.com/donate/">Donate</a></li>
<li class="page_item page-item-1103"><a href="https://www.ostechnix.com/privacy-policy/">Privacy Policy</a></li>
<li class="page_item page-item-1096"><a href="https://www.ostechnix.com/terms-and-conditions/">Terms and Conditions</a></li>
</ul>
</div> </div>
</div>
</div>
</section>
<section class="container" id="footer-bottom">
<div class="container-inner">
<a id="back-to-top" href="#"><i class="fa fa-angle-up"></i></a>
<div class="pad group">
<div class="grid one-half">
<img id="footer-logo" src="https://www.ostechnix.com/wp-content/uploads/2016/10/cropped-OSTechNix_280915-01-1.png" alt="">
<div id="copyright">
<p>OSTechNix &copy; 2020. All Rights Reserved.</p>
</div>
<div id="credit">
<p>This site is licensed under <a href="http://creativecommons.org/licenses/by-nc/4.0/" rel="nofollow">CC BY-NC 4.0</a>. </div>
</div>
<div class="grid one-half last">
<ul class="social-links"><li><a rel="nofollow noopener noreferrer" class="social-tooltip" title="Follow us on Reddit-square" aria-label="Follow us on Reddit-square" href="https://www.reddit.com/r/OSTechNix/" target="_blank"><i class="fab fa-reddit-square"></i></a></li><li><a rel="nofollow noopener noreferrer" class="social-tooltip" title="Follow us on Facebook-square" aria-label="Follow us on Facebook-square" href="https://www.facebook.com/ostechnix/" target="_blank" style="color:rgba(255,255,255,0.7)"><i class="fab fa-facebook-square"></i></a></li><li><a rel="nofollow noopener noreferrer" class="social-tooltip" title="Follow us on Twitter-square" aria-label="Follow us on Twitter-square" href="https://twitter.com/ostechnix" target="_blank" style="color:rgba(255,255,255,0.7)"><i class="fab fa-twitter-square"></i></a></li><li><a rel="nofollow noopener noreferrer" class="social-tooltip" title="Follow us on Linkedin-square" aria-label="Follow us on Linkedin-square" href="https://in.linkedin.com/in/ostechnix" target="_blank" style="color:rgba(255,255,255,0.7)"><i class="fab fa-linkedin"></i></a></li><li><a rel="nofollow noopener noreferrer" class="social-tooltip" title="Follow us on Rss" aria-label="Follow us on Rss" href="http://feeds.feedburner.com/Ostechnix" target="_blank" style="color:rgba(255,255,255,0.7)"><i class="fas fa-rss"></i></a></li></ul> </div>
</div>
</div>
</section>
</footer>
</div>
<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/www.ostechnix.com\/install-and-configure-kvm-in-ubuntu-20-04-headless-server\/":24293};
	</script>
<script type='text/javascript'>
/* <![CDATA[ */
var WfcFrontParams = {"effectsAndIconsSelectorCandidates":[],"wfcOptions":null};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.ostechnix.com/wp-content/themes/hueman-pro/addons/pro/wfc/front/assets/js/font-customizer-front.min.js?ver=3.1.1'></script>
<script type='text/javascript' src='https://www.ostechnix.com/wp-content/themes/hueman-pro/addons/assets/front/js/jQuerySharrre.min.js?ver=5.4.2'></script>
<script type='text/javascript' src='https://www.ostechnix.com/wp-includes/js/underscore.min.js?ver=1.8.3'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var HUParams = {"_disabled":[],"SmoothScroll":{"Enabled":false,"Options":{"touchpadSupport":false}},"centerAllImg":"1","timerOnScrollAllBrowsers":"1","extLinksStyle":"1","extLinksTargetExt":"1","extLinksSkipSelectors":{"classes":["btn","button"],"ids":[]},"imgSmartLoadEnabled":"1","imgSmartLoadOpts":{"parentSelectors":[".container .content",".container .sidebar","#footer","#header-widgets"],"opts":{"excludeImg":[".tc-holder-img"],"fadeIn_options":100,"threshold":0}},"goldenRatio":"1.618","gridGoldenRatioLimit":"350","sbStickyUserSettings":{"desktop":false,"mobile":false},"sidebarOneWidth":"340","sidebarTwoWidth":"260","isWPMobile":"","menuStickyUserSettings":{"desktop":"stick_up","mobile":"stick_up"},"mobileSubmenuExpandOnClick":"","submenuTogglerIcon":"<i class=\"fas fa-angle-down\"><\/i>","isDevMode":"","ajaxUrl":"https:\/\/www.ostechnix.com\/?huajax=1","frontNonce":{"id":"HuFrontNonce","handle":"502158b8f5"},"isWelcomeNoteOn":"","welcomeContent":"","i18n":{"collapsibleExpand":"Expand","collapsibleCollapse":"Collapse"},"deferFontAwesome":"1","fontAwesomeUrl":"https:\/\/www.ostechnix.com\/wp-content\/themes\/hueman-pro\/assets\/front\/css\/font-awesome.min.css?1.2.13","mainScriptUrl":"https:\/\/www.ostechnix.com\/wp-content\/themes\/hueman-pro\/assets\/front\/js\/scripts.min.js?1.2.13","flexSliderNeeded":"","flexSliderOptions":{"is_rtl":false,"has_touch_support":true,"is_slideshow":true,"slideshow_speed":5000},"fitTextMap":{"single_post_title":{"selectors":".single h1.entry-title","minEm":1.375,"maxEm":2.62000000000000010658141036401502788066864013671875},"page_title":{"selectors":".page-title h1","minEm":1,"maxEm":1.3000000000000000444089209850062616169452667236328125},"home_page_title":{"selectors":".home .page-title","minEm":1,"maxEm":1.1999999999999999555910790149937383830547332763671875,"compression":2.5},"post_titles":{"selectors":".blog .post-title, .archive .post-title","minEm":1.375,"maxEm":1.475000000000000088817841970012523233890533447265625},"featured_post_titles":{"selectors":".featured .post-title","minEm":1.375,"maxEm":2.125},"comments":{"selectors":".commentlist li","minEm":0.8125,"maxEm":0.93000000000000004884981308350688777863979339599609375,"compression":2.5},"entry":{"selectors":".entry","minEm":0.9375,"maxEm":1.125,"compression":2.5},"content_h1":{"selectors":".entry h1, .woocommerce div.product h1.product_title","minEm":1.7578125,"maxEm":2.671875},"content_h2":{"selectors":".entry h2","minEm":1.5234375,"maxEm":2.390625},"content_h3":{"selectors":".entry h3","minEm":1.40625,"maxEm":1.96875},"content_h4":{"selectors":".entry h4","minEm":1.2890625,"maxEm":1.6875},"content_h5":{"selectors":".entry h5","minEm":1.0546875,"maxEm":1.40625},"content_h6":{"selectors":".entry h6","minEm":0.9375,"maxEm":1.265625,"compression":2.5}},"userFontSize":"18","fitTextCompression":"1.5"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.ostechnix.com/wp-content/themes/hueman-pro/assets/front/js/hu-init.min.js?ver=1.2.13'></script>
<script type='text/javascript' src='https://www.ostechnix.com/wp-includes/js/comment-reply.min.js?ver=5.4.2'></script>
<script type='text/javascript' src='https://www.ostechnix.com/wp-content/themes/hueman-pro/addons/pro/header/assets/front/vendors/flickity.min.js?ver=1.2.13'></script>
<script type='text/javascript' src='https://www.ostechnix.com/wp-includes/js/wp-embed.min.js?ver=5.4.2'></script>
<script async="async" type='text/javascript' src='https://www.ostechnix.com/wp-content/plugins/akismet/_inc/form.js?ver=4.1.6'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.ostechnix.com/wp-content/plugins/jetpack/_inc/build/sharedaddy/sharing.min.js?ver=8.6.1'></script>
<script type='text/javascript'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-linkedin', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomlinkedin', 'menubar=1,resizable=1,width=580,height=450' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-telegram', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtelegram', 'menubar=1,resizable=1,width=450,height=450' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-pocket', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcompocket', 'menubar=1,resizable=1,width=450,height=450' );
				return false;
			});
</script>
<!--[if lt IE 9]>
<script src="https://www.ostechnix.com/wp-content/themes/hueman-pro/assets/front/js/ie/respond.js"></script>
<![endif]-->
<script type='text/javascript' src='https://stats.wp.com/e-202027.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:8.6.1',blog:'84551477',post:'24293',tz:'5.5',srv:'www.ostechnix.com'} ]);
	_stq.push([ 'clickTrackerInit', '84551477', '24293' ]);
</script>
</body>
</html>
